aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2009-07-15 13:53:21 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2009-07-15 13:53:21 +0000
commit10a39a1182d544a8cc8ea322b3c1c5f0dd80735d (patch)
tree602a2d1444746e7c77dcb32acdbe9fc6c97f63be /www/nginx
parent02cd8b6e648c25baa6e7161675ba609e5baed3f6 (diff)
downloadports-10a39a1182d544a8cc8ea322b3c1c5f0dd80735d.tar.gz
ports-10a39a1182d544a8cc8ea322b3c1c5f0dd80735d.zip
Illuminate and enable by default cache module.
Fix whitespaces. Do not bump PORTREVISION cause no functionally or building changes (cache module was enabled implicitly).
Notes
Notes: svn path=/head/; revision=237879
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 58ae03457316..cb2d1465354d 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -23,6 +23,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_MODULE "Enable HTTP module" on \
HTTP_ACCESSKEY_MODULE "Enable http_accesskey module" off \
HTTP_ADDITION_MODULE "Enable http_addition module" off \
+ HTTP_CACHE_MODULE "Enable http_cache module" on \
HTTP_DAV_MODULE "Enable http_webdav module" off \
HTTP_EVAL_MODULE "Enable eval module" off \
HTTP_FANCYINDEX_MODULE "Enable http_fancyindex module" off \
@@ -123,6 +124,10 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-accesskey-${NGINX_ACCESSKEY_MODULE_
CONFIGURE_ARGS+=--with-http_addition_module
.endif
+.if defined(WITHOUT_HTTP_CACHE_MODULE)
+CONFIGURE_ARGS+=--without-http-cache
+.endif
+
.if defined(WITH_HTTP_DAV_MODULE)
CONFIGURE_ARGS+=--with-http_dav_module
.endif
@@ -139,7 +144,7 @@ NGINX_FANCYINDEX_MODULE_VERSION= 0.1b5
MASTER_SITES+= http://furi-ku.org/nginx/fancyindex/:fancyindex
MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:fancyindex/}
MASTER_SITE_SUBDIR+= osa/:fancyindex
-DISTFILES+= nginx-fancyindex-${NGINX_FANCYINDEX_MODULE_VERSION:S/b/_beta/}.tar.bz2:fancyindex
+DISTFILES+= nginx-fancyindex-${NGINX_FANCYINDEX_MODULE_VERSION:S/b/_beta/}.tar.bz2:fancyindex
CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-fancyindex-${NGINX_FANCYINDEX_MODULE_VERSION:S/b/_beta/}
.endif