aboutsummaryrefslogtreecommitdiff
path: root/www/nostromo
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-04-16 08:45:27 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-04-16 08:45:27 +0000
commit0e5b45796e89139f86d24abe0e53df0e2f4bd7b7 (patch)
tree794ec3ce90945406ae81c9b05af7336b264ac47f /www/nostromo
parenta1e8387aef238107ec7c61b0bf6b4a771df78161 (diff)
downloadports-0e5b45796e89139f86d24abe0e53df0e2f4bd7b7.tar.gz
ports-0e5b45796e89139f86d24abe0e53df0e2f4bd7b7.zip
Nostromo aka nhttpd is a simple, fast and secure HTTP server. It
runs as a single process, handling connections with select(2). For CGIs and directory listing it does fork(2). The minimum of HTTP/1.1 and CGI/1.1 are implemented. Also supported are: chroot, setuid, basic authentication, SSL, IPv6, custom responses, aliases, and virtual hosts. The access log is written in standard CLF format. AUTHOR: Glocker Marcus <marcus@nazgul.ch> WWW: http://www.nazgul.ch/dev_nostromo.html PR: ports/155919 Submitted by: Adrian Steinmann <ast@marabu.ch>
Notes
Notes: svn path=/head/; revision=272789
Diffstat (limited to 'www/nostromo')
-rw-r--r--www/nostromo/Makefile55
-rw-r--r--www/nostromo/distinfo2
-rw-r--r--www/nostromo/files/nostromo.sh.in27
-rw-r--r--www/nostromo/files/patch-src-libmy-Makefile15
-rw-r--r--www/nostromo/files/patch-src-nhttpd-Makefile25
-rw-r--r--www/nostromo/files/patch-src-tools-Makefile23
-rw-r--r--www/nostromo/pkg-descr9
-rw-r--r--www/nostromo/pkg-plist15
8 files changed, 171 insertions, 0 deletions
diff --git a/www/nostromo/Makefile b/www/nostromo/Makefile
new file mode 100644
index 000000000000..3c63cb7c3f30
--- /dev/null
+++ b/www/nostromo/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: nostromo
+# Date created: 20 Mar 2011
+# Whom: Adrian Steinmann <ast@marabu.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nostromo
+PORTVERSION= 1.9.4
+CATEGORIES= www ipv6
+MASTER_SITES= http://www.nazgul.ch/dev/
+
+MAINTAINER= ast@marabu.ch
+COMMENT= A fast, secure HTTP/1.1 CGI/1.1 SSL IPv4/IPv6 webserver
+
+LICENSE= BSD
+
+NOSTROMO_DIR?= ${PREFIX}/nostromo
+NOSTROMO_LOGDIR?= ${NOSTROMO_DIR}/logs
+NOSTROMO_LOGDIR_PERMS?= 0775
+
+USE_RC_SUBR= nostromo.sh
+
+MAN8= nhttpd.8
+
+MAKE_ENV?= MAKEOBJDIR=. PREFIX=${PREFIX} NOSTROMO_DIR=${NOSTROMO_DIR}
+
+post-extract:
+ @${REINPLACE_CMD} -e "s@/var/nostromo@${NOSTROMO_DIR}@g" \
+ ${WRKSRC}/src/nhttpd/nhttpd.8
+ @${REINPLACE_CMD} -e "s@/var/nostromo@${NOSTROMO_DIR}@g" \
+ ${WRKSRC}/src/nhttpd/main.c
+ @${REINPLACE_CMD} -e "s@/var/nostromo@${NOSTROMO_DIR}@g" \
+ ${WRKSRC}/conf/nhttpd.conf-dist
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/src/nhttpd/nhttpd ${PREFIX}/sbin
+ @${INSTALL_SCRIPT} ${WRKSRC}/src/tools/crypt ${PREFIX}/sbin
+ @${INSTALL_MAN} ${WRKSRC}/src/nhttpd/nhttpd.8 ${PREFIX}/man/man8
+ @${MKDIR} ${NOSTROMO_DIR}
+ @${MKDIR} ${NOSTROMO_DIR}/conf
+ @${MKDIR} -m ${NOSTROMO_LOGDIR_PERMS} -p ${NOSTROMO_LOGDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/mimes ${NOSTROMO_DIR}/conf
+ @${INSTALL_DATA} ${WRKSRC}/conf/nhttpd.conf-dist ${NOSTROMO_DIR}/conf
+ @${MKDIR} ${NOSTROMO_DIR}/htdocs
+ @${INSTALL_DATA} ${WRKSRC}/htdocs/index.html ${NOSTROMO_DIR}/htdocs
+ @${INSTALL_DATA} ${WRKSRC}/htdocs/nostromo.gif ${NOSTROMO_DIR}/htdocs
+ @${MKDIR} ${NOSTROMO_DIR}/htdocs/cgi-bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/htdocs/cgi-bin/printenv \
+ ${NOSTROMO_DIR}/htdocs/cgi-bin
+ @${MKDIR} ${NOSTROMO_DIR}/icons
+ @${INSTALL_DATA} ${WRKSRC}/icons/dir.gif ${NOSTROMO_DIR}/icons
+ @${INSTALL_DATA} ${WRKSRC}/icons/file.gif ${NOSTROMO_DIR}/icons
+
+.include <bsd.port.mk>
diff --git a/www/nostromo/distinfo b/www/nostromo/distinfo
new file mode 100644
index 000000000000..4a54dde02003
--- /dev/null
+++ b/www/nostromo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nostromo-1.9.4.tar.gz) = dbdd71fcfdefb9c862bdabd8eae2533293a111848dd9a92ee151465e37b33194
+SIZE (nostromo-1.9.4.tar.gz) = 47724
diff --git a/www/nostromo/files/nostromo.sh.in b/www/nostromo/files/nostromo.sh.in
new file mode 100644
index 000000000000..65dd114f31e5
--- /dev/null
+++ b/www/nostromo/files/nostromo.sh.in
@@ -0,0 +1,27 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: nostromo
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+
+#
+# Add the following line to /etc/rc.conf to enable nostromo:
+#
+# nostromo_enable="YES"
+#
+
+. /etc/rc.subr
+
+name=nostromo
+rcvar=`set_rcvar`
+
+command=/usr/local/sbin/nhttpd
+
+nostromo_enable=${nostromo_enable:-"NO"}
+nostromo_flags=${nostromo_flags:-"-c /usr/local/nostromo/conf/nhttpd.conf"}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/www/nostromo/files/patch-src-libmy-Makefile b/www/nostromo/files/patch-src-libmy-Makefile
new file mode 100644
index 000000000000..a022be048e2b
--- /dev/null
+++ b/www/nostromo/files/patch-src-libmy-Makefile
@@ -0,0 +1,15 @@
+--- src/libmy/Makefile.orig 2011-03-20 11:23:57.000000000 +0100
++++ src/libmy/Makefile 2011-03-20 11:24:15.000000000 +0100
+@@ -2,9 +2,9 @@
+ SRCS= strcutl.c strcutw.c strcuts.c strcuti.c strcutf.c flog.c flogd.c fparse.c strlower.c strb64d.c
+
+ CFLAGS+= -Wall -Werror -Wstrict-prototypes
+-NOMAN= 1
+-NOPIC= 1
+-NOPROFILE= 1
++NO_MAN= 1
++NO_PIC= 1
++NO_PROFILE= 1
+
+ PIPE= -pipe
+
diff --git a/www/nostromo/files/patch-src-nhttpd-Makefile b/www/nostromo/files/patch-src-nhttpd-Makefile
new file mode 100644
index 000000000000..49412a9a4354
--- /dev/null
+++ b/www/nostromo/files/patch-src-nhttpd-Makefile
@@ -0,0 +1,25 @@
+--- src/nhttpd/Makefile.orig 2011-03-20 22:39:18.000000000 +0100
++++ src/nhttpd/Makefile 2011-03-20 22:39:54.000000000 +0100
+@@ -10,18 +10,21 @@
+
+ BINOWN= root
+ BINMOD= 0555
+-BINDIR= /usr/local/sbin
++BINDIR= ${PREFIX}/sbin
+
+ OS!= uname -s
+
+ LDADD+= -lssl -lcrypto
++
+ .if ${OS} == "FreeBSD"
+ LDADD+= -lcrypt
+ MANBUILDCAT= yes
+ .endif
++
+ .if ${OS} == "NetBSD"
+ LDADD+= -lcrypt
+ .endif
++
+ .if ${OS} == "Darwin"
+ MAN8= nhttpd.8
+ .endif
diff --git a/www/nostromo/files/patch-src-tools-Makefile b/www/nostromo/files/patch-src-tools-Makefile
new file mode 100644
index 000000000000..6fb70a99c6e7
--- /dev/null
+++ b/www/nostromo/files/patch-src-tools-Makefile
@@ -0,0 +1,23 @@
+--- src/tools/Makefile.orig 2011-03-20 11:22:18.000000000 +0100
++++ src/tools/Makefile 2011-03-20 11:26:24.000000000 +0100
+@@ -5,17 +5,18 @@
+
+ PIPE= -pipe
+
+-NOMAN= 1
++NO_MAN= 1
+
+ BINOWN= root
+ BINMOD= 0555
+-BINDIR= /usr/local/sbin
++BINDIR= ${PREFIX}/sbin
+
+ OS!= uname -s
+
+ .if ${OS} == "FreeBSD"
+ LDADD+= -lcrypt
+ .endif
++
+ .if ${OS} == "NetBSD"
+ LDADD+= -lcrypt
+ .endif
diff --git a/www/nostromo/pkg-descr b/www/nostromo/pkg-descr
new file mode 100644
index 000000000000..0fb0a15e2740
--- /dev/null
+++ b/www/nostromo/pkg-descr
@@ -0,0 +1,9 @@
+Nostromo aka nhttpd is a simple, fast and secure HTTP server. It
+runs as a single process, handling connections with select(2). For
+CGIs and directory listing it does fork(2). The minimum of HTTP/1.1
+and CGI/1.1 are implemented. Also supported are: chroot, setuid,
+basic authentication, SSL, IPv6, custom responses, aliases, and
+virtual hosts. The access log is written in standard CLF format.
+
+AUTHOR: Glocker Marcus <marcus@nazgul.ch>
+WWW: http://www.nazgul.ch/dev_nostromo.html
diff --git a/www/nostromo/pkg-plist b/www/nostromo/pkg-plist
new file mode 100644
index 000000000000..9ec6003d2d52
--- /dev/null
+++ b/www/nostromo/pkg-plist
@@ -0,0 +1,15 @@
+sbin/crypt
+sbin/nhttpd
+nostromo/conf/mimes
+nostromo/conf/nhttpd.conf-dist
+nostromo/htdocs/index.html
+nostromo/htdocs/nostromo.gif
+nostromo/htdocs/cgi-bin/printenv
+nostromo/icons/dir.gif
+nostromo/icons/file.gif
+@dirrmtry nostromo/conf
+@dirrmtry nostromo/htdocs/cgi-bin
+@dirrmtry nostromo/htdocs
+@dirrmtry nostromo/icons
+@dirrmtry nostromo/logs
+@dirrmtry nostromo