aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Dancer-Plugin-REST
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2014-08-13 15:29:48 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2014-08-13 15:29:48 +0000
commitab7b1ad6e9abefb7730abbe84066f582090e3806 (patch)
treef32b246a3fdd09ce21fd500ae13d225e5cd35672 /www/p5-Dancer-Plugin-REST
parent21967e1dd312863a75465bd491831c9d40c2174b (diff)
downloadports-ab7b1ad6e9abefb7730abbe84066f582090e3806.tar.gz
ports-ab7b1ad6e9abefb7730abbe84066f582090e3806.zip
New port: www/p5-Dancer-Plugin-REST:
This plugin helps you write a RESTful webservice with Dancer. WWW: http://search.cpan.org/dist/Dancer-Plugin-REST/
Notes
Notes: svn path=/head/; revision=364791
Diffstat (limited to 'www/p5-Dancer-Plugin-REST')
-rw-r--r--www/p5-Dancer-Plugin-REST/Makefile20
-rw-r--r--www/p5-Dancer-Plugin-REST/distinfo2
-rw-r--r--www/p5-Dancer-Plugin-REST/pkg-descr3
-rw-r--r--www/p5-Dancer-Plugin-REST/pkg-plist2
4 files changed, 27 insertions, 0 deletions
diff --git a/www/p5-Dancer-Plugin-REST/Makefile b/www/p5-Dancer-Plugin-REST/Makefile
new file mode 100644
index 000000000000..0a58c8d31cde
--- /dev/null
+++ b/www/p5-Dancer-Plugin-REST/Makefile
@@ -0,0 +1,20 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Dancer-Plugin-REST
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:YANICK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Dancer plugin for writing RESTful apps
+
+RUN_DEPENDS= p5-Dancer>0:${PORTSDIR}/www/p5-Dancer
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= modbuild run build
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer-Plugin-REST/distinfo b/www/p5-Dancer-Plugin-REST/distinfo
new file mode 100644
index 000000000000..3ff068674bab
--- /dev/null
+++ b/www/p5-Dancer-Plugin-REST/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer-Plugin-REST-0.11.tar.gz) = 81b8916632ef464c913829fe661eb1a6cecba0f2f9f7e1935db128f2ab4518a8
+SIZE (Dancer-Plugin-REST-0.11.tar.gz) = 19134
diff --git a/www/p5-Dancer-Plugin-REST/pkg-descr b/www/p5-Dancer-Plugin-REST/pkg-descr
new file mode 100644
index 000000000000..03682085276a
--- /dev/null
+++ b/www/p5-Dancer-Plugin-REST/pkg-descr
@@ -0,0 +1,3 @@
+This plugin helps you write a RESTful webservice with Dancer.
+
+WWW: http://search.cpan.org/dist/Dancer-Plugin-REST/
diff --git a/www/p5-Dancer-Plugin-REST/pkg-plist b/www/p5-Dancer-Plugin-REST/pkg-plist
new file mode 100644
index 000000000000..89e239f1b3a9
--- /dev/null
+++ b/www/p5-Dancer-Plugin-REST/pkg-plist
@@ -0,0 +1,2 @@
+%%PERL5_MAN3%%/Dancer::Plugin::REST.3.gz
+%%SITE_PERL%%/Dancer/Plugin/REST.pm