aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Maypole/Makefile
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2012-01-01 16:47:41 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2012-01-01 16:47:41 +0000
commit19fe40753d31ba0d91325ae15897602b2531875a (patch)
tree756dc92902e540775c00a7af9b20473c9ab8e7a9 /www/p5-Maypole/Makefile
parentc2f2d9bfd586d4beba0a893372843bf1de3a93ea (diff)
downloadports-19fe40753d31ba0d91325ae15897602b2531875a.tar.gz
ports-19fe40753d31ba0d91325ae15897602b2531875a.zip
- change required APACHE version from 13+ to 20+
(prepare to remove www/apache13) - no PORTREVISION bump since apache22 is the default with hat apache@
Notes
Notes: svn path=/head/; revision=288372
Diffstat (limited to 'www/p5-Maypole/Makefile')
-rw-r--r--www/p5-Maypole/Makefile25
1 files changed, 3 insertions, 22 deletions
diff --git a/www/p5-Maypole/Makefile b/www/p5-Maypole/Makefile
index 957cb23ea75b..6483e4b07082 100644
--- a/www/p5-Maypole/Makefile
+++ b/www/p5-Maypole/Makefile
@@ -42,34 +42,15 @@ PORTSCOUT= skipv:2.121
MAKE_JOBS_SAFE= yes
-OPTIONS= MODPERL "mod_perl support" off \
- MODPERL2 "mod_perl2 support" on
+OPTIONS= MODPERL2 "mod_perl2 support" on
PERL_CONFIGURE= yes
.include <bsd.port.options.mk>
-.if defined(WITH_MODPERL) || defined(WITH_MODPERL2)
-USE_APACHE_RUN= 13+
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_MODPERL) && ${APACHE_VERSION} > 13
-IGNORE= mod_perl require apache13 but ${APACHE_PORT} is installed
-.elif defined(WITH_MODPERL2) && ${APACHE_VERSION} < 20
-IGNORE= mod_perl2 require at last apache20 but ${APACHE_PORT} is installed
-.endif
-
-.if defined(WITH_MODPERL) && defined(WITH_MODPERL2)
-IGNORE= only 1 mod_perl at a time
-.endif
-
.if defined(WITH_MODPERL2)
+USE_APACHE_RUN= 20+
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Request.pm:${PORTSDIR}/www/p5-libapreq2
.endif
-.if defined(WITH_MODPERL)
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq
-.endif
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES+= pkg-message
@@ -132,4 +113,4 @@ post-install:
.endif
@ ${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>