aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Maypole/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2004-11-21 10:40:43 +0000
committerLars Thegler <lth@FreeBSD.org>2004-11-21 10:40:43 +0000
commit5946cea585175cf01ce66d435093bb6bf4caa149 (patch)
treeaaf9464398119379b64ba779df9ed5c1169758b0 /www/p5-Maypole/Makefile
parentaed4714254e814a410bc083437b904ac3a75309e (diff)
downloadports-5946cea585175cf01ce66d435093bb6bf4caa149.tar.gz
ports-5946cea585175cf01ce66d435093bb6bf4caa149.zip
- Update to 2.04
Submitted by: Alex Sayle <alex.sayle@ehsbrann.com>, Casper Warming <cwg@usr.bin.dk>
Notes
Notes: svn path=/head/; revision=122068
Diffstat (limited to 'www/p5-Maypole/Makefile')
-rw-r--r--www/p5-Maypole/Makefile65
1 files changed, 47 insertions, 18 deletions
diff --git a/www/p5-Maypole/Makefile b/www/p5-Maypole/Makefile
index f7c29d72e0f8..c8f2274b71fc 100644
--- a/www/p5-Maypole/Makefile
+++ b/www/p5-Maypole/Makefile
@@ -5,11 +5,10 @@
# $FreeBSD$
PORTNAME= Maypole
-PORTVERSION= 1.7
-PORTREVISION= 1
+PORTVERSION= 2.04
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= ../by-authors/id/S/SI/SIMON/
+MASTER_SITE_SUBDIR= ../by-authors/id/S/SR/SRI/
PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
@@ -25,8 +24,28 @@ BUILD_DEPENDS= ${SITE_PERL}/Class/DBI/Loader.pm:${PORTSDIR}/databases/p5-Class-D
${SITE_PERL}/CGI/Untaint.pm:${PORTSDIR}/www/p5-CGI-Untaint \
${SITE_PERL}/UNIVERSAL/moniker.pm:${PORTSDIR}/devel/p5-UNIVERSAL-moniker \
${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-exports \
- ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq \
- ${SITE_PERL}/Template/Plugin/Class.pm:${PORTSDIR}/www/p5-Template-Plugin-Class
+ ${SITE_PERL}/Template/Plugin/Class.pm:${PORTSDIR}/www/p5-Template-Plugin-Class \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/Lingua/EN/Inflect/Number.pm:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect-Number \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/CGI/Simple.pm:${PORTSDIR}/www/p5-CGI-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+OPTIONS= MODPERL "mod_perl support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MODPERL)
+.if defined(WITH_APACHE2)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq2
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq2
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq
+.endif
+.endif
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGMSG_SUB= DOCSDIR=${DOCSDIR} \
@@ -38,39 +57,51 @@ PERL_CONFIGURE= yes
MAN3= Apache::MVC.3 \
CGI::Maypole.3 \
Maypole.3 \
+ Maypole::Application.3 \
Maypole::CLI.3 \
+ Maypole::Config.3 \
+ Maypole::Constants.3 \
+ Maypole::Manual.3 \
+ Maypole::Manual::About.3 \
+ Maypole::Manual::Beer.3 \
+ Maypole::Manual::BuySpy.3 \
+ Maypole::Manual::Flox.3 \
+ Maypole::Manual::Model.3 \
+ Maypole::Manual::Request.3 \
+ Maypole::Manual::StandardTemplates.3 \
+ Maypole::Manual::View.3 \
+ Maypole::Manual::Workflow.3 \
Maypole::Model::Base.3 \
Maypole::Model::CDBI.3 \
Maypole::Model::CDBI::Plain.3 \
- Maypole::View::Mason.3 \
- Maypole::View::TT.3 \
- Maypole::Workflow.3
+ Maypole::View::Base.3 \
+ Maypole::View::TT.3
-DOC_FILES= About.pod \
+DOC_FILES= ../Manual.pod \
+ About.pod \
Beer.pod \
BuySpy.pod \
Flox.pod \
Model.pod \
- Overview.pod \
Request.pod \
StandardTemplates.pod \
- Templates.pod \
View.pod \
- makedoc.pl
+ Workflow.pod
EXAMPLE_FILES= BeerDB.pm
-TEMPLATE_FILES= beerdb.css \
+TEMPLATE_FILES= maypole.css \
beer/addnew \
- custom/frontpage \
- custom/header \
factory/addnew \
factory/edit \
factory/footer \
+ factory/frontpage \
factory/header \
factory/list \
factory/macros \
+ factory/maypole \
factory/navbar \
factory/pager \
factory/search_form \
+ factory/title \
factory/view
pre-patch:
@@ -81,7 +112,7 @@ post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
.for FILE in ${DOC_FILES}
- @ ${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${DOCSDIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/lib/Maypole/Manual/${FILE} ${DOCSDIR}
.endfor
@ ${MKDIR} ${EXAMPLESDIR}
.for FILE in ${EXAMPLE_FILES}
@@ -89,14 +120,12 @@ post-install:
.endfor
.endif
@ ${MKDIR} ${DATADIR}/templates/beer
- @ ${MKDIR} ${DATADIR}/templates/custom
@ ${MKDIR} ${DATADIR}/templates/factory
.for FILE in ${TEMPLATE_FILES}
@ ${INSTALL_DATA} ${WRKSRC}/templates/${FILE} ${DATADIR}/templates/${FILE}
.endfor
@ ${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
IGNORE= "Perl 5.6 or newer required. Install lang/perl5 or lang/perl5.8 and try again."
.endif