aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Curl
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-09-26 18:14:58 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-09-26 18:14:58 +0000
commitc4299fad26830f7b2a6b001a4718f89e5e632c51 (patch)
tree26e85bbbe4f590ec19ae36afd60637422a6cd987 /www/p5-WWW-Curl
parentc199fd7d2282eb86f44ba98ec8cbf3db8265676c (diff)
downloadports-c4299fad26830f7b2a6b001a4718f89e5e632c51.tar.gz
ports-c4299fad26830f7b2a6b001a4718f89e5e632c51.zip
Fix build with curl 7.66.0 and unbreak this port
Notes
Notes: svn path=/head/; revision=512931
Diffstat (limited to 'www/p5-WWW-Curl')
-rw-r--r--www/p5-WWW-Curl/Makefile2
-rw-r--r--www/p5-WWW-Curl/files/patch-Makefile.PL2
2 files changed, 1 insertions, 3 deletions
diff --git a/www/p5-WWW-Curl/Makefile b/www/p5-WWW-Curl/Makefile
index 4e9511943352..518478c2e16d 100644
--- a/www/p5-WWW-Curl/Makefile
+++ b/www/p5-WWW-Curl/Makefile
@@ -14,8 +14,6 @@ COMMENT= Perl extension interface for libcurl
LICENSE= MIT
-BROKEN= non-void function 'constant' should return a value
-
LIB_DEPENDS= libcurl.so:ftp/curl
TEST_DEPENDS= p5-Test-CPAN-Meta>=0:devel/p5-Test-CPAN-Meta \
p5-Test-Pod>=1.14:devel/p5-Test-Pod \
diff --git a/www/p5-WWW-Curl/files/patch-Makefile.PL b/www/p5-WWW-Curl/files/patch-Makefile.PL
index f0ac8d720360..9d1115ce54ea 100644
--- a/www/p5-WWW-Curl/files/patch-Makefile.PL
+++ b/www/p5-WWW-Curl/files/patch-Makefile.PL
@@ -4,7 +4,7 @@
open (H, "<", $curl_h) or die ("Cannot open $curl_h: ".$!);
while(<H>) {
if (/^#define (CURL[A-Za-z0-9_]*)/) {
-+ next if ($1 eq 'CURL_DID_MEMORY_FUNC_TYPEDEFS' || $1 eq 'CURL_STRICTER' );
++ next if ($1 eq 'CURL_DID_MEMORY_FUNC_TYPEDEFS' || $1 eq 'CURL_STRICTER' || $1 eq 'CURLINC_CURL_H' );
push @syms, $1;
}
}