aboutsummaryrefslogtreecommitdiff
path: root/www/py-WebError/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-27 15:28:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-27 15:28:38 +0000
commit3aa6e846b177756f53ea2e47a6d5b42d5b8bbae8 (patch)
tree32ddd9332692f27493d5113db6b5fec3c857f533 /www/py-WebError/Makefile
parentbc809ff4eda9a28bdae8e53df16348c671761f90 (diff)
downloadports-3aa6e846b177756f53ea2e47a6d5b42d5b8bbae8.tar.gz
ports-3aa6e846b177756f53ea2e47a6d5b42d5b8bbae8.zip
py-WebError is a python module for web error handling and
exception catching. WWW: http://pypi.python.org/pypi/WebError/ PR: ports/132044 Submitted by: Wen Heping <wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=229179
Diffstat (limited to 'www/py-WebError/Makefile')
-rw-r--r--www/py-WebError/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/py-WebError/Makefile b/www/py-WebError/Makefile
new file mode 100644
index 000000000000..28ad0ad11c0a
--- /dev/null
+++ b/www/py-WebError/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-WebError
+# Date created: 24 Feb, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WebError
+PORTVERSION= 0.10.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Web Error handling and exception catching
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Paste>=1.7:${PORTSDIR}/www/py-paste \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=1.0:${PORTSDIR}/textproc/py-pygments \
+ ${PYTHON_PKGNAMEPREFIX}Tempita>=0.3:${PORTSDIR}/textproc/py-Tempita \
+ ${PYTHON_PKGNAMEPREFIX}webob>=0.9.6.1:${PORTSDIR}/www/py-webob \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0.8:${PORTSDIR}/devel/py-simplejson
+
+USE_PYTHON= 2.5
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>