aboutsummaryrefslogtreecommitdiff
path: root/www/py-django-smart-selects/Makefile
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2021-04-20 17:21:22 +0000
committerDan Langille <dvl@FreeBSD.org>2021-04-20 17:56:04 +0000
commitb616ac3cf1073053a4bc04065ec40b52d5e4b409 (patch)
tree7984c2734b4bebbf06118564c43964b3e9de5900 /www/py-django-smart-selects/Makefile
parentc02c79f7313c1d9b27fd21ec815666042b9d5bb6 (diff)
downloadports-b616ac3cf1073053a4bc04065ec40b52d5e4b409.tar.gz
ports-b616ac3cf1073053a4bc04065ec40b52d5e4b409.zip
add www/py-django-smart-selects
allows you to quickly filter or group "chained" models by adding a custom foreign key or many to many field to your models PR: 254835 Reported by: gettoknowmi <gettoknowmi@yahoo.com>
Diffstat (limited to 'www/py-django-smart-selects/Makefile')
-rw-r--r--www/py-django-smart-selects/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/www/py-django-smart-selects/Makefile b/www/py-django-smart-selects/Makefile
new file mode 100644
index 000000000000..00f59a2fab15
--- /dev/null
+++ b/www/py-django-smart-selects/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= django-smart-selects
+PORTVERSION= 1.5.9
+CATEGORIES= www
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gatemken@cisco.com
+COMMENT= Quickly filter or group "chained" models
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django22>0:www/py-django22@${PY_FLAVOR}
+
+USES= python:3.6+,run
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>