aboutsummaryrefslogtreecommitdiff
path: root/www/py-restclient/Makefile
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
commit4942ce5a7d8a3d0cbebaf4d202011850d1f7569f (patch)
treedb1f21912f461000d609ddcd5d130946bcfe9e09 /www/py-restclient/Makefile
parentb4be9b354e86bd790925c5a9a2e67df8ba20bc00 (diff)
downloadports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.tar.gz
ports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Notes
Notes: svn path=/head/; revision=196700
Diffstat (limited to 'www/py-restclient/Makefile')
-rw-r--r--www/py-restclient/Makefile19
1 files changed, 2 insertions, 17 deletions
diff --git a/www/py-restclient/Makefile b/www/py-restclient/Makefile
index 32a320949dab..f91f698c0257 100644
--- a/www/py-restclient/Makefile
+++ b/www/py-restclient/Makefile
@@ -14,25 +14,10 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= lwhsu@FreeBSD.org
COMMENT= Convenient library for writing REST clients
-BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
-RUN_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools \
- ${PYTHON_SITELIBDIR}/httplib2/__init__.py:${PORTSDIR}/www/py-httplib2
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/httplib2/__init__.py:${PORTSDIR}/www/py-httplib2
USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-
-EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
-
-PYDISTUTILS_BUILD_TARGET= bdist_egg
-PYDISTUTILS_INSTALL_TARGET= easy_install
-PYDISTUTILS_INSTALLARGS= -O 1 -N -S ${PYTHON_SITELIBDIR} ${WRKSRC}/dist/${PYRESTCLIENT_EGG}
-
-PYRESTCLIENT_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
-
-PLIST_SUB+= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
- PYRESTCLIENT_EGG=${PYRESTCLIENT_EGG} \
- PYRESTCLIENT_EGG_VER="${PORTNAME}==${PORTVERSION}"
-
+USE_PYDISTUTILS= easy_install
post-patch:
${REINPLACE_CMD} -e 's,install_requires.*,,' ${WRKSRC}/setup.py