aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-03-23 12:01:42 +0000
committerJohn Marino <marino@FreeBSD.org>2014-03-23 12:01:42 +0000
commita7e41dc8406a573c6e4eb071fcc5490dec053e81 (patch)
tree5e94fe917c1d37a85628e8f90a3f16f54103de41 /www/seamonkey/Makefile
parentb388cf7a7e696303c6c57d51368c07606e23300c (diff)
downloadports-a7e41dc8406a573c6e4eb071fcc5490dec053e81.tar.gz
ports-a7e41dc8406a573c6e4eb071fcc5490dec053e81.zip
www/seamonkey: Unbreak DragonFly
The first fix is a NO-OP for FreeBSD. The clang/optimized flags work- around is OSVERSION-specific, so let's limit it to FreeBSD only. The real breakage was caused by the XPI_FILE substitution. The "x86" part of DragonFly's "x86_64" was getting transformed incorrectly to "i386_64". This could be prevented by changing the replacement pattern to "x86$", but "x86" is not a standard ARCH value, so this substitution isn't made on FreeBSD anyway. The solution is just remove it as the only effect it has is negative. Tested on: Redports, all four i386 builders pass
Notes
Notes: svn path=/head/; revision=348851
Diffstat (limited to 'www/seamonkey/Makefile')
-rw-r--r--www/seamonkey/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index c762f4c01e47..259158ac3612 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -85,6 +85,7 @@ XPI_LIBDIR= ${PREFIX}/lib/xpi
# avoid clang 3.2/3.3 crash in js/src/jsgc.cpp on refillFreeList<(js::AllowGC)1>
# http://svnweb.freebsd.org/changeset/base/255804
+.if ${OPSYS} == FreeBSD
.if ${CHOSEN_COMPILER_TYPE} == clang && ${ARCH} == i386 && ${OSVERSION} < 1000056
. if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
BROKEN= Cannot build with OPTIMIZED_CFLAGS option due to \
@@ -99,6 +100,7 @@ CXXFLAGS+= -O1
. endif
. endif
.endif
+.endif
.if ${PORT_OPTIONS:MALSA}
BUILD_DEPENDS+= alsa-lib>=1.0.27.2_1:${PORTSDIR}/audio/alsa-lib
@@ -138,7 +140,7 @@ MOZ_OPTIONS+= --disable-composer
MOZ_OPTIONS+= --enable-calendar
MOZ_MK_OPTIONS+= MOZ_CO_PROJECT=calendar
LIGHTNING_DIR= share/lightning
-XPI_FILE= ${MOZ_OBJDIR}/mozilla/dist/xpi-stage/lightning-${L_VERSION}.en-US.${OPSYS:L}${OSREL}-${ARCH:S/x86/i386/:S/amd64/x86_64/}.xpi
+XPI_FILE= ${MOZ_OBJDIR}/mozilla/dist/xpi-stage/lightning-${L_VERSION}.en-US.${OPSYS:L}${OSREL}-${ARCH:S/amd64/x86_64/}.xpi
XPI_ORIG_ID= {e2fda1a4-762b-4020-b5ad-a41df1933103}
XPI_ID= lightning@seamonkey.mozilla.org
.else