aboutsummaryrefslogtreecommitdiff
path: root/www/tomcat7
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-07-26 11:13:32 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-07-26 11:13:32 +0000
commit4002dc80c73e7e51cbb7321b3fff3504152de272 (patch)
tree567b8bac6d5fe2580ef81be411bf7a7f51f62c07 /www/tomcat7
parentec3a438a22fbb97983629d2ef436acbb7917d689 (diff)
downloadports-4002dc80c73e7e51cbb7321b3fff3504152de272.tar.gz
ports-4002dc80c73e7e51cbb7321b3fff3504152de272.zip
Update to 6.0.29 release and implement "status" and "poll" rc commands.
Notes
Notes: svn path=/head/; revision=258273
Diffstat (limited to 'www/tomcat7')
-rw-r--r--www/tomcat7/Makefile2
-rw-r--r--www/tomcat7/distinfo6
-rw-r--r--www/tomcat7/files/tomcat6.sh.in30
3 files changed, 27 insertions, 11 deletions
diff --git a/www/tomcat7/Makefile b/www/tomcat7/Makefile
index e606dc562588..ba75deaf6e98 100644
--- a/www/tomcat7/Makefile
+++ b/www/tomcat7/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tomcat
-PORTVERSION= 6.0.28
+PORTVERSION= 6.0.29
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-6/v${PORTVERSION}/bin
diff --git a/www/tomcat7/distinfo b/www/tomcat7/distinfo
index e99ef41e20da..e8d1e70f86f3 100644
--- a/www/tomcat7/distinfo
+++ b/www/tomcat7/distinfo
@@ -1,3 +1,3 @@
-MD5 (apache-tomcat-6.0.28.tar.gz) = e79253eff8e851a2c2bf9d42e58b0a78
-SHA256 (apache-tomcat-6.0.28.tar.gz) = 810d3a178e00fb1874beeb46fb5faa79e6ddf7a46a43d3b644e78f998fb18e25
-SIZE (apache-tomcat-6.0.28.tar.gz) = 6405516
+MD5 (apache-tomcat-6.0.29.tar.gz) = 7d614e03d18d3f21fcfdff96f0b6c311
+SHA256 (apache-tomcat-6.0.29.tar.gz) = 4cb25adf2b541c93a34e2e6b1b31d6da1f77ceaa688ac1a7c6635a475ae5266d
+SIZE (apache-tomcat-6.0.29.tar.gz) = 6407210
diff --git a/www/tomcat7/files/tomcat6.sh.in b/www/tomcat7/files/tomcat6.sh.in
index ef05ec5a4656..42bf6c29fc62 100644
--- a/www/tomcat7/files/tomcat6.sh.in
+++ b/www/tomcat7/files/tomcat6.sh.in
@@ -113,6 +113,8 @@ flags="-p ${pidfile} ${java_command} start ${tomcat%%TOMCAT_VERSION%%_flags} ${l
start_precmd="pid_touch"
stop_cmd="tomcat_stop"
+status_cmd="tomcat_status"
+poll_cmd="tomcat_poll"
pid_touch() {
touch $pidfile
@@ -124,11 +126,7 @@ tomcat_stop() {
if [ -z "$rc_pid" ]; then
[ -n "$rc_fast" ] && return 0
- if [ -n "$pidfile" ]; then
- echo "${name} not running? (check $pidfile)."
- else
- echo "${name} not running?"
- fi
+ echo "${name} not running? (check $pidfile)."
return 1
fi
@@ -139,10 +137,28 @@ tomcat_stop() {
rm -f ${pidfile}
}
+tomcat_status() {
+ rc_pid=$(tomcat_check_pidfile $pidfile)
+
+ if [ -z "$rc_pid" ]; then
+ [ -n "$rc_fast" ] && return 0
+ echo "${name} not running? (check $pidfile)."
+ return 1
+ fi
+}
+
+tomcat_poll() {
+ while (true) ; do
+ rc_pid=$(tomcat_check_pidfile $pidfile)
+ [ -z "$rc_pid" ] && break
+ sleep 2
+ done
+}
+
tomcat_check_pidfile() {
_pidfile=$1
- if [ -z "$_pidfile" -o -z "$_procname" ]; then
- err 3 'USAGE: check_pidfile pidfile procname [interpreter]'
+ if [ -z "$_pidfile" ]; then
+ err 3 'USAGE: tomcat_check_pidfile pidfile'
fi
if [ ! -f $_pidfile ]; then
debug "pid file ($_pidfile): not readable."