aboutsummaryrefslogtreecommitdiff
path: root/www/webgo
diff options
context:
space:
mode:
authorJulien Laffaye <jlaffaye@FreeBSD.org>2012-05-14 22:09:38 +0000
committerJulien Laffaye <jlaffaye@FreeBSD.org>2012-05-14 22:09:38 +0000
commit7dca9e3dd5e08126abef74ad0cc489e673f694d0 (patch)
treee417bda70d0ddb0624ef62f119198b8a5dfa2735 /www/webgo
parentb990fcd821626da24b2aa415d09d9e46c385ad6b (diff)
downloadports-7dca9e3dd5e08126abef74ad0cc489e673f694d0.tar.gz
ports-7dca9e3dd5e08126abef74ad0cc489e673f694d0.zip
- Update to 20120419
PR: ports/167344 Approved by: wen (maintainer)
Notes
Notes: svn path=/head/; revision=296619
Diffstat (limited to 'www/webgo')
-rw-r--r--www/webgo/Makefile13
-rw-r--r--www/webgo/distinfo4
-rw-r--r--www/webgo/pkg-descr2
-rw-r--r--www/webgo/pkg-plist23
4 files changed, 36 insertions, 6 deletions
diff --git a/www/webgo/Makefile b/www/webgo/Makefile
index d4a32c42af4c..9226e61bd27d 100644
--- a/www/webgo/Makefile
+++ b/www/webgo/Makefile
@@ -7,7 +7,6 @@
PORTNAME= webgo
PORTVERSION= 0.1.0.${SVNVERSION}
-PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= LOCAL/jlaffaye
DISTNAME= ${PORTNAME}-${SVNVERSION}
@@ -15,10 +14,18 @@ DISTNAME= ${PORTNAME}-${SVNVERSION}
MAINTAINER= wen@FreeBSD.org
COMMENT= Simplest way to write web applications in the Go programming language
-SVNVERSION= 20110915
-PLIST_FILES= ${GO_LIBDIR}/web.a
+SVNVERSION= 20120419
USE_GO= yes
+GO_PKGNAME= ${SUBLIBDIR}/web
+
+SUBLIBDIR= github.com/hoisie
+
+do-install:
+ ${MKDIR} ${GO_LOCAL_LIBDIR}/${SUBLIBDIR}
+ ${INSTALL_DATA} ${GO_WRKDIR_PKG}/${SUBLIBDIR}/web.a ${GO_LOCAL_LIBDIR}/${SUBLIBDIR}
+ ${MKDIR} ${GO_LOCAL_SRCDIR}/${GO_PKGNAME}
+ (cd ${GO_WRKSRC}/ && ${COPYTREE_SHARE} \* ${GO_LOCAL_SRCDIR}/${GO_PKGNAME})
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
diff --git a/www/webgo/distinfo b/www/webgo/distinfo
index f2872e4a1b18..c88639b16d98 100644
--- a/www/webgo/distinfo
+++ b/www/webgo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (webgo-20110915.tar.gz) = 2dcb0092401501b54e8001f102af9a8103a97935e3bc3da683a70f8d3a1df45f
-SIZE (webgo-20110915.tar.gz) = 20612
+SHA256 (webgo-20120419.tar.gz) = f31a68c7142fe1e64bdb07151482b371fd3da5d61dc0c35e046aec6c3a6a92d2
+SIZE (webgo-20120419.tar.gz) = 15237
diff --git a/www/webgo/pkg-descr b/www/webgo/pkg-descr
index 6ab7b25f7416..803fb09d16c8 100644
--- a/www/webgo/pkg-descr
+++ b/www/webgo/pkg-descr
@@ -14,4 +14,4 @@ Some features include:
execution and page render speed
* Serving static files
-WWW: https://github.com/hoisie/web.go
+WWW: https://github.com/hoisie/web
diff --git a/www/webgo/pkg-plist b/www/webgo/pkg-plist
new file mode 100644
index 000000000000..2fd9928ffcc7
--- /dev/null
+++ b/www/webgo/pkg-plist
@@ -0,0 +1,23 @@
+%%GO_LIBDIR%%/github.com/hoisie/web.a
+go/src/pkg/%%GO_PKGNAME%%/LICENSE
+go/src/pkg/%%GO_PKGNAME%%/Makefile
+go/src/pkg/%%GO_PKGNAME%%/Readme.md
+go/src/pkg/%%GO_PKGNAME%%/fcgi.go
+go/src/pkg/%%GO_PKGNAME%%/scgi.go
+go/src/pkg/%%GO_PKGNAME%%/status.go
+go/src/pkg/%%GO_PKGNAME%%/web.go
+go/src/pkg/%%GO_PKGNAME%%/web_test.go
+go/src/pkg/%%GO_PKGNAME%%/examples/Makefile
+go/src/pkg/%%GO_PKGNAME%%/examples/arcchallenge.go
+go/src/pkg/%%GO_PKGNAME%%/examples/hello.go
+go/src/pkg/%%GO_PKGNAME%%/examples/logger.go
+go/src/pkg/%%GO_PKGNAME%%/examples/methodhandler.go
+go/src/pkg/%%GO_PKGNAME%%/examples/multipart.go
+go/src/pkg/%%GO_PKGNAME%%/examples/multiserver.go
+go/src/pkg/%%GO_PKGNAME%%/examples/params.go
+@dirrm go/src/pkg/%%GO_PKGNAME%%/examples
+@dirrm go/src/pkg/%%GO_PKGNAME%%
+@dirrmtry go/src/pkg/github.com/hoisie
+@dirrmtry go/src/pkg/github.com/
+@dirrmtry %%GO_LIBDIR%%/github.com/hoisie
+@dirrmtry %%GO_LIBDIR%%/github.com