aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2008-05-28 21:01:11 +0000
committerDiane Bruce <db@FreeBSD.org>2008-05-28 21:01:11 +0000
commitddfd8cdbdb4f4634f28fe62b04529fe73dd4f68e (patch)
tree58bdbbf120c7b5b8de067ab849b85e82dfb741d5 /www
parent640de5a4f16ba683b4906390a743635ef8138654 (diff)
downloadports-ddfd8cdbdb4f4634f28fe62b04529fe73dd4f68e.tar.gz
ports-ddfd8cdbdb4f4634f28fe62b04529fe73dd4f68e.zip
The serf library is a C-based HTTP client library built upon the
Apache Portable Runtime (APR) library. It multiplexes connections, running the read/write communication asynchronously. Memory copies and transformations are kept to a minimum to provide high performance operation. WWW: http://serf.googlecode.com PR: ports/124059 Submitted by: Craig Rodrigues <rodrigc at FreeBSD.org>
Notes
Notes: svn path=/head/; revision=213829
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/serf/Makefile35
-rw-r--r--www/serf/distinfo3
-rw-r--r--www/serf/pkg-descr7
-rw-r--r--www/serf/pkg-plist9
5 files changed, 55 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a17de915f615..5ead9afcfb58 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1224,6 +1224,7 @@
SUBDIR += selenium
SUBDIR += serendipity
SUBDIR += serendipity-devel
+ SUBDIR += serf
SUBDIR += servlet-api
SUBDIR += session2
SUBDIR += shttpd
diff --git a/www/serf/Makefile b/www/serf/Makefile
new file mode 100644
index 000000000000..af58e6c82d13
--- /dev/null
+++ b/www/serf/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: apr
+# Date created: 28 May 2008
+# Whom: Craig Rodrigues <rodrigc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= serf
+PORTVERSION= 0.1.2
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
+
+MAINTAINER= rodrigc@FreeBSD.org
+COMMENT= Serf HTTP client library
+
+LIB_DEPENDS+= apr:${PORTSDIR}/devel/apr
+
+PROJECTHOST= serf
+PORTDOCS= design-guide.txt
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS+= --with-apr=${PREFIX}/bin/apr-1-config \
+ --with-apr-util=${PREFIX}/bin/apu-1-config
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.if !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/design-guide.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/serf/distinfo b/www/serf/distinfo
new file mode 100644
index 000000000000..4fc23ab194b1
--- /dev/null
+++ b/www/serf/distinfo
@@ -0,0 +1,3 @@
+MD5 (serf-0.1.2.tar.bz2) = 9578f4b40d4ae7ea799bb0067d6b1c7c
+SHA256 (serf-0.1.2.tar.bz2) = 44c852c9135914b85c7a1f36ef41f88c63de52faab98493a6e59008b7060f89c
+SIZE (serf-0.1.2.tar.bz2) = 117871
diff --git a/www/serf/pkg-descr b/www/serf/pkg-descr
new file mode 100644
index 000000000000..bad5f25a9a7d
--- /dev/null
+++ b/www/serf/pkg-descr
@@ -0,0 +1,7 @@
+The serf library is a C-based HTTP client library built upon the
+Apache Portable Runtime (APR) library. It multiplexes connections,
+running the read/write communication asynchronously. Memory copies
+and transformations are kept to a minimum to provide high
+performance operation.
+
+WWW: http://serf.googlecode.com
diff --git a/www/serf/pkg-plist b/www/serf/pkg-plist
new file mode 100644
index 000000000000..ce4ec05c4fab
--- /dev/null
+++ b/www/serf/pkg-plist
@@ -0,0 +1,9 @@
+include/serf-0/serf.h
+include/serf-0/serf_bucket_types.h
+include/serf-0/serf_bucket_util.h
+include/serf-0/serf_declare.h
+lib/libserf-0.so.0
+lib/libserf-0.so
+lib/libserf-0.la
+lib/libserf-0.a
+@dirrm include/serf-0