aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2020-01-11 12:08:34 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2020-01-11 12:08:34 +0000
commit1bb5e2f364df758bee960e4252cfd9e27620cf14 (patch)
tree78fe61224e199f2cff622dcd1850aae73035cd75 /www
parentf2bbf79d4cc63fd0b1160b9f95bfe73ee8ebffa5 (diff)
downloadports-1bb5e2f364df758bee960e4252cfd9e27620cf14.tar.gz
ports-1bb5e2f364df758bee960e4252cfd9e27620cf14.zip
[NEW] www/py-flask-smorest: Flask/Marshmallow-based REST API framework
REST API framework built upon Flask and marshmallow. - Serialization, deserialization and validation using marshmallow Schema - Explicit validation error messages returned in response - Database-agnostic - OpenAPI (Swagger) specification automatically generated and exposed with ReDoc or Swagger UI - Pagination - ETag WWW: https://github.com/marshmallow-code/flask-smorest PR: 242611 Submitted by: Goran Mekić <meka@tilda.center>
Notes
Notes: svn path=/head/; revision=522679
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-flask-smorest/Makefile33
-rw-r--r--www/py-flask-smorest/distinfo3
-rw-r--r--www/py-flask-smorest/pkg-descr11
4 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ab77e47fc66b..195970e77965 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1644,6 +1644,7 @@
SUBDIR += py-flask-restful
SUBDIR += py-flask-restplus
SUBDIR += py-flask-script
+ SUBDIR += py-flask-smorest
SUBDIR += py-flask-socketio
SUBDIR += py-flask-sockets
SUBDIR += py-flask-uploads
diff --git a/www/py-flask-smorest/Makefile b/www/py-flask-smorest/Makefile
new file mode 100644
index 000000000000..b94a6b33c12b
--- /dev/null
+++ b/www/py-flask-smorest/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= flask-smorest
+PORTVERSION= 0.18.2
+CATEGORIES= www devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= meka@tilda.center
+COMMENT= Flask/Marshmallow-based REST API framework
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}werkzeug>=0.15:www/py-werkzeug@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Flask>=1.1.0:www/py-flask@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}marshmallow>=2.15.2:devel/py-marshmallow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}webargs>=1.5.2:www/py-webargs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}apispec>=3.0.0:devel/py-apispec@${PY_FLAVOR}
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=4.0.0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_PYTHON= autoplist concurrent distutils
+
+TEST_ENV= PYTHONPATH=${WRKSRC}/src
+
+NO_ARCH= yes
+
+do-test:
+ cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -v -rs -o addopts=
+
+.include <bsd.port.mk>
diff --git a/www/py-flask-smorest/distinfo b/www/py-flask-smorest/distinfo
new file mode 100644
index 000000000000..883f291097d0
--- /dev/null
+++ b/www/py-flask-smorest/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1576574402
+SHA256 (flask-smorest-0.18.2.tar.gz) = c16bab8cd1de750f79e7bcba6f7ffea9a1299f0e69053e41273af920b5a0e748
+SIZE (flask-smorest-0.18.2.tar.gz) = 54329
diff --git a/www/py-flask-smorest/pkg-descr b/www/py-flask-smorest/pkg-descr
new file mode 100644
index 000000000000..6407021878f8
--- /dev/null
+++ b/www/py-flask-smorest/pkg-descr
@@ -0,0 +1,11 @@
+REST API framework built upon Flask and marshmallow.
+
+ - Serialization, deserialization and validation using marshmallow Schema
+ - Explicit validation error messages returned in response
+ - Database-agnostic
+ - OpenAPI (Swagger) specification automatically generated and exposed with
+ ReDoc or Swagger UI
+ - Pagination
+ - ETag
+
+WWW: https://github.com/marshmallow-code/flask-smorest