aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-11-14 16:12:56 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-11-14 16:12:56 +0000
commit30a183cdd9faf4c65a08818c285c8d9351e43ad3 (patch)
treedbe08499461c3eea79dce8b1eca87e2699ef0d1c /www
parent1ff45cdd0ae918b61cf33786436856d37aa2dcfb (diff)
downloadports-30a183cdd9faf4c65a08818c285c8d9351e43ad3.tar.gz
ports-30a183cdd9faf4c65a08818c285c8d9351e43ad3.zip
Importing KDE Frameworks into the ports tree (required for newer KDE Desktop and Applications)
KDE Frameworks is a collection of libraries and software frameworks by KDE that serve as technological foundation for KDE Plasma 5 and KDE Applications distributed under the GNU Lesser General Public License (LGPL) [1]. The work is based on what we have in the KDE testing repo [2]. This is the next big step in updating the KDE Desktop and its Applications to anything less dusty. With this change, `USES=kde:5` is now a valid option. Ports that need to depend on KDE Framework can now set: USES=kde:5 USE_KDE=<framework1> <framework2> ... <frameworkX> For example: www/qupzilla-qt5 can depend on sysutils/kf5-kwallet via: KWALLET_USE= KDE=wallet I would like to thank Raphael and Adriaan for reviewing the ports in the testing repo :) [1] https://en.wikipedia.org/wiki/KDE_Frameworks [2] http://src.mouf.net/area51/log/branches/plasma5 Reviewed by: rakuco, mat, groot_kde.org Approved by: rakuco (maintainer) Differential Revision: https://reviews.freebsd.org/D8329
Notes
Notes: svn path=/head/; revision=426118
Diffstat (limited to 'www')
-rw-r--r--www/Makefile4
-rw-r--r--www/kf5-kdewebkit/Makefile18
-rw-r--r--www/kf5-kdewebkit/distinfo3
-rw-r--r--www/kf5-kdewebkit/pkg-descr3
-rw-r--r--www/kf5-kdewebkit/pkg-plist20
-rw-r--r--www/kf5-khtml/Makefile24
-rw-r--r--www/kf5-khtml/distinfo3
-rw-r--r--www/kf5-khtml/pkg-descr4
-rw-r--r--www/kf5-khtml/pkg-plist168
-rw-r--r--www/kf5-kjs/Makefile17
-rw-r--r--www/kf5-kjs/distinfo3
-rw-r--r--www/kf5-kjs/pkg-descr5
-rw-r--r--www/kf5-kjs/pkg-plist115
-rw-r--r--www/kf5-kjsembed/Makefile16
-rw-r--r--www/kf5-kjsembed/distinfo3
-rw-r--r--www/kf5-kjsembed/pkg-descr3
-rw-r--r--www/kf5-kjsembed/pkg-plist127
17 files changed, 536 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ee423402af8b..19c7bb2d15a8 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -336,6 +336,10 @@
SUBDIR += kannel-sqlbox
SUBDIR += kcgi
SUBDIR += kdewebdev4
+ SUBDIR += kf5-kdewebkit
+ SUBDIR += kf5-khtml
+ SUBDIR += kf5-kjs
+ SUBDIR += kf5-kjsembed
SUBDIR += kohana
SUBDIR += kpartsplugin
SUBDIR += kplaylist
diff --git a/www/kf5-kdewebkit/Makefile b/www/kf5-kdewebkit/Makefile
new file mode 100644
index 000000000000..94c0290c9ead
--- /dev/null
+++ b/www/kf5-kdewebkit/Makefile
@@ -0,0 +1,18 @@
+# Created by: tcberner
+# $FreeBSD$
+
+PORTNAME= kdewebkit
+PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= www kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KF5 library providing integration of QtWebKit
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= auth codecs completion config configwidgets coreaddons \
+ ecm i18n jobwidgets kio parts service sonnet textwidgets \
+ wallet widgetsaddons xmlgui
+USE_QT5= buildtools_build core dbus gui network qmake_build webkit \
+ widgets xml
+
+.include <bsd.port.mk>
diff --git a/www/kf5-kdewebkit/distinfo b/www/kf5-kdewebkit/distinfo
new file mode 100644
index 000000000000..2730ccd10c40
--- /dev/null
+++ b/www/kf5-kdewebkit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475424082
+SHA256 (KDE/frameworks/5.27.0/kdewebkit-5.27.0.tar.xz) = 0e91d5083b0e446577ddcbe4c4b87d34fe5aab1c4d6831665339aac29cedc639
+SIZE (KDE/frameworks/5.27.0/kdewebkit-5.27.0.tar.xz) = 29448
diff --git a/www/kf5-kdewebkit/pkg-descr b/www/kf5-kdewebkit/pkg-descr
new file mode 100644
index 000000000000..40a86224dbc1
--- /dev/null
+++ b/www/kf5-kdewebkit/pkg-descr
@@ -0,0 +1,3 @@
+This library provides KDE integration of the QtWebKit library.
+
+WWW: http://api.kde.org/frameworks-api/frameworks5-apidocs/kdewebkit/html/index.html
diff --git a/www/kf5-kdewebkit/pkg-plist b/www/kf5-kdewebkit/pkg-plist
new file mode 100644
index 000000000000..40474f10a1eb
--- /dev/null
+++ b/www/kf5-kdewebkit/pkg-plist
@@ -0,0 +1,20 @@
+include/KF5/KDEWebKit/KGraphicsWebView
+include/KF5/KDEWebKit/KWebPage
+include/KF5/KDEWebKit/KWebPluginFactory
+include/KF5/KDEWebKit/KWebView
+include/KF5/KDEWebKit/KWebWallet
+include/KF5/KDEWebKit/kdewebkit_export.h
+include/KF5/KDEWebKit/kgraphicswebview.h
+include/KF5/KDEWebKit/kwebpage.h
+include/KF5/KDEWebKit/kwebpluginfactory.h
+include/KF5/KDEWebKit/kwebview.h
+include/KF5/KDEWebKit/kwebwallet.h
+include/KF5/kdewebkit_version.h
+lib/cmake/KF5WebKit/KF5WebKitConfig.cmake
+lib/cmake/KF5WebKit/KF5WebKitConfigVersion.cmake
+lib/cmake/KF5WebKit/KF5WebKitTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KF5WebKit/KF5WebKitTargets.cmake
+lib/libKF5WebKit.so
+lib/libKF5WebKit.so.5
+lib/libKF5WebKit.so.%%KDE_FRAMEWORKS_VERSION%%
+%%QT_MKSPECDIR%%/modules/qt_KDEWebKit.pri
diff --git a/www/kf5-khtml/Makefile b/www/kf5-khtml/Makefile
new file mode 100644
index 000000000000..5b0e8035c806
--- /dev/null
+++ b/www/kf5-khtml/Makefile
@@ -0,0 +1,24 @@
+# Created by: tcberner
+# $FreeBSD$
+
+PORTNAME= khtml
+PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= www kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KF5 KTHML rendering engine
+
+LIB_DEPENDS= libgif.so:graphics/giflib \
+ libpng16.so:graphics/png
+
+USES= cmake:outsource compiler:c++11-lib gettext jpeg kde:5 \
+ tar:xz
+USE_KDE= archive auth bookmarks codecs completion config \
+ configwidgets coreaddons ecm globalaccel i18n iconthemes \
+ jobwidgets js kio notifications parts service sonnet \
+ textwidgets wallet widgetsaddons windowsystem xmlgui
+USE_QT5= buildtools_build core dbus gui network phonon4 \
+ printsupport qmake_build widgets x11extras xml
+USE_XORG= ice sm x11 xext
+
+.include <bsd.port.mk>
diff --git a/www/kf5-khtml/distinfo b/www/kf5-khtml/distinfo
new file mode 100644
index 000000000000..02431566725d
--- /dev/null
+++ b/www/kf5-khtml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475424082
+SHA256 (KDE/frameworks/5.27.0/khtml-5.27.0.tar.xz) = 808d8d3602d4ab1441102ff4b7639fd54e6af7d5de6f4d430fbbe427e6ab5a17
+SIZE (KDE/frameworks/5.27.0/khtml-5.27.0.tar.xz) = 4326208
diff --git a/www/kf5-khtml/pkg-descr b/www/kf5-khtml/pkg-descr
new file mode 100644
index 000000000000..4a94048390a6
--- /dev/null
+++ b/www/kf5-khtml/pkg-descr
@@ -0,0 +1,4 @@
+KHTML is a web rendering engine, based on the KParts technology and using KJS
+for JavaScript support.
+
+WWW: http://api.kde.org/frameworks-api/frameworks5-apidocs/khtml/html/index.html
diff --git a/www/kf5-khtml/pkg-plist b/www/kf5-khtml/pkg-plist
new file mode 100644
index 000000000000..0c5d15392ff5
--- /dev/null
+++ b/www/kf5-khtml/pkg-plist
@@ -0,0 +1,168 @@
+etc/xdg/khtmlrc
+include/KF5/KHtml/KHTMLPart
+include/KF5/KHtml/KHTMLSettings
+include/KF5/KHtml/KHTMLView
+include/KF5/KHtml/dom/css_rule.h
+include/KF5/KHtml/dom/css_stylesheet.h
+include/KF5/KHtml/dom/css_value.h
+include/KF5/KHtml/dom/dom2_events.h
+include/KF5/KHtml/dom/dom2_range.h
+include/KF5/KHtml/dom/dom2_traversal.h
+include/KF5/KHtml/dom/dom2_views.h
+include/KF5/KHtml/dom/dom_core.h
+include/KF5/KHtml/dom/dom_doc.h
+include/KF5/KHtml/dom/dom_element.h
+include/KF5/KHtml/dom/dom_exception.h
+include/KF5/KHtml/dom/dom_html.h
+include/KF5/KHtml/dom/dom_misc.h
+include/KF5/KHtml/dom/dom_node.h
+include/KF5/KHtml/dom/dom_string.h
+include/KF5/KHtml/dom/dom_text.h
+include/KF5/KHtml/dom/dom_xml.h
+include/KF5/KHtml/dom/html_base.h
+include/KF5/KHtml/dom/html_block.h
+include/KF5/KHtml/dom/html_document.h
+include/KF5/KHtml/dom/html_element.h
+include/KF5/KHtml/dom/html_form.h
+include/KF5/KHtml/dom/html_head.h
+include/KF5/KHtml/dom/html_image.h
+include/KF5/KHtml/dom/html_inline.h
+include/KF5/KHtml/dom/html_list.h
+include/KF5/KHtml/dom/html_misc.h
+include/KF5/KHtml/dom/html_object.h
+include/KF5/KHtml/dom/html_table.h
+include/KF5/KHtml/kencodingdetector.h
+include/KF5/KHtml/khtml_events.h
+include/KF5/KHtml/khtml_export.h
+include/KF5/KHtml/khtml_part.h
+include/KF5/KHtml/khtml_settings.h
+include/KF5/KHtml/khtmldefaults.h
+include/KF5/KHtml/khtmlpart.h
+include/KF5/KHtml/khtmlsettings.h
+include/KF5/KHtml/khtmlview.h
+include/KF5/khtml_version.h
+lib/cmake/KF5KHtml/KF5KHtmlConfig.cmake
+lib/cmake/KF5KHtml/KF5KHtmlConfigVersion.cmake
+lib/cmake/KF5KHtml/KF5KHtmlTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KF5KHtml/KF5KHtmlTargets.cmake
+lib/libKF5KHtml.so
+lib/libKF5KHtml.so.5
+lib/libKF5KHtml.so.%%KDE_FRAMEWORKS_VERSION%%
+%%QT_PLUGINDIR%%/kf5/parts/khtmladaptorpart.so
+%%QT_PLUGINDIR%%/kf5/parts/khtmlimagepart.so
+%%QT_PLUGINDIR%%/kf5/parts/khtmlpart.so
+%%QT_PLUGINDIR%%/kf5/parts/kjavaappletviewer.so
+%%QT_PLUGINDIR%%/kf5/parts/kmultipart.so
+%%QT_MKSPECDIR%%/modules/qt_KHtml.pri
+share/kf5/khtml/css/html4.css
+share/kf5/khtml/css/presentational.css
+share/kf5/khtml/css/quirks.css
+share/kf5/khtml/error.html
+share/kf5/kjava/kjava.jar
+share/kf5/kjava/kjava.policy
+share/kf5/kjava/pluginsinfo
+share/kservices5/khtml.desktop
+share/kservices5/khtmladaptorpart.desktop
+share/kservices5/khtmlimage.desktop
+share/kservices5/kjavaappletviewer.desktop
+share/kservices5/kmultipart.desktop
+share/locale/af/LC_MESSAGES/khtml5.mo
+share/locale/ar/LC_MESSAGES/khtml5.mo
+share/locale/as/LC_MESSAGES/khtml5.mo
+share/locale/ast/LC_MESSAGES/khtml5.mo
+share/locale/be/LC_MESSAGES/khtml5.mo
+share/locale/be@latin/LC_MESSAGES/khtml5.mo
+share/locale/bg/LC_MESSAGES/khtml5.mo
+share/locale/bn/LC_MESSAGES/khtml5.mo
+share/locale/bn_IN/LC_MESSAGES/khtml5.mo
+share/locale/br/LC_MESSAGES/khtml5.mo
+share/locale/bs/LC_MESSAGES/khtml5.mo
+share/locale/ca/LC_MESSAGES/khtml5.mo
+share/locale/ca@valencia/LC_MESSAGES/khtml5.mo
+share/locale/crh/LC_MESSAGES/khtml5.mo
+share/locale/cs/LC_MESSAGES/khtml5.mo
+share/locale/csb/LC_MESSAGES/khtml5.mo
+share/locale/cy/LC_MESSAGES/khtml5.mo
+share/locale/da/LC_MESSAGES/khtml5.mo
+share/locale/de/LC_MESSAGES/khtml5.mo
+share/locale/el/LC_MESSAGES/khtml5.mo
+share/locale/en_GB/LC_MESSAGES/khtml5.mo
+share/locale/eo/LC_MESSAGES/khtml5.mo
+share/locale/es/LC_MESSAGES/khtml5.mo
+share/locale/et/LC_MESSAGES/khtml5.mo
+share/locale/eu/LC_MESSAGES/khtml5.mo
+share/locale/fa/LC_MESSAGES/khtml5.mo
+share/locale/fi/LC_MESSAGES/khtml5.mo
+share/locale/fr/LC_MESSAGES/khtml5.mo
+share/locale/fy/LC_MESSAGES/khtml5.mo
+share/locale/ga/LC_MESSAGES/khtml5.mo
+share/locale/gd/LC_MESSAGES/khtml5.mo
+share/locale/gl/LC_MESSAGES/khtml5.mo
+share/locale/gu/LC_MESSAGES/khtml5.mo
+share/locale/ha/LC_MESSAGES/khtml5.mo
+share/locale/he/LC_MESSAGES/khtml5.mo
+share/locale/hi/LC_MESSAGES/khtml5.mo
+share/locale/hne/LC_MESSAGES/khtml5.mo
+share/locale/hr/LC_MESSAGES/khtml5.mo
+share/locale/hsb/LC_MESSAGES/khtml5.mo
+share/locale/hu/LC_MESSAGES/khtml5.mo
+share/locale/hy/LC_MESSAGES/khtml5.mo
+share/locale/ia/LC_MESSAGES/khtml5.mo
+share/locale/id/LC_MESSAGES/khtml5.mo
+share/locale/is/LC_MESSAGES/khtml5.mo
+share/locale/it/LC_MESSAGES/khtml5.mo
+share/locale/ja/LC_MESSAGES/khtml5.mo
+share/locale/ka/LC_MESSAGES/khtml5.mo
+share/locale/kk/LC_MESSAGES/khtml5.mo
+share/locale/km/LC_MESSAGES/khtml5.mo
+share/locale/kn/LC_MESSAGES/khtml5.mo
+share/locale/ko/LC_MESSAGES/khtml5.mo
+share/locale/ku/LC_MESSAGES/khtml5.mo
+share/locale/lb/LC_MESSAGES/khtml5.mo
+share/locale/lt/LC_MESSAGES/khtml5.mo
+share/locale/lv/LC_MESSAGES/khtml5.mo
+share/locale/mai/LC_MESSAGES/khtml5.mo
+share/locale/mk/LC_MESSAGES/khtml5.mo
+share/locale/ml/LC_MESSAGES/khtml5.mo
+share/locale/mr/LC_MESSAGES/khtml5.mo
+share/locale/ms/LC_MESSAGES/khtml5.mo
+share/locale/nb/LC_MESSAGES/khtml5.mo
+share/locale/nds/LC_MESSAGES/khtml5.mo
+share/locale/ne/LC_MESSAGES/khtml5.mo
+share/locale/nl/LC_MESSAGES/khtml5.mo
+share/locale/nn/LC_MESSAGES/khtml5.mo
+share/locale/oc/LC_MESSAGES/khtml5.mo
+share/locale/or/LC_MESSAGES/khtml5.mo
+share/locale/pa/LC_MESSAGES/khtml5.mo
+share/locale/pl/LC_MESSAGES/khtml5.mo
+share/locale/ps/LC_MESSAGES/khtml5.mo
+share/locale/pt/LC_MESSAGES/khtml5.mo
+share/locale/pt_BR/LC_MESSAGES/khtml5.mo
+share/locale/ro/LC_MESSAGES/khtml5.mo
+share/locale/ru/LC_MESSAGES/khtml5.mo
+share/locale/se/LC_MESSAGES/khtml5.mo
+share/locale/si/LC_MESSAGES/khtml5.mo
+share/locale/sk/LC_MESSAGES/khtml5.mo
+share/locale/sl/LC_MESSAGES/khtml5.mo
+share/locale/sq/LC_MESSAGES/khtml5.mo
+share/locale/sr/LC_MESSAGES/khtml5.mo
+share/locale/sr@ijekavian/LC_MESSAGES/khtml5.mo
+share/locale/sr@ijekavianlatin/LC_MESSAGES/khtml5.mo
+share/locale/sr@latin/LC_MESSAGES/khtml5.mo
+share/locale/sv/LC_MESSAGES/khtml5.mo
+share/locale/ta/LC_MESSAGES/khtml5.mo
+share/locale/te/LC_MESSAGES/khtml5.mo
+share/locale/tg/LC_MESSAGES/khtml5.mo
+share/locale/th/LC_MESSAGES/khtml5.mo
+share/locale/tr/LC_MESSAGES/khtml5.mo
+share/locale/tt/LC_MESSAGES/khtml5.mo
+share/locale/ug/LC_MESSAGES/khtml5.mo
+share/locale/uk/LC_MESSAGES/khtml5.mo
+share/locale/uz/LC_MESSAGES/khtml5.mo
+share/locale/uz@cyrillic/LC_MESSAGES/khtml5.mo
+share/locale/vi/LC_MESSAGES/khtml5.mo
+share/locale/wa/LC_MESSAGES/khtml5.mo
+share/locale/xh/LC_MESSAGES/khtml5.mo
+share/locale/zh_CN/LC_MESSAGES/khtml5.mo
+share/locale/zh_HK/LC_MESSAGES/khtml5.mo
+share/locale/zh_TW/LC_MESSAGES/khtml5.mo
diff --git a/www/kf5-kjs/Makefile b/www/kf5-kjs/Makefile
new file mode 100644
index 000000000000..f6d0144c9089
--- /dev/null
+++ b/www/kf5-kjs/Makefile
@@ -0,0 +1,17 @@
+# Created by: tcberner
+# $FreeBSD$
+
+PORTNAME= kjs
+PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= www kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KF5 library providing an ECMAScript interpreter
+
+LIB_DEPENDS= libpcre.so:devel/pcre
+
+USES= cmake:outsource compiler:c++11-lib kde:5 pkgconfig tar:xz
+USE_KDE= ecm doctools
+USE_QT5= buildtools_build core qmake_build
+
+.include <bsd.port.mk>
diff --git a/www/kf5-kjs/distinfo b/www/kf5-kjs/distinfo
new file mode 100644
index 000000000000..04d69f911f59
--- /dev/null
+++ b/www/kf5-kjs/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475424082
+SHA256 (KDE/frameworks/5.27.0/kjs-5.27.0.tar.xz) = 325d0d0db21dce3051b8a602420f77a92596b9cb2d57d8f5396f5db2c757a4a3
+SIZE (KDE/frameworks/5.27.0/kjs-5.27.0.tar.xz) = 293792
diff --git a/www/kf5-kjs/pkg-descr b/www/kf5-kjs/pkg-descr
new file mode 100644
index 000000000000..305a784c85bd
--- /dev/null
+++ b/www/kf5-kjs/pkg-descr
@@ -0,0 +1,5 @@
+This library provides an ECMAScript compatible interpreter.
+The ECMA standard is based on well known scripting languages
+such as Netscape's JavaScript and Microsoft's JScript.
+
+WWW: http://api.kde.org/frameworks-api/frameworks5-apidocs/kjs/html/index.html
diff --git a/www/kf5-kjs/pkg-plist b/www/kf5-kjs/pkg-plist
new file mode 100644
index 000000000000..782a16a847cf
--- /dev/null
+++ b/www/kf5-kjs/pkg-plist
@@ -0,0 +1,115 @@
+bin/kjs5
+include/KF5/kjs/CommonIdentifiers.h
+include/KF5/kjs/CompileState.h
+include/KF5/kjs/ExecState.h
+include/KF5/kjs/JSImmediate.h
+include/KF5/kjs/JSLock.h
+include/KF5/kjs/JSType.h
+include/KF5/kjs/JSVariableObject.h
+include/KF5/kjs/JSWrapperObject.h
+include/KF5/kjs/LocalStorage.h
+include/KF5/kjs/Parser.h
+include/KF5/kjs/PropertyNameArray.h
+include/KF5/kjs/SavedBuiltins.h
+include/KF5/kjs/SymbolTable.h
+include/KF5/kjs/array_instance.h
+include/KF5/kjs/array_object.h
+include/KF5/kjs/bool_object.h
+include/KF5/kjs/collector.h
+include/KF5/kjs/commonunicode.h
+include/KF5/kjs/completion.h
+include/KF5/kjs/context.h
+include/KF5/kjs/date_object.h
+include/KF5/kjs/debugger.h
+include/KF5/kjs/dtoa.h
+include/KF5/kjs/error_object.h
+include/KF5/kjs/function.h
+include/KF5/kjs/function_object.h
+include/KF5/kjs/global.h
+include/KF5/kjs/grammar.h
+include/KF5/kjs/identifier.h
+include/KF5/kjs/internal.h
+include/KF5/kjs/interpreter.h
+include/KF5/kjs/json_object.h
+include/KF5/kjs/jsonlexer.h
+include/KF5/kjs/jsonstringify.h
+include/KF5/kjs/kjsapi_export.h
+include/KF5/kjs/kjsarguments.h
+include/KF5/kjs/kjscontext.h
+include/KF5/kjs/kjsinterpreter.h
+include/KF5/kjs/kjsobject.h
+include/KF5/kjs/kjsprototype.h
+include/KF5/kjs/lexer.h
+include/KF5/kjs/list.h
+include/KF5/kjs/lookup.h
+include/KF5/kjs/makenodes.h
+include/KF5/kjs/math_object.h
+include/KF5/kjs/nodes.h
+include/KF5/kjs/nodes2bytecode.h
+include/KF5/kjs/number_object.h
+include/KF5/kjs/object.h
+include/KF5/kjs/object_object.h
+include/KF5/kjs/operations.h
+include/KF5/kjs/package.h
+include/KF5/kjs/property_map.h
+include/KF5/kjs/property_slot.h
+include/KF5/kjs/propertydescriptor.h
+include/KF5/kjs/protect.h
+include/KF5/kjs/regexp.h
+include/KF5/kjs/regexp_object.h
+include/KF5/kjs/scope_chain.h
+include/KF5/kjs/scriptfunction.h
+include/KF5/kjs/string_object.h
+include/KF5/kjs/types.h
+include/KF5/kjs/ustring.h
+include/KF5/kjs/value.h
+include/KF5/kjs_version.h
+include/KF5/wtf/ASCIICType.h
+include/KF5/wtf/AlwaysInline.h
+include/KF5/wtf/Assertions.h
+include/KF5/wtf/DisallowCType.h
+include/KF5/wtf/FastMalloc.h
+include/KF5/wtf/Forward.h
+include/KF5/wtf/GetPtr.h
+include/KF5/wtf/HashCountedSet.h
+include/KF5/wtf/HashFunctions.h
+include/KF5/wtf/HashIterators.h
+include/KF5/wtf/HashMap.h
+include/KF5/wtf/HashSet.h
+include/KF5/wtf/HashTable.h
+include/KF5/wtf/HashTraits.h
+include/KF5/wtf/ListRefPtr.h
+include/KF5/wtf/MathExtras.h
+include/KF5/wtf/Noncopyable.h
+include/KF5/wtf/OwnArrayPtr.h
+include/KF5/wtf/OwnPtr.h
+include/KF5/wtf/PassRefPtr.h
+include/KF5/wtf/Platform.h
+include/KF5/wtf/RefCounted.h
+include/KF5/wtf/RefPtr.h
+include/KF5/wtf/RefPtrHashMap.h
+include/KF5/wtf/SharedPtr.h
+include/KF5/wtf/UnusedParam.h
+include/KF5/wtf/Vector.h
+include/KF5/wtf/VectorTraits.h
+lib/cmake/KF5JS/KF5JSConfig.cmake
+lib/cmake/KF5JS/KF5JSConfigVersion.cmake
+lib/cmake/KF5JS/KF5JSTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KF5JS/KF5JSTargets.cmake
+lib/libKF5JS.so
+lib/libKF5JS.so.5
+lib/libKF5JS.so.%%KDE_FRAMEWORKS_VERSION%%
+lib/libKF5JSApi.so
+lib/libKF5JSApi.so.5
+lib/libKF5JSApi.so.%%KDE_FRAMEWORKS_VERSION%%
+man/man1/kjs5.1.gz
+man/ca/man1/kjs5.1.gz
+man/de/man1/kjs5.1.gz
+man/it/man1/kjs5.1.gz
+man/nl/man1/kjs5.1.gz
+man/pt_BR/man1/kjs5.1.gz
+man/sv/man1/kjs5.1.gz
+man/uk/man1/kjs5.1.gz
+%%QT_MKSPECDIR%%/modules/qt_KJS.pri
+%%QT_MKSPECDIR%%/modules/qt_KJSApi.pri
+share/kf5/kjs/create_hash_table
diff --git a/www/kf5-kjsembed/Makefile b/www/kf5-kjsembed/Makefile
new file mode 100644
index 000000000000..f95794bc76b0
--- /dev/null
+++ b/www/kf5-kjsembed/Makefile
@@ -0,0 +1,16 @@
+# Created by: tcberner
+# $FreeBSD$
+
+PORTNAME= kjsembed
+PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= www kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KF5 library for binding JavaScript objects to QObjects
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= archive doctools ecm i18n js
+USE_QT5= buildtools_build core gui qmake_build svg \
+ uiplugin uitools widgets xml
+
+.include <bsd.port.mk>
diff --git a/www/kf5-kjsembed/distinfo b/www/kf5-kjsembed/distinfo
new file mode 100644
index 000000000000..006e5a07f189
--- /dev/null
+++ b/www/kf5-kjsembed/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475424082
+SHA256 (KDE/frameworks/5.27.0/kjsembed-5.27.0.tar.xz) = 4b60cae1b4672764d77dd1b6376f8cf3c01684bf24ad24740596d740a8d882c8
+SIZE (KDE/frameworks/5.27.0/kjsembed-5.27.0.tar.xz) = 2741800
diff --git a/www/kf5-kjsembed/pkg-descr b/www/kf5-kjsembed/pkg-descr
new file mode 100644
index 000000000000..96d2aab37c62
--- /dev/null
+++ b/www/kf5-kjsembed/pkg-descr
@@ -0,0 +1,3 @@
+KSJEmbed provides a method of binding JavaScript objects to QObjects.
+
+WWW: http://api.kde.org/frameworks-api/frameworks5-apidocs/kjsembed/html/index.html
diff --git a/www/kf5-kjsembed/pkg-plist b/www/kf5-kjsembed/pkg-plist
new file mode 100644
index 000000000000..cbb1573d0355
--- /dev/null
+++ b/www/kf5-kjsembed/pkg-plist
@@ -0,0 +1,127 @@
+bin/kjscmd5
+bin/kjsconsole
+include/KF5/KJsEmbed/KJsEmbed/KJsEmbed
+include/KF5/KJsEmbed/kjsembed/binding_support.h
+include/KF5/KJsEmbed/kjsembed/kjseglobal.h
+include/KF5/KJsEmbed/kjsembed/kjsembed.h
+include/KF5/KJsEmbed/kjsembed/kjsembed_export.h
+include/KF5/KJsEmbed/kjsembed/pointer.h
+include/KF5/KJsEmbed/kjsembed/static_binding.h
+include/KF5/KJsEmbed/kjsembed/variant_binding.h
+lib/cmake/KF5JsEmbed/KF5JsEmbedConfig.cmake
+lib/cmake/KF5JsEmbed/KF5JsEmbedConfigVersion.cmake
+lib/cmake/KF5JsEmbed/KF5JsEmbedTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KF5JsEmbed/KF5JsEmbedTargets.cmake
+lib/libKF5JsEmbed.so
+lib/libKF5JsEmbed.so.5
+lib/libKF5JsEmbed.so.%%KDE_FRAMEWORKS_VERSION%%
+%%QT_MKSPECDIR%%/modules/qt_KJsEmbed.pri
+man/ca/man1/kjscmd5.1.gz
+man/de/man1/kjscmd5.1.gz
+man/it/man1/kjscmd5.1.gz
+man/man1/kjscmd5.1.gz
+man/nl/man1/kjscmd5.1.gz
+man/pt_BR/man1/kjscmd5.1.gz
+man/ru/man1/kjscmd5.1.gz
+man/sv/man1/kjscmd5.1.gz
+man/uk/man1/kjscmd5.1.gz
+share/locale/af/LC_MESSAGES/kjsembed5.mo
+share/locale/ar/LC_MESSAGES/kjsembed5.mo
+share/locale/as/LC_MESSAGES/kjsembed5.mo
+share/locale/ast/LC_MESSAGES/kjsembed5.mo
+share/locale/be/LC_MESSAGES/kjsembed5.mo
+share/locale/be@latin/LC_MESSAGES/kjsembed5.mo
+share/locale/bg/LC_MESSAGES/kjsembed5.mo
+share/locale/bn/LC_MESSAGES/kjsembed5.mo
+share/locale/bn_IN/LC_MESSAGES/kjsembed5.mo
+share/locale/br/LC_MESSAGES/kjsembed5.mo
+share/locale/bs/LC_MESSAGES/kjsembed5.mo
+share/locale/ca/LC_MESSAGES/kjsembed5.mo
+share/locale/ca@valencia/LC_MESSAGES/kjsembed5.mo
+share/locale/crh/LC_MESSAGES/kjsembed5.mo
+share/locale/cs/LC_MESSAGES/kjsembed5.mo
+share/locale/csb/LC_MESSAGES/kjsembed5.mo
+share/locale/cy/LC_MESSAGES/kjsembed5.mo
+share/locale/da/LC_MESSAGES/kjsembed5.mo
+share/locale/de/LC_MESSAGES/kjsembed5.mo
+share/locale/el/LC_MESSAGES/kjsembed5.mo
+share/locale/en_GB/LC_MESSAGES/kjsembed5.mo
+share/locale/eo/LC_MESSAGES/kjsembed5.mo
+share/locale/es/LC_MESSAGES/kjsembed5.mo
+share/locale/et/LC_MESSAGES/kjsembed5.mo
+share/locale/eu/LC_MESSAGES/kjsembed5.mo
+share/locale/fa/LC_MESSAGES/kjsembed5.mo
+share/locale/fi/LC_MESSAGES/kjsembed5.mo
+share/locale/fr/LC_MESSAGES/kjsembed5.mo
+share/locale/fy/LC_MESSAGES/kjsembed5.mo
+share/locale/ga/LC_MESSAGES/kjsembed5.mo
+share/locale/gd/LC_MESSAGES/kjsembed5.mo
+share/locale/gl/LC_MESSAGES/kjsembed5.mo
+share/locale/gu/LC_MESSAGES/kjsembed5.mo
+share/locale/ha/LC_MESSAGES/kjsembed5.mo
+share/locale/he/LC_MESSAGES/kjsembed5.mo
+share/locale/hi/LC_MESSAGES/kjsembed5.mo
+share/locale/hne/LC_MESSAGES/kjsembed5.mo
+share/locale/hr/LC_MESSAGES/kjsembed5.mo
+share/locale/hsb/LC_MESSAGES/kjsembed5.mo
+share/locale/hu/LC_MESSAGES/kjsembed5.mo
+share/locale/hy/LC_MESSAGES/kjsembed5.mo
+share/locale/ia/LC_MESSAGES/kjsembed5.mo
+share/locale/id/LC_MESSAGES/kjsembed5.mo
+share/locale/is/LC_MESSAGES/kjsembed5.mo
+share/locale/it/LC_MESSAGES/kjsembed5.mo
+share/locale/ja/LC_MESSAGES/kjsembed5.mo
+share/locale/ka/LC_MESSAGES/kjsembed5.mo
+share/locale/kk/LC_MESSAGES/kjsembed5.mo
+share/locale/km/LC_MESSAGES/kjsembed5.mo
+share/locale/kn/LC_MESSAGES/kjsembed5.mo
+share/locale/ko/LC_MESSAGES/kjsembed5.mo
+share/locale/ku/LC_MESSAGES/kjsembed5.mo
+share/locale/lb/LC_MESSAGES/kjsembed5.mo
+share/locale/lt/LC_MESSAGES/kjsembed5.mo
+share/locale/lv/LC_MESSAGES/kjsembed5.mo
+share/locale/mai/LC_MESSAGES/kjsembed5.mo
+share/locale/mk/LC_MESSAGES/kjsembed5.mo
+share/locale/ml/LC_MESSAGES/kjsembed5.mo
+share/locale/mr/LC_MESSAGES/kjsembed5.mo
+share/locale/ms/LC_MESSAGES/kjsembed5.mo
+share/locale/nb/LC_MESSAGES/kjsembed5.mo
+share/locale/nds/LC_MESSAGES/kjsembed5.mo
+share/locale/ne/LC_MESSAGES/kjsembed5.mo
+share/locale/nl/LC_MESSAGES/kjsembed5.mo
+share/locale/nn/LC_MESSAGES/kjsembed5.mo
+share/locale/oc/LC_MESSAGES/kjsembed5.mo
+share/locale/or/LC_MESSAGES/kjsembed5.mo
+share/locale/pa/LC_MESSAGES/kjsembed5.mo
+share/locale/pl/LC_MESSAGES/kjsembed5.mo
+share/locale/ps/LC_MESSAGES/kjsembed5.mo
+share/locale/pt/LC_MESSAGES/kjsembed5.mo
+share/locale/pt_BR/LC_MESSAGES/kjsembed5.mo
+share/locale/ro/LC_MESSAGES/kjsembed5.mo
+share/locale/ru/LC_MESSAGES/kjsembed5.mo
+share/locale/se/LC_MESSAGES/kjsembed5.mo
+share/locale/si/LC_MESSAGES/kjsembed5.mo
+share/locale/sk/LC_MESSAGES/kjsembed5.mo
+share/locale/sl/LC_MESSAGES/kjsembed5.mo
+share/locale/sq/LC_MESSAGES/kjsembed5.mo
+share/locale/sr/LC_MESSAGES/kjsembed5.mo
+share/locale/sr@ijekavian/LC_MESSAGES/kjsembed5.mo
+share/locale/sr@ijekavianlatin/LC_MESSAGES/kjsembed5.mo
+share/locale/sr@latin/LC_MESSAGES/kjsembed5.mo
+share/locale/sv/LC_MESSAGES/kjsembed5.mo
+share/locale/ta/LC_MESSAGES/kjsembed5.mo
+share/locale/te/LC_MESSAGES/kjsembed5.mo
+share/locale/tg/LC_MESSAGES/kjsembed5.mo
+share/locale/th/LC_MESSAGES/kjsembed5.mo
+share/locale/tr/LC_MESSAGES/kjsembed5.mo
+share/locale/tt/LC_MESSAGES/kjsembed5.mo
+share/locale/ug/LC_MESSAGES/kjsembed5.mo
+share/locale/uk/LC_MESSAGES/kjsembed5.mo
+share/locale/uz/LC_MESSAGES/kjsembed5.mo
+share/locale/uz@cyrillic/LC_MESSAGES/kjsembed5.mo
+share/locale/vi/LC_MESSAGES/kjsembed5.mo
+share/locale/wa/LC_MESSAGES/kjsembed5.mo
+share/locale/xh/LC_MESSAGES/kjsembed5.mo
+share/locale/zh_CN/LC_MESSAGES/kjsembed5.mo
+share/locale/zh_HK/LC_MESSAGES/kjsembed5.mo
+share/locale/zh_TW/LC_MESSAGES/kjsembed5.mo