aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-01-09 18:07:25 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-01-09 18:07:25 +0000
commitc83630d56746224b7250f0983a9def633268fb81 (patch)
tree0986ea871ac4a740fbb571f0f02479c1be873707 /www
parentcec2e05355557ac61a8445324a66a51d6acc96d9 (diff)
downloadports-c83630d56746224b7250f0983a9def633268fb81.tar.gz
ports-c83630d56746224b7250f0983a9def633268fb81.zip
- Update to 0.7.0
Notes
Notes: svn path=/head/; revision=376636
Diffstat (limited to 'www')
-rw-r--r--www/nghttp2/Makefile14
-rw-r--r--www/nghttp2/distinfo4
-rw-r--r--www/nghttp2/pkg-plist2
3 files changed, 13 insertions, 7 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index 76cbfbb1ba8e..09d7ce500255 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nghttp2
-PORTVERSION= 0.6.7
+PORTVERSION= 0.7.0
CATEGORIES= www net
MASTER_SITES= https://github.com/tatsuhiro-t/${PORTNAME}/releases/download/v${PORTVERSION}/ \
LOCAL/sunpoet
@@ -12,9 +12,11 @@ COMMENT= HTTP/2.0 C Library
LICENSE= MIT
-BUILD_DEPENDS= libevent2>=2.0.8:${PORTSDIR}/devel/libevent2 \
+BUILD_DEPENDS= libev>=4.15:${PORTSDIR}/devel/libev \
+ libevent2>=2.0.8:${PORTSDIR}/devel/libevent2 \
spdylay>=1.3.0:${PORTSDIR}/www/spdylay
-LIB_DEPENDS= libevent_openssl.so:${PORTSDIR}/devel/libevent2 \
+LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev \
+ libevent_openssl.so:${PORTSDIR}/devel/libevent2 \
libspdylay.so:${PORTSDIR}/www/spdylay
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -26,12 +28,16 @@ CONFIGURE_ARGS= --disable-python-bindings \
--enable-app \
--enable-examples \
--with-spdylay
-CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+CONFIGURE_ENV= LIBEV_CFLAGS="-I${LOCALBASE}/include" \
+ LIBEV_LIBS="-L${LOCALBASE}/lib -lev" \
+ OPENSSL_CFLAGS="-I${OPENSSLINC}" \
OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl" \
ZLIB_CFLAGS="-I${INCLUDEDIR}" \
ZLIB_LIBS="-L${LIBDIR} -lz"
+CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
+LIBS+= -L${LOCALBASE}/lib -lev
USE_CXXSTD= c++11
USE_GNOME= libxml2
USE_LDCONFIG= yes
diff --git a/www/nghttp2/distinfo b/www/nghttp2/distinfo
index 7ef39a3bc6c7..cc16b237f7ff 100644
--- a/www/nghttp2/distinfo
+++ b/www/nghttp2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nghttp2-0.6.7.tar.xz) = 6cd748982f03c0039072c6a61c8dd88fe270ec34b826fb4591e5ed93f1a8376c
-SIZE (nghttp2-0.6.7.tar.xz) = 813524
+SHA256 (nghttp2-0.7.0.tar.xz) = 41765d7ed8a4790b674ac27ae5106006799de402c0f0427a71c40875e2971542
+SIZE (nghttp2-0.7.0.tar.xz) = 821656
diff --git a/www/nghttp2/pkg-plist b/www/nghttp2/pkg-plist
index 947f553fe5c6..4789b976cb3b 100644
--- a/www/nghttp2/pkg-plist
+++ b/www/nghttp2/pkg-plist
@@ -10,7 +10,7 @@ include/nghttp2/nghttp2ver.h
lib/libnghttp2.a
lib/libnghttp2.so
lib/libnghttp2.so.5
-lib/libnghttp2.so.5.2.2
+lib/libnghttp2.so.5.3.0
%%ASIO%%lib/libnghttp2_asio.a
%%ASIO%%lib/libnghttp2_asio.so
%%ASIO%%lib/libnghttp2_asio.so.0