aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-07-08 22:38:42 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-07-08 22:38:42 +0000
commitd059ac8662ee17beff2bc1c3d37ae1951c1d0f3d (patch)
tree46770ae25f1ecf1182bb95e8e0634cc2f3fcd543 /www
parentd4122db7d36adca2e2480c3cce1f33e111895d9f (diff)
downloadports-d059ac8662ee17beff2bc1c3d37ae1951c1d0f3d.tar.gz
ports-d059ac8662ee17beff2bc1c3d37ae1951c1d0f3d.zip
- strip
- remove obsolete apache-*-2.2.* conflict - add modules.d to EXAMPLESDIR - always install DOC (remove Makefile hack) - bump PORREVISION - sort pkg-plist
Notes
Notes: svn path=/head/; revision=361314
Diffstat (limited to 'www')
-rw-r--r--www/apache24/Makefile17
-rw-r--r--www/apache24/files/patch-Makefile.in20
-rw-r--r--www/apache24/pkg-plist34
3 files changed, 32 insertions, 39 deletions
diff --git a/www/apache24/Makefile b/www/apache24/Makefile
index f5933b412a60..fa769d5427c0 100644
--- a/www/apache24/Makefile
+++ b/www/apache24/Makefile
@@ -2,7 +2,7 @@
PORTNAME= apache24
PORTVERSION= 2.4.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
@@ -15,8 +15,7 @@ LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
libapr-1.so.0.5.1:${PORTSDIR}/devel/apr1 \
libpcre.so:${PORTSDIR}/devel/pcre
-CONFLICTS_INSTALL= caudium14-1.* \
- apache-*-2.2.* apache22-*
+CONFLICTS_INSTALL= caudium14-1.* apache22-*
USE_APACHE= common24
USES= tar:bzip2 iconv perl5 libtool cpe
@@ -72,10 +71,6 @@ SSL_USE= OPENSSL=yes
ETC_SUBDIRS= Includes envvars.d extra modules.d
-.if ! ${PORT_OPTIONS:MDOCS}
-MAKE_ENV+= NOPORTDOCS=yes
-.endif
-
APR_CONFIG?= ${LOCALBASE}/bin/apr-1-config
APU_CONFIG?= ${LOCALBASE}/bin/apu-1-config
@@ -156,6 +151,14 @@ post-install:
@${MKDIR} ${ETC_SUBDIRS:S|^|${STAGEDIR}${ETCDIR}/|}
${INSTALL_DATA} ${FILESDIR}/no-accf.conf ${STAGEDIR}${ETCDIR}/Includes/
${INSTALL_DATA} ${FILESDIR}/README_modules.d ${STAGEDIR}/${ETCDIR}/modules.d/
+# place for module configuration samples
+ @${MKDIR} ${STAGEDIR}/${EXAMPLESDIR}/modules.d
+ ${INSTALL_DATA} ${FILESDIR}/README_modules.d ${STAGEDIR}/${EXAMPLESDIR}/modules.d
+
+# supress warnings about all the non binary files
+ -@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/* \
+ ${STAGEDIR}${PREFIX}/bin/* \
+ ${STAGEDIR}${PREFIX}/libexec/apache24/*.so 2>/dev/null
.if ${PORT_OPTIONS:MLOG_FORENSIC}
@${INSTALL_SCRIPT} ${WRKSRC}/support/check_forensic ${STAGEDIR}${PREFIX}/sbin
diff --git a/www/apache24/files/patch-Makefile.in b/www/apache24/files/patch-Makefile.in
index bc40962301cf..532ee840ef9f 100644
--- a/www/apache24/files/patch-Makefile.in
+++ b/www/apache24/files/patch-Makefile.in
@@ -1,5 +1,5 @@
--- ./Makefile.in.orig 2012-12-17 12:50:41.000000000 +0100
-+++ ./Makefile.in 2013-10-27 15:15:14.000000000 +0100
++++ ./Makefile.in 2014-07-08 06:27:38.000000000 +0200
@@ -32,12 +32,10 @@
install-conf:
@echo Installing configuration files
@@ -91,16 +91,8 @@
install-other:
@test -d $(DESTDIR)$(logfiledir) || $(MKINSTALLDIRS) $(DESTDIR)$(logfiledir)
-@@ -224,19 +196,17 @@
- done
-
- install-man:
-- @echo Installing man pages and online manual
-+ @echo Installing man pages
- @test -d $(DESTDIR)$(mandir) || $(MKINSTALLDIRS) $(DESTDIR)$(mandir)
- @test -d $(DESTDIR)$(mandir)/man1 || $(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man1
- @test -d $(DESTDIR)$(mandir)/man8 || $(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man8
-- @test -d $(DESTDIR)$(manualdir) || $(MKINSTALLDIRS) $(DESTDIR)$(manualdir)
+@@ -231,12 +203,7 @@
+ @test -d $(DESTDIR)$(manualdir) || $(MKINSTALLDIRS) $(DESTDIR)$(manualdir)
@cp -p $(top_srcdir)/docs/man/*.1 $(DESTDIR)$(mandir)/man1
@cp -p $(top_srcdir)/docs/man/*.8 $(DESTDIR)$(mandir)/man8
- @if test "x$(RSYNC)" != "x" && test -x $(RSYNC) ; then \
@@ -109,11 +101,7 @@
- cd $(top_srcdir)/docs/manual && cp -rp * $(DESTDIR)$(manualdir); \
- cd $(DESTDIR)$(manualdir) && find . -name ".svn" -type d -print | xargs rm -rf 2>/dev/null || true; \
- fi
-+.if !defined(NOPORTDOCS)
-+ @echo Installing online manual
-+ @test -d $(DESTDIR)$(manualdir) || $(MKINSTALLDIRS) $(DESTDIR)$(manualdir)
-+ cd $(top_srcdir)/docs/manual && cp -rp * $(DESTDIR)$(manualdir);
-+.endif
++ cd $(top_srcdir)/docs/manual && cp -rp * $(DESTDIR)$(manualdir)
install-suexec:
@if test -f $(builddir)/support/suexec; then \
diff --git a/www/apache24/pkg-plist b/www/apache24/pkg-plist
index 3b14da652c6c..37cb0a832c19 100644
--- a/www/apache24/pkg-plist
+++ b/www/apache24/pkg-plist
@@ -279,6 +279,7 @@ sbin/split-logfile
@unexec if cmp -s %D/%%ETCDIR%%/mime.types %D/%%EXAMPLESDIR%%/mime.types; then rm -f %D/%%ETCDIR%%/mime.types; fi
%%EXAMPLESDIR%%/mime.types
@exec [ -f %D/%%ETCDIR%%/mime.types ] || cp %D/%%EXAMPLESDIR%%/mime.types %D/%%ETCDIR%%/mime.types
+%%EXAMPLESDIR%%/modules.d/README_modules.d
%%WWWDIR%%/cgi-bin/printenv
%%WWWDIR%%/cgi-bin/printenv.vbs
%%WWWDIR%%/cgi-bin/printenv.wsf
@@ -545,22 +546,23 @@ sbin/split-logfile
%%WWWDIR%%/icons/world2.gif
%%WWWDIR%%/icons/world2.png
%%WWWDIR%%/icons/xml.png
-@dirrm %%WWWDIR%%/icons/small
-@dirrm %%WWWDIR%%/icons
-@dirrm %%WWWDIR%%/error/include
-@dirrm %%WWWDIR%%/error
-@dirrmtry %%WWWDIR%%/data
-@dirrmtry %%WWWDIR%%/cgi-bin
-@dirrmtry %%WWWDIR%%
-@dirrm %%EXAMPLESDIR%%/extra
-@dirrm %%EXAMPLESDIR%%
-@dirrm %%DATADIR%%/build
-@dirrm %%DATADIR%%
-@dirrmtry libexec/apache24
-@dirrmtry include/apache24
@unexec rm -f %D/%%ETCDIR%%/httpd.conf.bak 2> /dev/null || true
-@dirrmtry %%ETCDIR%%/modules.d
-@dirrmtry %%ETCDIR%%/extra
-@dirrmtry %%ETCDIR%%/envvars.d
@dirrmtry %%ETCDIR%%/Includes
+@dirrmtry %%ETCDIR%%/envvars.d
+@dirrmtry %%ETCDIR%%/extra
+@dirrmtry %%ETCDIR%%/modules.d
@dirrmtry %%ETCDIR%%
+@dirrmtry include/apache24
+@dirrmtry libexec/apache24
+@dirrm %%DATADIR%%/build
+@dirrm %%DATADIR%%
+@dirrm %%EXAMPLESDIR%%/extra
+@dirrm %%EXAMPLESDIR%%/modules.d
+@dirrm %%EXAMPLESDIR%%
+@dirrmtry %%WWWDIR%%/cgi-bin
+@dirrmtry %%WWWDIR%%/data
+@dirrm %%WWWDIR%%/error/include
+@dirrm %%WWWDIR%%/error
+@dirrm %%WWWDIR%%/icons/small
+@dirrm %%WWWDIR%%/icons
+@dirrmtry %%WWWDIR%%