aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-10-20 17:21:52 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-10-20 17:21:52 +0000
commitdd6724073c36fff24dc18242866907890e9234dd (patch)
tree3b3c026ebfccbb31f396b69689daec3b23732c1a /www
parent4f746444519dbf456aab3964dfe1cd55990ed470 (diff)
downloadports-dd6724073c36fff24dc18242866907890e9234dd.tar.gz
ports-dd6724073c36fff24dc18242866907890e9234dd.zip
Fix compatibility with curl 7.66
- Bump PORTREVISION for package change PR: 241280 Submitted by: olivier
Notes
Notes: svn path=/head/; revision=515062
Diffstat (limited to 'www')
-rw-r--r--www/p5-WWW-Curl/Makefile2
-rw-r--r--www/p5-WWW-Curl/files/patch-Curl.xs42
-rw-r--r--www/p5-WWW-Curl/files/patch-Makefile.PL10
3 files changed, 50 insertions, 4 deletions
diff --git a/www/p5-WWW-Curl/Makefile b/www/p5-WWW-Curl/Makefile
index 518478c2e16d..629463ad3a6b 100644
--- a/www/p5-WWW-Curl/Makefile
+++ b/www/p5-WWW-Curl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= WWW-Curl
PORTVERSION= 4.17
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www ftp perl5
MASTER_SITES= CPAN \
http://curl.haxx.se/libcurl/perl/
diff --git a/www/p5-WWW-Curl/files/patch-Curl.xs b/www/p5-WWW-Curl/files/patch-Curl.xs
index b0e42ee55023..968e3619f76e 100644
--- a/www/p5-WWW-Curl/files/patch-Curl.xs
+++ b/www/p5-WWW-Curl/files/patch-Curl.xs
@@ -1,6 +1,25 @@
---- Curl.xs.orig 2019-09-17 09:12:44 UTC
+--- Curl.xs.orig 2014-02-21 16:08:30 UTC
+++ Curl.xs
-@@ -73,7 +73,7 @@ typedef struct {
+@@ -18,6 +18,10 @@
+ #include <curl/easy.h>
+ #include <curl/multi.h>
+
++#ifdef CURLINC_MULTI_H
++#define __CURL_MULTI_H
++#endif
++
+ #define header_callback_func writeheader_callback_func
+
+ /* Do a favor for older perl versions */
+@@ -38,6 +42,7 @@ typedef enum {
+ SLIST_HTTPHEADER = 0,
+ SLIST_QUOTE,
+ SLIST_POSTQUOTE,
++ SLIST_CONNECT_TO,
+ #ifdef CURLOPT_RESOLVE
+ SLIST_RESOLVE,
+ #endif
+@@ -73,7 +78,7 @@ typedef struct {
#ifdef __CURL_MULTI_H
struct CURLM *curlm;
#else
@@ -9,3 +28,22 @@
#endif
} perl_curl_multi;
+@@ -129,6 +134,10 @@ slist_index(int option)
+ case CURLOPT_POSTQUOTE:
+ return SLIST_POSTQUOTE;
+ break;
++ case CURLOPT_CONNECT_TO:
++ return SLIST_CONNECT_TO;
++ break;
++
+ #ifdef CURLOPT_RESOLVE
+ case CURLOPT_RESOLVE:
+ return SLIST_RESOLVE;
+@@ -754,6 +763,7 @@ curl_easy_setopt(self, option, value, push=0)
+ case CURLOPT_HTTPHEADER:
+ case CURLOPT_QUOTE:
+ case CURLOPT_POSTQUOTE:
++ case CURLOPT_CONNECT_TO:
+ #ifdef CURLOPT_RESOLVE
+ case CURLOPT_RESOLVE:
+ #endif
diff --git a/www/p5-WWW-Curl/files/patch-Makefile.PL b/www/p5-WWW-Curl/files/patch-Makefile.PL
index 9d1115ce54ea..93d9de7d38e9 100644
--- a/www/p5-WWW-Curl/files/patch-Makefile.PL
+++ b/www/p5-WWW-Curl/files/patch-Makefile.PL
@@ -1,6 +1,6 @@
--- Makefile.PL.orig 2014-02-21 16:08:09 UTC
+++ Makefile.PL
-@@ -121,6 +121,7 @@ if (!defined($curl_h)) {
+@@ -121,13 +121,14 @@ if (!defined($curl_h)) {
open (H, "<", $curl_h) or die ("Cannot open $curl_h: ".$!);
while(<H>) {
if (/^#define (CURL[A-Za-z0-9_]*)/) {
@@ -8,3 +8,11 @@
push @syms, $1;
}
}
+ close H;
+
+ for my $e (sort @syms) {
+- if($e =~ /(OBSOLETE|^CURL_EXTERN|_LAST\z|_LASTENTRY\z)/) {
++ if($e =~ /(OBSOLETE|^CURL_EXTERN|_LAST\z|_LASTENTRY\z|^CURLINC_)/) {
+ next;
+ }
+ my ($group) = $e =~ m/^([^_]+_)/;