aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2017-04-14 12:18:18 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2017-04-14 12:18:18 +0000
commitea0de7d06624b079d5bf21c63de1d05df9a49834 (patch)
tree828f787bc406a8429b375e53a5c2e76e223941fa /www
parente8fd22852684068364c0666f38b857f16113cbf4 (diff)
downloadports-ea0de7d06624b079d5bf21c63de1d05df9a49834.tar.gz
ports-ea0de7d06624b079d5bf21c63de1d05df9a49834.zip
New port, www/rubygem-rack-timeout: Abort requests that are taking too long
Adding www/rubygem-rack-timeout, because it is a dependency of the upcoming www/mastodon port. WWW: http://github.com/heroku/rack-timeout/ Approved by: swills (mentor, implicit)
Notes
Notes: svn path=/head/; revision=438505
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-rack-timeout/Makefile19
-rw-r--r--www/rubygem-rack-timeout/distinfo3
-rw-r--r--www/rubygem-rack-timeout/pkg-descr9
4 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a6b317962eb0..7c343c515bd8 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2060,6 +2060,7 @@
SUBDIR += rubygem-rack-proxy
SUBDIR += rubygem-rack-ssl
SUBDIR += rubygem-rack-test
+ SUBDIR += rubygem-rack-timeout
SUBDIR += rubygem-rack15
SUBDIR += rubygem-rack16
SUBDIR += rubygem-rails4
diff --git a/www/rubygem-rack-timeout/Makefile b/www/rubygem-rack-timeout/Makefile
new file mode 100644
index 000000000000..368d796261f8
--- /dev/null
+++ b/www/rubygem-rack-timeout/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= rack-timeout
+PORTVERSION= 0.4.2
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Abort requests that are taking too long
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+NO_ARCH= yes
+
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-rack-timeout/distinfo b/www/rubygem-rack-timeout/distinfo
new file mode 100644
index 000000000000..b624c9f84f42
--- /dev/null
+++ b/www/rubygem-rack-timeout/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492171633
+SHA256 (rubygem/rack-timeout-0.4.2.gem) = b6268bba8794c702b024f835a0e1854a67d7e75cbd5323d982185fdd3fa2a153
+SIZE (rubygem/rack-timeout-0.4.2.gem) = 22016
diff --git a/www/rubygem-rack-timeout/pkg-descr b/www/rubygem-rack-timeout/pkg-descr
new file mode 100644
index 000000000000..ee1044df553a
--- /dev/null
+++ b/www/rubygem-rack-timeout/pkg-descr
@@ -0,0 +1,9 @@
+Rack::Timeout is middleware, which aborts requests that have been running for
+longer than a specified timeout.
+
+Rack::Timeout is not a solution to the problem of long-running requests, it is a
+debug and remediation tool. Developers should track rack-timeout's data and
+address recurring instances of particular timeouts, for example, by refactoring
+code so it runs faster or offsetting lengthy work to happen asynchronously.
+
+WWW: http://github.com/heroku/rack-timeout/