aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-11-14 16:12:56 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-11-14 16:12:56 +0000
commit30a183cdd9faf4c65a08818c285c8d9351e43ad3 (patch)
treedbe08499461c3eea79dce8b1eca87e2699ef0d1c /x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt
parent1ff45cdd0ae918b61cf33786436856d37aa2dcfb (diff)
downloadports-30a183cdd9faf4c65a08818c285c8d9351e43ad3.tar.gz
ports-30a183cdd9faf4c65a08818c285c8d9351e43ad3.zip
Importing KDE Frameworks into the ports tree (required for newer KDE Desktop and Applications)
KDE Frameworks is a collection of libraries and software frameworks by KDE that serve as technological foundation for KDE Plasma 5 and KDE Applications distributed under the GNU Lesser General Public License (LGPL) [1]. The work is based on what we have in the KDE testing repo [2]. This is the next big step in updating the KDE Desktop and its Applications to anything less dusty. With this change, `USES=kde:5` is now a valid option. Ports that need to depend on KDE Framework can now set: USES=kde:5 USE_KDE=<framework1> <framework2> ... <frameworkX> For example: www/qupzilla-qt5 can depend on sysutils/kf5-kwallet via: KWALLET_USE= KDE=wallet I would like to thank Raphael and Adriaan for reviewing the ports in the testing repo :) [1] https://en.wikipedia.org/wiki/KDE_Frameworks [2] http://src.mouf.net/area51/log/branches/plasma5 Reviewed by: rakuco, mat, groot_kde.org Approved by: rakuco (maintainer) Differential Revision: https://reviews.freebsd.org/D8329
Notes
Notes: svn path=/head/; revision=426118
Diffstat (limited to 'x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt')
-rw-r--r--x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt b/x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..c7e1c60ba006
--- /dev/null
+++ b/x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt
@@ -0,0 +1,21 @@
+Do not try to run the svg validation script.
+
+--- CMakeLists.txt.orig 2016-09-27 06:30:58 UTC
++++ CMakeLists.txt
+@@ -64,16 +64,6 @@ function(generate_binary_resource target
+ endfunction()
+ endif()
+
+-find_program(BASH_EXE bash)
+-if (BASH_EXE)
+- file(GLOB_RECURSE SVGS "*.svg")
+- add_custom_target(breeze-validate-svg ALL
+- COMMAND ${BASH_EXE} ${CMAKE_SOURCE_DIR}/validate_svg.sh
+- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+- SOURCES ${SVGS}
+- )
+-endif()
+-
+ add_subdirectory(autotests)
+ add_subdirectory(icons)
+ add_subdirectory(icons-dark)