aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-11-23 18:46:43 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-11-23 18:46:43 +0000
commit65af48315158144fceeb5eee139f7ef00db32d7d (patch)
tree8a9801b1e16c9f0c5ffd5ff7cc553ce35339ecd1 /x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt
parent6aaddac97620c8ae58e821d6cb4c705143538868 (diff)
downloadports-65af48315158144fceeb5eee139f7ef00db32d7d.tar.gz
ports-65af48315158144fceeb5eee139f7ef00db32d7d.zip
Update KDE Frameworks to 5.76
November 07, 2020. KDE today announces the release of KDE Frameworks 5.76.0. KDE Frameworks are 70 addon libraries to Qt which provide a wide variety of commonly needed functionality in mature, peer reviewed and well tested libraries with friendly licensing terms. For an introduction see the KDE Frameworks release announcement. This release is part of a series of planned monthly releases making improvements available to developers in a quick and predictable manner. Announcement: https://kde.org/announcements/kde-frameworks-5.76.0/ PR: 251135 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=556116
Diffstat (limited to 'x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt')
-rw-r--r--x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt b/x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt
index 52434680ab3b..52c478771510 100644
--- a/x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt
+++ b/x11-themes/kf5-breeze-icons/files/patch-CMakeLists.txt
@@ -1,14 +1,16 @@
---- CMakeLists.txt.orig 2020-10-04 09:45:37 UTC
+--- CMakeLists.txt.orig 2020-11-07 11:32:04 UTC
+++ CMakeLists.txt
-@@ -25,11 +25,11 @@ include(GtkUpdateIconCache)
+@@ -25,13 +25,13 @@ include(GtkUpdateIconCache)
set(REQUIRED_QT_VERSION 5.12.0)
# Find Python 3
-find_package (Python 3 COMPONENTS Interpreter)
+find_package (Python3 COMPONENTS Interpreter)
--if(Python_FOUND)
-+if(Python3_FOUND)
+ # FIXME: This is a temporary solution to unbreak KDE's Windows CI.
+ # Remove "NOT WIN32" when icon generation works on Windows.
+-if(Python_FOUND AND NOT WIN32)
++if(Python3_FOUND AND NOT WIN32)
# Find lxml Python 3 module
- exec_program(${Python_EXECUTABLE}
+ exec_program(${Python3_EXECUTABLE}