aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/qogir-gtk-themes/Makefile
diff options
context:
space:
mode:
authorAlexander Vereeken <Alexander88207@protonmail.com>2021-03-20 18:37:35 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-05-01 05:58:47 +0000
commit823dccc5d26f80899401d53764a368f71e0541cf (patch)
tree081c4ef8d507a8fe795da00757fc086fedd866bc /x11-themes/qogir-gtk-themes/Makefile
parent4127a5020b170756fb425e3024d0cc9ac2097325 (diff)
downloadports-823dccc5d26f80899401d53764a368f71e0541cf.tar.gz
ports-823dccc5d26f80899401d53764a368f71e0541cf.zip
x11-themes/qogir-gtk-themes: add new port
Qogir is a flat Design theme for GTK 3, GTK 2 and Gnome-Shell. Supported Desktop Environments: * Cinnamon * Gnome-Shell * Metacity * Plank * Unity * Xfce https://github.com/vinceliuice/Qogir-theme PR: 252774 Reviewed by: tcberner Differential Revision: https://reviews.freebsd.org/D28206
Diffstat (limited to 'x11-themes/qogir-gtk-themes/Makefile')
-rw-r--r--x11-themes/qogir-gtk-themes/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-themes/qogir-gtk-themes/Makefile b/x11-themes/qogir-gtk-themes/Makefile
new file mode 100644
index 000000000000..16065893fc79
--- /dev/null
+++ b/x11-themes/qogir-gtk-themes/Makefile
@@ -0,0 +1,30 @@
+# Created by: Alexander Vereeken <Alexander88207@protonmail.com>
+
+PORTNAME= qogir-gtk-themes
+DISTVERSION= 2021-02-09
+CATEGORIES= x11-themes
+
+MAINTAINER= Alexander88207@protonmail.com
+COMMENT= Qogir is a flat Design theme for GTK
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= bash>0:shells/bash
+RUN_DEPENDS= gtk-murrine-engine>0:x11-themes/gtk-murrine-engine \
+ gtk-engines2>0:x11-themes/gtk-engines2
+
+USES= shebangfix
+SHEBANG_FILES= install.sh
+
+USE_GITHUB= yes
+GH_ACCOUNT= vinceliuice
+GH_PROJECT= Qogir-theme
+NO_ARCH= yes
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/themes
+ ${WRKSRC}/install.sh -d ${STAGEDIR}${PREFIX}/share/themes
+
+.include <bsd.port.mk>