aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/plib/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-08-03 09:28:57 +0000
committerSatoshi Asami <asami@FreeBSD.org>2000-08-03 09:28:57 +0000
commitc6bcad2436d925c98052ed292bd0794ae0e34b45 (patch)
tree4752ebd6e8eb5959ebf00516e4ecf7156215bbce /x11-toolkits/plib/Makefile
parentfbd121eee966abfc21d176cbede935ecd6bf1a34 (diff)
downloadports-c6bcad2436d925c98052ed292bd0794ae0e34b45.tar.gz
ports-c6bcad2436d925c98052ed292bd0794ae0e34b45.zip
(1) Add new variable, XFREE86_VERSION, to specify which version of
XFree86 (3 or 4) to depend to when USE_XLIB is set. XFREE86_VERSION defaults to 3 for now, but adventurous users can override it in /etc/make.conf. When XFREE86_VERSION=3, USE_XLIB will add a dependency to x11/XFree86; when it is set to 4, the dependency will be to x11/XFree86-4-libraries. When XFREE86_VERSION=4, the PKG_IGNORE_DEPENDS and ALWAYS_BUILD_DEPENDS hacks to avoid messing with XFree86 are turned off. Since XFree86 version 4 includes some software that used to be separate ports, when XFREE86_VERSION=3 the following variables are provided: USE_DGS LIB_DEPENDS on x11/dgs USE_FREETYPE LIB_DEPENDS on print/freetype USE_MESA LIB_DEPENDS on graphics/Mesa3 USE_XPM LIB_DEPENDS on graphics/xpm When XFREE86_VERSION=4, these variables have no effect. The LIB_DEPENDS in the tree for the above four ports have all been converted to the USE_* counterparts. For your information, this is the count of the number of ports: USE_DGS 0 USE_FREETYPE 16 USE_MESA 36 USE_XPM 236 There is a new variable, XAWVER, which is set to 6 when XFREE86_VERSION=3 and 7 when XFREE86_VERSION=4. This is also passed to PLIST_SUB so ports that build Xaw based shared libraries can use this variable to substitute the shlib version number. There is also a provision of using a separate mtree file for XFREE86_VERSION=4, but that part is not enabled yet. Reviewed by: the ports list Tested by: make index (XFREE86_VERSION=3 only) (2) Add hebrew to list of valid categories. Submitted by: nbm
Notes
Notes: svn path=/head/; revision=31272
Diffstat (limited to 'x11-toolkits/plib/Makefile')
-rw-r--r--x11-toolkits/plib/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/x11-toolkits/plib/Makefile b/x11-toolkits/plib/Makefile
index 19d5ad507d1d..277020daf31d 100644
--- a/x11-toolkits/plib/Makefile
+++ b/x11-toolkits/plib/Makefile
@@ -12,12 +12,11 @@ MASTER_SITES= http://plib.sourceforge.net/dist/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= GL.14:${PORTSDIR}/graphics/Mesa3
-
USE_X_PREFIX= yes
+USE_MESA= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS=-I${X11BASE}/include
-CONFIGURE_ARGS+= --includedir=$(PREFIX)/include/plib \
+CONFIGURE_ENV= CPPFLAGS=-I${X11BASE}/include
+CONFIGURE_ARGS= --includedir=$(PREFIX)/include/plib \
--with-glut=${PREFIX}
USE_GMAKE= yes
USE_NEWGCC= yes