aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wlroots/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-04-12 09:43:56 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-06-23 18:07:18 +0000
commitf2820b6cc2170feef17989c422f2cf46644a5b57 (patch)
tree97998c6f87a571c33be6621c0f37651bd0823898 /x11-toolkits/wlroots/Makefile
parentd69ea6ec51818b161d974dfad2d14ffc279d1d3a (diff)
downloadports-f2820b6cc2170feef17989c422f2cf46644a5b57.tar.gz
ports-f2820b6cc2170feef17989c422f2cf46644a5b57.zip
x11-toolkits/wlroots: update to 0.14.0
Changes: https://github.com/swaywm/wlroots/releases/tag/0.14.0 Reported by: GitHub (watch releases)
Diffstat (limited to 'x11-toolkits/wlroots/Makefile')
-rw-r--r--x11-toolkits/wlroots/Makefile37
1 files changed, 18 insertions, 19 deletions
diff --git a/x11-toolkits/wlroots/Makefile b/x11-toolkits/wlroots/Makefile
index 74eaa8aada3e..dcb789f0f170 100644
--- a/x11-toolkits/wlroots/Makefile
+++ b/x11-toolkits/wlroots/Makefile
@@ -1,12 +1,10 @@
PORTNAME= wlroots
-DISTVERSION= 0.13.0
-PORTREVISION= 4
+DISTVERSION= 0.14.0
CATEGORIES= x11-toolkits
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES+= 7c0e2a271a4c.patch:-p1 # https://github.com/swaywm/wlroots/pull/2064
-PATCHFILES+= e1b5323f56c3.patch:-p1 # https://github.com/swaywm/wlroots/pull/2064
-PATCHFILES+= d0c1f0c0b637.patch:-p1 # https://github.com/swaywm/wlroots/pull/2908
+PATCHFILES+= 55a8d225cf8c.patch:-p1 # https://github.com/swaywm/wlroots/pull/2064
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Modular Wayland compositor library
@@ -20,38 +18,34 @@ BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
LIB_DEPENDS= libudev.so:devel/libudev-devd \
libdrm.so:graphics/libdrm \
libwayland-server.so:graphics/wayland \
+ libseat.so:sysutils/seatd \
libinput.so:x11/libinput \
libxkbcommon.so:x11/libxkbcommon
-RUN_DEPENDS= libudev-devd>=0.4.1:devel/libudev-devd \
- mesa-dri>0:graphics/mesa-dri
+RUN_DEPENDS= libudev-devd>=0.4.1:devel/libudev-devd
USES= compiler:c11 gl meson pkgconfig xorg
USE_GITHUB= yes
-USE_GL= egl gbm glesv2
+USE_GL= gbm
USE_XORG= pixman
USE_LDCONFIG= yes
GH_ACCOUNT= swaywm
-MESON_ARGS= -Dexamples=false
+MESON_ARGS= -Dexamples=false -Drenderers=${RENDERERS:ts,}
-OPTIONS_DEFINE= LIBSEAT NVIDIA UUID X11
-OPTIONS_DEFAULT=LIBSEAT UUID X11
+OPTIONS_DEFINE= NVIDIA OPENGL X11
+OPTIONS_DEFAULT=OPENGL X11
OPTIONS_SUB= yes
-LIBSEAT_DESC= DRM sessions with/without root via libseat
-LIBSEAT_LIB_DEPENDS= libseat.so:sysutils/seatd
-LIBSEAT_MESON_ENABLED= libseat
-
NVIDIA_DESC= EGLStreams support for DRM backend (experimental)
NVIDIA_PATCH_SITES= https://github.com/danvd/${GH_PROJECT}-eglstreams/commit/:nvidia
-NVIDIA_PATCHFILES= eba4b66f92ca.patch:-p1:nvidia # https://github.com/swaywm/wlroots/pull/2769
+NVIDIA_PATCHFILES= b78146d76ab0.patch:-p1:nvidia # https://github.com/swaywm/wlroots/pull/2769
+NVIDIA_IMPLIES= OPENGL
.if make(makesum)
.MAKEFLAGS: WITH+=NVIDIA
.endif
-# uuid_create() is random on NetBSD and OpenBSD but not DragonFly and FreeBSD
-# See also https://github.com/netbsd/src/commit/8651e9a438af
-UUID_DESC= Exported surfaces to use random UUIDs via libuuid
-UUID_LIB_DEPENDS= libuuid.so:misc/e2fsprogs-libuuid
+OPENGL_RUN_DEPENDS= mesa-dri>0:graphics/mesa-dri
+OPENGL_USE= GL=egl,glesv2
+OPENGL_VARS= RENDERERS+=gles2
X11_LIB_DEPENDS= libxcb-errors.so:x11/xcb-util-errors \
libxcb-render-util.so:x11/xcb-util-renderutil \
@@ -61,4 +55,9 @@ X11_RUN_DEPENDS= xwayland-devel>0:x11-servers/xwayland-devel
X11_USE= XORG=xcb
X11_MESON_ENABLED= x11-backend xwayland
+post-patch:
+# Extract (snapshot) version from the port instead of meson.build
+ @${REINPLACE_CMD} "/STR/s/meson.project_version()/'${DISTVERSIONFULL}'/" \
+ ${WRKSRC}/include/wlr/meson.build
+
.include <bsd.port.mk>