aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wxgtk31/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-12 07:17:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-12 07:17:10 +0000
commit80b90892bead3d4c4d1cfeac64415eeee5772eab (patch)
treeca21688feef2b18e4bc0daf5d6f5bc608ff380c2 /x11-toolkits/wxgtk31/Makefile
parentd8648995465a515a2f0bd75b0a0b2477d65aa2a3 (diff)
downloadports-80b90892bead3d4c4d1cfeac64415eeee5772eab.tar.gz
ports-80b90892bead3d4c4d1cfeac64415eeee5772eab.zip
x11-toolkits/wxgtk31: Change to gtk3 because it is the latest gtk version
Also remove the stray file wxmsw.mo that caused conflict with wxgtk30. This patch is a portion of the patch from the bug#228904. PR: 228904 Submitted by: Greg V <greg@unrelenting.technology>
Notes
Notes: svn path=/head/; revision=472232
Diffstat (limited to 'x11-toolkits/wxgtk31/Makefile')
-rw-r--r--x11-toolkits/wxgtk31/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/x11-toolkits/wxgtk31/Makefile b/x11-toolkits/wxgtk31/Makefile
index 700b7350d466..67194e5f4829 100644
--- a/x11-toolkits/wxgtk31/Makefile
+++ b/x11-toolkits/wxgtk31/Makefile
@@ -3,8 +3,9 @@
PORTNAME= wx
DISTVERSIONPREFIX= v
DISTVERSION= 3.1.1
+PORTREVISION= 1
CATEGORIES= x11-toolkits
-PKGNAMESUFFIX= 31-gtk2
+PKGNAMESUFFIX= 31-gtk3
MAINTAINER= yuri@FreeBSD.org
COMMENT= GUI toolkit (wxWidgets) with GTK+ bindings
@@ -29,7 +30,7 @@ GH_PROJECT= wxWidgets
GNU_CONFIGURE= yes
USE_XORG= x11 sm xxf86vm xtst
USE_GL= gl glu
-USE_GNOME= cairo gdkpixbuf2 gtk20
+USE_GNOME= cairo gdkpixbuf2 gtk30
USE_LDCONFIG= yes
USE_CXXSTD= c++11
CONFIGURE_ARGS= --with-libpng=sys \
@@ -38,7 +39,7 @@ CONFIGURE_ARGS= --with-libpng=sys \
--with-zlib=sys \
--with-expat=sys \
--with-opengl \
- --with-gtk \
+ --with-gtk=3 \
--without-gnomevfs \
--disable-epollloop \
--disable-joystick \
@@ -66,7 +67,7 @@ MSPACK_CONFIGURE_WITH= libmspack
MSPACK_LIB_DEPENDS= libmspack.so:archivers/libmspack
WEBKIT_CONFIGURE_ENABLE= webview
-WEBKIT_LIB_DEPENDS= libwebkitgtk-1.0.so:www/webkit-gtk2
+WEBKIT_LIB_DEPENDS= libwebkit2gtk-4.0.so:www/webkit2-gtk3
.include <bsd.port.pre.mk>
@@ -78,4 +79,7 @@ CONFIGURE_ARGS+=--disable-precomp-headers
post-build-NLS-on:
@${DO_MAKE_BUILD} allmo -C ${BUILD_WRKSRC}/locale
+post-install-NLS-on: # stray file: https://trac.wxwidgets.org/ticket/18147
+ @${RM} ${STAGEDIR}${PREFIX}/share/locale/it/LC_MESSAGES/wxmsw.mo
+
.include <bsd.port.post.mk>