aboutsummaryrefslogtreecommitdiff
path: root/x11/eaglemode/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-02-26 15:22:37 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-02-26 15:22:37 +0000
commitd613b75b1d87505cc967bc6f8b7a419b2d57be5b (patch)
treefb8dfa0620864eed2a359680644745507734b86a /x11/eaglemode/Makefile
parent448b972896fbb34deed41c2bf9c30b12c6b16bc6 (diff)
downloadports-d613b75b1d87505cc967bc6f8b7a419b2d57be5b.tar.gz
ports-d613b75b1d87505cc967bc6f8b7a419b2d57be5b.zip
- Update multimedia/libxine to 1.2.1 with a commit merged from hg
to fix DVB support. (which still is broken for tuners using hardware pid filtering, like when running webcamd with "-m dvb-usb-init.force_pid_filter_usage=1".) - Add patches to fix build of ports depending on libxine to: audio/amarok, graphics/gimageview [1], graphics/pornview [1], graphics/osg [2], graphics/osg-devel [2], multimedia/emotion, x11/kdelibs4 [3], multimedia/kmplayer, multimedia/konverter, multimedia/qdvdauthor [4], multimedia/vdr-plugin-xineliboutput, multimedia/xfce4-media [5], multimedia/xine_artsplugin, multimedia/k9copy-kde4 [6] - Fix RUN_DEPENDS= xine... which should be LIB_DEPENDS for audio/atunes . [7] - Mark multimedia/phonon-xine BROKEN which refuses to build with libxine 1.2.x and is deprecated upstream. [3] - Disable XINE knob for x11/eaglemode for which I don't have a fix. [2] - Note: multimedia/kaffeine runs after rakuco's x11/kdelibs4 fix, but it only shows a green window at least with mp4 or ts files. (avi files and audio still work.) It seems the kaffeine developers have found this too and are now switching away from libxine in their git repo - so I guess we'll have a broken kaffeine at least until they release a new version. - Bump PORTREVISIONs for ports depending on libxine by default. - Add optional libbluray support to multimedia/libxine and multimedia/vdr-plugin-xineliboutput. PR: ports/165057 [6] Submitted by: nox (self) [6], rakuco [3] Approved by: dinoex (maintainer, via irc) [1], amdmi3 (maintainer, via private email) [2], kde@ (rakuco, via irc) [3], Phil Oleson <oz@nixil.net> (maintainer, via private email) [4], xfce@ (rene, via irc) [5], Eduardo Gielamo Oliveira <egoliveira@gmail.com> (maintainer) [6], lme (maintainer, via irc) [7] Thanx to: Darren Salt (upstream libxine maintainer) for a few hints on irc to help with patching ports depending on deprecated libxine features
Notes
Notes: svn path=/head/; revision=292268
Diffstat (limited to 'x11/eaglemode/Makefile')
-rw-r--r--x11/eaglemode/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11/eaglemode/Makefile b/x11/eaglemode/Makefile
index 53895f2e797d..d58141fb2668 100644
--- a/x11/eaglemode/Makefile
+++ b/x11/eaglemode/Makefile
@@ -7,7 +7,7 @@
PORTNAME= eaglemode
PORTVERSION= 0.82.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -31,7 +31,7 @@ BUILD_ARGS+= ${lib}-inc-dir="${LOCALBASE}/include" \
${lib}-lib-dir="${LOCALBASE}/lib"
.endfor
-OPTIONS= XINE "Video playback support through libxine" on \
+OPTIONS= XINE "Video playback support through libxine" off \
RSVG "SVG support throute librsvg" on
.include <bsd.port.options.mk>
@@ -41,10 +41,11 @@ BROKEN= Does not build on 6.x
.endif
.if !defined(WITHOUT_XINE)
-LIB_DEPENDS+= xine.1:${PORTSDIR}/multimedia/libxine
+LIB_DEPENDS+= xine.2:${PORTSDIR}/multimedia/libxine
BUILD_ARGS+= xine-inc-dir="${LOCALBASE}/include" \
xine-lib-dir="${LOCALBASE}/lib"
PLIST_SUB+= EMAV=""
+BROKEN= does not build with libxine 1.2.x
.else
PLIST_SUB+= EMAV="@comment "
.endif