aboutsummaryrefslogtreecommitdiff
path: root/x11/kf5-kdelibs4support
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-07-08 22:14:10 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-07-09 17:36:35 +0000
commitc0f139b89306c012b33bdd4d676b107305ba3e06 (patch)
tree02588523ca26bd83647873708e04d2c1bdd56495 /x11/kf5-kdelibs4support
parentba93bcdc15399175b77e3ae109a6ed37807b1364 (diff)
downloadports-c0f139b89306c012b33bdd4d676b107305ba3e06.tar.gz
ports-c0f139b89306c012b33bdd4d676b107305ba3e06.zip
*/kf5-*: (KDE Frameworks) lighten dependencies
- ECM (extra-cmake-modules) is only ever a build-dep and was missing in some places where it was previously pulled in implicitly - Qt testlib is only a build-dep While here - conventionally, the _build and _run items in USE_KDE and USE_QT are sorted to the end, and they start a new line in the Makefile - remove tcberner's created-line (confirmed on IRC) - use DISTVERSION everywhere - reduce inter-framework dependencies using the tooling proposed by tcberner in https://reviews.freebsd.org/D27304 Some PORTREVISION may have jumped by more than 1, since this commit is a squash of a long string of updates where I may have bumped a port once for ecm_build, and a second time for other lightening-up.
Diffstat (limited to 'x11/kf5-kdelibs4support')
-rw-r--r--x11/kf5-kdelibs4support/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11/kf5-kdelibs4support/Makefile b/x11/kf5-kdelibs4support/Makefile
index 410cd97306af..09b2cd9b521c 100644
--- a/x11/kf5-kdelibs4support/Makefile
+++ b/x11/kf5-kdelibs4support/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kdelibs4support
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -10,15 +11,16 @@ BUILD_DEPENDS= p5-URI>=0:net/p5-URI
USES= cmake compiler:c++11-lib gettext kde:5 qt:5 shebangfix \
tar:xz xorg
USE_KDE= auth bookmarks codecs completion config configwidgets \
- coreaddons crash dbusaddons doctools_build emoticons globalaccel guiaddons \
+ coreaddons crash dbusaddons emoticons globalaccel guiaddons \
i18n iconthemes itemviews jobwidgets kded kio notifications \
- parts service solid sonnet textwidgets unitconversion \
+ parts service solid textwidgets unitconversion \
widgetsaddons windowsystem xmlgui \
+ doctools_build ecm_build \
designerplugin_build designerplugin_run \
itemmodels_run
-USE_QT= buildtools_build concurrent core dbus designer gui network \
- printsupport qmake_build svg testlib widgets \
- x11extras xml
+USE_QT= concurrent core dbus designer gui network \
+ printsupport svg widgets x11extras xml \
+ buildtools_build qmake_build testlib_build
USE_XORG= ice sm x11 xext
SHEBANG_FILES= src/kio/fileshareset