aboutsummaryrefslogtreecommitdiff
path: root/x11/libxfce4menu/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-01-02 16:36:33 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-01-02 16:36:33 +0000
commitb2f2269daff8c7e224099d352e652241fbdfcb7b (patch)
tree27b902ea7af0a7d6abc54b964847536e36093b87 /x11/libxfce4menu/Makefile
parent0a2af555796c3880231fff24f17bf146795a8887 (diff)
downloadports-b2f2269daff8c7e224099d352e652241fbdfcb7b.tar.gz
ports-b2f2269daff8c7e224099d352e652241fbdfcb7b.zip
Welcome XFCE 4.16 to the FreeBSD ports tree!
Upstream announce: https://xfce.org/about/news/?post=1608595200 This XFCE release dropped support for GTK2 plugins and also dropped GTK2 from all components. WARNING: please check UPDATING before upgrading your packages. In case of problems also read the libexo pkg-message. Due to this some panel plugins and libraries will be removed since they cannot compile anymore: - print/xfce4-print - x11/xfce4-quicklauncher-plugin - x11/xfce4-wmdock-plugin - x11-toolkits/libxfce4gui These further components also fail to build or work and are being marked BROKEN, deprecated and marked for removal: - science/xfce4-equake-plugin - x11/xfce4-embed-plugin - deskutils/orage - deskutils/xfce4-volumed [1] deskutils/xfce4-notes-plugin will be also marked BROKEN, but there is active development in it's upstream repository and a fixed release is expected soon. deskutils/xfce4-generic-slider will also be marked broken, since it fails to compile. [2] Thanks also to riggs, Olivier Duchateau <duchateau.olivier@gmail.com> and the people in Approved and Reviewed lines below for help and contributions. Reviewed by: woodsb02 Approved by: sergey.dyatko@gmail.com (maintainer) [1], ehaupt [2] Differential Revision: https://reviews.freebsd.org/D27846
Notes
Notes: svn path=/head/; revision=559953
Diffstat (limited to 'x11/libxfce4menu/Makefile')
-rw-r--r--x11/libxfce4menu/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/x11/libxfce4menu/Makefile b/x11/libxfce4menu/Makefile
index 1e8924e56264..abffde3effa6 100644
--- a/x11/libxfce4menu/Makefile
+++ b/x11/libxfce4menu/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libxfce4menu
-PORTVERSION= 4.14.1
-PORTREVISION= 2
+PORTVERSION= 4.16.0
CATEGORIES= x11 xfce
MASTER_SITES= XFCE
DISTNAME= libxfce4ui-${DISTVERSIONFULL}
@@ -15,7 +14,9 @@ COMMENT= Widgets library for the Xfce desktop environment
LICENSE= GPLv2
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
+ libfreetype.so:print/freetype2 \
+ libepoxy.so:graphics/libepoxy \
+ libgtop-2.0.so:devel/libgtop
USES= compiler:c11 gettext-tools gmake gnome libtool pathfix \
pkgconfig tar:bzip2 xfce xorg
@@ -26,13 +27,15 @@ USE_XORG= ice sm x11
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-CONFIGURE_ARGS= --with-vendor-info=${OPSYS} --without-html-dir
+CONFIGURE_ARGS= --with-vendor-info=${OPSYS} --without-html-dir \
+ --enable-glibtop --enable-epoxy \
+ --disable-gudev
INSTALL_TARGET= install-strip
PORTSCOUT= limitw:1,even
-OPTIONS_DEFINE= GIR GLADE GTK2 NLS STARTUP VAPI
-OPTIONS_DEFAULT= GIR GTK2 STARTUP VAPI
+OPTIONS_DEFINE= GIR GLADE NLS STARTUP VAPI
+OPTIONS_DEFAULT= GIR STARTUP VAPI
OPTIONS_SUB= yes
GIR_DESC= Use Gobject Introspection
@@ -45,9 +48,6 @@ GLADE_CONFIGURE_ENABLE= gladeui2
GLADE_LIB_DEPENDS= libgladeui-2.so:devel/glade
GLADE_USE= gnome=libxml2
-GTK2_CONFIGURE_ENABLE= gtk2
-GTK2_USE= gnome=gtk20
-
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext-runtime