aboutsummaryrefslogtreecommitdiff
path: root/x11/pmenu/files
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2021-02-05 11:30:44 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2021-02-05 11:30:44 +0000
commit6539f2a7fb2e9b67f904f5391f4c37b2a70ef19a (patch)
treecccc7cc97ef6401015f635fa37f3a2ecc6765a56 /x11/pmenu/files
parent678a5d8f68b1b464b7036883a3916242c02718ec (diff)
downloadports-6539f2a7fb2e9b67f904f5391f4c37b2a70ef19a.tar.gz
ports-6539f2a7fb2e9b67f904f5391f4c37b2a70ef19a.zip
Update to 2.2.0
With the last release, πmenu now uses XRender to draw anti-aliased graphics (the line separators, and the slices). Also, you do not need xclickroot anymore: with the -r 3 option, pie menu can be run in background (by following it with a &) and it will watch for clicks on the root window. I included this xclickroot functionality into πmenu so it is always loaded, and it does not have the overhead of initiating and drawing stuff.
Notes
Notes: svn path=/head/; revision=564111
Diffstat (limited to 'x11/pmenu/files')
-rw-r--r--x11/pmenu/files/patch-config.mk31
1 files changed, 25 insertions, 6 deletions
diff --git a/x11/pmenu/files/patch-config.mk b/x11/pmenu/files/patch-config.mk
index b2dc6caa8b5a..32179e87b82e 100644
--- a/x11/pmenu/files/patch-config.mk
+++ b/x11/pmenu/files/patch-config.mk
@@ -1,11 +1,30 @@
---- config.mk.orig 2020-10-06 11:12:09 UTC
+--- config.mk.orig 2021-02-05 04:34:38 UTC
+++ config.mk
-@@ -17,12 +17,12 @@ FREETYPEINC = /usr/include/freetype2
+@@ -2,16 +2,16 @@
+ PROG = pmenu
- # includes and libs
- INCS = -I${LOCALINC} -I${X11INC} -I${FREETYPEINC}
--LIBS = -L${LOCALLIB} -L${X11LIB} -lm -lfontconfig -lXft -lX11 -lXinerama -lXext -lImlib2
-+LIBS += -L${LOCALLIB} -L${X11LIB} -lm -lfontconfig -lXft -lX11 -lXinerama -lXext -lImlib2
+ # paths
+-PREFIX = /usr/local
++PREFIX ?= /usr/local
+ MANPREFIX = ${PREFIX}/share/man
+
+-LOCALINC = /usr/local/include
+-LOCALLIB = /usr/local/lib
++LOCALINC = ${LOCALBASE}/include
++LOCALLIB = ${LOCALBASE}/lib
+
+-X11INC = /usr/X11R6/include
+-X11LIB = /usr/X11R6/lib
++X11INC = ${LOCALBASE}/include/xorg
++X11LIB = ${LOCALBASE}/lib/xorg
+
+-FREETYPEINC = /usr/include/freetype2
++FREETYPEINC = ${LOCALBASE}/include/freetype2
+ # OpenBSD (uncomment)
+ #FREETYPEINC = ${X11INC}/freetype2
+
+@@ -20,9 +20,9 @@ INCS = -I${LOCALINC} -I${X11INC} -I${FREETYPEINC}
+ LIBS = -L${LOCALLIB} -L${X11LIB} -lm -lfontconfig -lXft -lX11 -lXinerama -lXrender -lXext -lImlib2
# flags
-CPPFLAGS =