aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /x11
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
downloadports-fe61bf1eb4f2758636a3c065686a833eb412df25.tar.gz
ports-fe61bf1eb4f2758636a3c065686a833eb412df25.zip
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Notes
Notes: svn path=/head/; revision=280300
Diffstat (limited to 'x11')
-rw-r--r--x11/florence/Makefile3
-rw-r--r--x11/gnome-applets/Makefile7
-rw-r--r--x11/gnome-applets/files/patch-battstat_battstat_applet.c15
-rw-r--r--x11/gnome-applets/files/patch-gweather_gweather-applet.c12
-rw-r--r--x11/gnome-screensaver/Makefile8
-rw-r--r--x11/gnome-screensaver/files/patch-src_gs-lock-plug.c11
-rw-r--r--x11/gnome-session/Makefile3
-rw-r--r--x11/zenity/Makefile3
-rw-r--r--x11/zenity/files/patch-src_notification.c15
9 files changed, 64 insertions, 13 deletions
diff --git a/x11/florence/Makefile b/x11/florence/Makefile
index c45afb5b7e70..dbcdc03cf242 100644
--- a/x11/florence/Makefile
+++ b/x11/florence/Makefile
@@ -7,13 +7,14 @@
PORTNAME= florence
PORTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= SF/florence/florence/${PORTVERSION}
MAINTAINER= kmoore@FreeBSD.org
COMMENT= Florence OnScreen Keyboard
-LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify \
+LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify \
cspi.10:${PORTSDIR}/accessibility/at-spi
USE_XORG= xtst
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 03727ebbdf25..0b692899a299 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnome-applets/Makefile,v 1.216 2010/09/27 10:14:28 kwm Exp $
+# $MCom: ports/x11/gnome-applets/Makefile,v 1.219 2011/04/10 19:41:38 mezz Exp $
#
PORTNAME= gnome-applets
PORTVERSION= 2.32.1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -29,7 +29,6 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/system-tools-backends-2.0.pc:${PORTS
USE_GETTEXT= yes
USE_BZIP2= yes
USE_GMAKE= yes
-GNOME_DESKTOP_VERSION=2
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
@@ -58,7 +57,7 @@ WITH_GNOME= yes
.if exists(${LOCALBASE}/libdata/pkgconfig/libnotify.pc) || \
!defined(WITHOUT_LIBNOTIFY)
-LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
.endif
.if ${ARCH} != "i386" && ${ARCH} != "amd64"
diff --git a/x11/gnome-applets/files/patch-battstat_battstat_applet.c b/x11/gnome-applets/files/patch-battstat_battstat_applet.c
index a95b7b569a09..05f2171440bb 100644
--- a/x11/gnome-applets/files/patch-battstat_battstat_applet.c
+++ b/x11/gnome-applets/files/patch-battstat_battstat_applet.c
@@ -1,6 +1,15 @@
---- battstat/battstat_applet.c.orig Fri Aug 19 22:13:49 2005
-+++ battstat/battstat_applet.c Tue Aug 23 20:37:13 2005
-@@ -430,14 +430,14 @@ battery_full_notify (GtkWidget *applet)
+--- battstat/battstat_applet.c.orig 2010-11-22 15:38:27.000000000 +0100
++++ battstat/battstat_applet.c 2011-03-07 19:09:55.000000000 +0100
+@@ -435,7 +435,7 @@ battery_full_notify (GtkWidget *applet)
+ GTK_ICON_LOOKUP_USE_BUILTIN,
+ NULL);
+
+- NotifyNotification *n = notify_notification_new (_("Your battery is now fully recharged"), "", /* "battery" */ NULL, applet);
++ NotifyNotification *n = notify_notification_new (_("Your battery is now fully recharged"), "", /* "battery" */ NULL);
+
+ /* XXX: it would be nice to pass this as a named icon */
+ notify_notification_set_icon_from_pixbuf (n, icon);
+@@ -462,14 +462,14 @@ battery_full_notify (GtkWidget *applet)
static void
battery_full_dialog (GtkWidget *applet)
{
diff --git a/x11/gnome-applets/files/patch-gweather_gweather-applet.c b/x11/gnome-applets/files/patch-gweather_gweather-applet.c
new file mode 100644
index 000000000000..9472c7b9e5fd
--- /dev/null
+++ b/x11/gnome-applets/files/patch-gweather_gweather-applet.c
@@ -0,0 +1,12 @@
+--- gweather/gweather-applet.c.orig 2011-03-07 17:35:07.000000000 +0100
++++ gweather/gweather-applet.c 2011-03-07 17:35:33.000000000 +0100
+@@ -471,8 +471,7 @@ update_finish (WeatherInfo *info, gpoint
+ if (icon == NULL)
+ icon = "stock-unknown";
+
+- n = notify_notification_new (message, detail, icon,
+- gw_applet->container);
++ n = notify_notification_new (message, detail, icon);
+
+ notify_notification_show (n, &error);
+ if (error)
diff --git a/x11/gnome-screensaver/Makefile b/x11/gnome-screensaver/Makefile
index 53db051654d3..55cb5c7ea4a1 100644
--- a/x11/gnome-screensaver/Makefile
+++ b/x11/gnome-screensaver/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnome-screensaver/Makefile,v 1.121 2010/09/30 19:51:41 kwm Exp $
+# $MCom: ports/x11/gnome-screensaver/Makefile,v 1.124 2011/04/09 16:54:20 mezz Exp $
#
PORTNAME= gnome-screensaver
PORTVERSION= 2.30.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,9 +16,11 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME screen saver and locker
-LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify
RUN_DEPENDS= xscreensaver-gl-helper:${PORTSDIR}/x11/xscreensaver-gnome-hacks
+CONFLICTS= gnome-screensaver-3.[0-9]*
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
diff --git a/x11/gnome-screensaver/files/patch-src_gs-lock-plug.c b/x11/gnome-screensaver/files/patch-src_gs-lock-plug.c
new file mode 100644
index 000000000000..af5d39f8e346
--- /dev/null
+++ b/x11/gnome-screensaver/files/patch-src_gs-lock-plug.c
@@ -0,0 +1,11 @@
+--- src/gs-lock-plug.c.orig 2011-03-06 21:27:00.000000000 +0100
++++ src/gs-lock-plug.c 2011-03-06 21:27:36.000000000 +0100
+@@ -1090,7 +1090,7 @@ submit_note (GtkButton *button,
+ strftime (summary, 128, "%X", tmp);
+
+ notify_init ("gnome-screensaver-dialog");
+- note = notify_notification_new (summary, escaped_text, NULL, NULL);
++ note = notify_notification_new (summary, escaped_text, NULL);
+ notify_notification_set_timeout (note, NOTIFY_EXPIRES_NEVER);
+ notify_notification_show (note, NULL);
+ g_object_unref (note);
diff --git a/x11/gnome-session/Makefile b/x11/gnome-session/Makefile
index 98cb2522d845..6a6783ab652c 100644
--- a/x11/gnome-session/Makefile
+++ b/x11/gnome-session/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gnome-session
PORTVERSION= 2.32.1
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -20,7 +21,7 @@ CONFLICTS= gnome-session-2.31.* gnome-session-2.90.* gnome-session-3.*
BUILD_DEPENDS= ${LOCALBASE}/libexec/gnome-settings-daemon:${PORTSDIR}/sysutils/gnome-settings-daemon
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring \
- notify.1:${PORTSDIR}/devel/libnotify \
+ notify.4:${PORTSDIR}/devel/libnotify \
execinfo:${PORTSDIR}/devel/libexecinfo \
upower-glib.1:${PORTSDIR}/sysutils/upower
RUN_DEPENDS= ${LOCALBASE}/libexec/gnome-settings-daemon:${PORTSDIR}/sysutils/gnome-settings-daemon \
diff --git a/x11/zenity/Makefile b/x11/zenity/Makefile
index aae55592f2bc..03ccc5ea658d 100644
--- a/x11/zenity/Makefile
+++ b/x11/zenity/Makefile
@@ -8,6 +8,7 @@
PORTNAME= zenity
PORTVERSION= 2.32.1
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -36,7 +37,7 @@ OPTIONS= NOTIFY "Enable libnotify support" on
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_NOTIFY)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+= --enable-libnotify
.else
CONFIGURE_ARGS+= --disable-libnotify
diff --git a/x11/zenity/files/patch-src_notification.c b/x11/zenity/files/patch-src_notification.c
new file mode 100644
index 000000000000..2acdb9b30bf2
--- /dev/null
+++ b/x11/zenity/files/patch-src_notification.c
@@ -0,0 +1,15 @@
+--- src/notification.c.orig 2011-08-11 11:03:46.000000000 +0200
++++ src/notification.c 2011-08-11 11:05:21.000000000 +0200
+@@ -184,10 +184,10 @@
+ icon = freeme = g_filename_to_uri (icon_file, NULL, NULL);
+ }
+
+- notif = notify_notification_new_with_status_icon (
++ notif = notify_notification_new (
+ message[0] /* title */,
+ message[1] /* summary */,
+- icon, status_icon);
++ icon);
+
+ g_strfreev (message);
+ g_free (freeme);