aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorPierre Pronchery <khorben@defora.org>2023-11-23 11:26:02 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2023-11-23 12:30:51 +0000
commitb6f53ab294c35ffbb4cea53bf0233df39cd17dfb (patch)
tree119dc3d0c5d8dd9b708291bca4f40708b99f10b0 /x11
parentf9faa4a89b5788a6f323c00a5fba5d419bfe433e (diff)
downloadports-b6f53ab294c35ffbb4cea53bf0233df39cd17dfb.tar.gz
ports-b6f53ab294c35ffbb4cea53bf0233df39cd17dfb.zip
x11/deforaos-integration: new port
DeforaOS desktop integration WWW: https://www.defora.org
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/deforaos-integration/Makefile45
-rw-r--r--x11/deforaos-integration/distinfo3
-rw-r--r--x11/deforaos-integration/pkg-descr1
-rw-r--r--x11/deforaos-integration/pkg-plist19
5 files changed, 69 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 38d05080736c..8dbec9ef64df 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -50,6 +50,7 @@
SUBDIR += cool-retro-term
SUBDIR += coreterminal
SUBDIR += damask
+ SUBDIR += deforaos-integration
SUBDIR += deforaos-keyboard
SUBDIR += deforaos-libdesktop
SUBDIR += deforaos-locker
diff --git a/x11/deforaos-integration/Makefile b/x11/deforaos-integration/Makefile
new file mode 100644
index 000000000000..fc1047f936d4
--- /dev/null
+++ b/x11/deforaos-integration/Makefile
@@ -0,0 +1,45 @@
+PORTNAME= deforaos-integration
+PORTVERSION= 0.1.2
+CATEGORIES= x11
+MASTER_SITES= https://ftp.defora.org/pub/DeforaOS/Apps/Desktop/src/Integration/
+DISTNAME= Integration-${PORTVERSION}
+
+MAINTAINER= olivier@FreeBSD.org
+COMMENT= DeforaOS desktop integration
+WWW= https://www.defora.org/
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${LOCALBASE}/bin/surfer:www/deforaos-surfer \
+ ${LOCALBASE}/bin/metacity:x11-wm/metacity \
+ gnome-icon-theme>=0:misc/gnome-icon-theme
+BUILD_DEPENDS= ${LOCALBASE}/include/Desktop/Locker.h:x11/deforaos-locker \
+ ${LOCALBASE}/include/Desktop/Keyboard.h:x11/deforaos-keyboard \
+ ${LOCALBASE}/include/Desktop/Player.h:multimedia/deforaos-player \
+ ${LOCALBASE}/include/Desktop/Phone.h:comms/deforaos-phone
+LIB_DEPENDS= libSystem.so:devel/deforaos-libsystem \
+ libDesktop.so:x11/deforaos-libdesktop \
+ libpurple.so:net-im/libpurple \
+ libsofia-sip-ua.so:net/sofia-sip \
+ libpulse.so:audio/pulseaudio \
+ libPanel.so.0:x11-wm/deforaos-panel \
+ libharfbuzz.so:print/harfbuzz \
+ libdbus-glib-1.so:devel/dbus-glib \
+ libdbus-1.so:devel/dbus
+
+USES= gnome pkgconfig xorg desktop-file-utils
+
+USE_GNOME= gtk30 cairo gdkpixbuf2
+USE_XORG= x11
+USE_LDCONFIG= yes
+#MAKE_ARGS+= PREFIX=${PREFIX}
+#MAKE_ENV+= MANDIR=${STAGEDIR}${MANPREFIX}/man
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/Phone/modem/*.so \
+ ${STAGEDIR}${PREFIX}/lib/Phone/plugins/*.so \
+ ${STAGEDIR}${PREFIX}/lib/Locker/plugins/*.so \
+ ${STAGEDIR}${PREFIX}/lib/Panel/applets/*.so
+
+.include <bsd.port.mk>
diff --git a/x11/deforaos-integration/distinfo b/x11/deforaos-integration/distinfo
new file mode 100644
index 000000000000..74113b1302a3
--- /dev/null
+++ b/x11/deforaos-integration/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1700699795
+SHA256 (Integration-0.1.2.tar.gz) = 59944ec129783d292a6526ff9b1dbc7ecf2da9761d4cf61c61241293f3758daa
+SIZE (Integration-0.1.2.tar.gz) = 48093
diff --git a/x11/deforaos-integration/pkg-descr b/x11/deforaos-integration/pkg-descr
new file mode 100644
index 000000000000..ff4b57ecd811
--- /dev/null
+++ b/x11/deforaos-integration/pkg-descr
@@ -0,0 +1 @@
+DeforaOS desktop integration
diff --git a/x11/deforaos-integration/pkg-plist b/x11/deforaos-integration/pkg-plist
new file mode 100644
index 000000000000..61b5e2dd932a
--- /dev/null
+++ b/x11/deforaos-integration/pkg-plist
@@ -0,0 +1,19 @@
+bin/calculator
+bin/deforaos-session
+bin/stopwatch
+lib/Locker/plugins/panel.so
+lib/Panel/applets/keyboard.so
+lib/Panel/applets/phone.so
+lib/Panel/applets/player.so
+lib/Phone/modem/purple.so
+lib/Phone/modem/sofia.so
+lib/Phone/plugins/locker.so
+lib/Phone/plugins/notify.so
+lib/Phone/plugins/pulseaudio.so
+lib/Surfer/htmlapps/calculator.html
+lib/Surfer/htmlapps/stopwatch.html
+share/applications/org.defora.calculator.desktop
+share/applications/org.defora.stopwatch.desktop
+share/doc/Integration/COPYING
+share/doc/Integration/README.md
+share/xsessions/DeforaOS.desktop