aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-08-03 21:14:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-05-27 03:30:56 +0000
commitf783260c1c4d7bacbb6d36cab209eab28da49d4e (patch)
treef94a6e8757b431fef7eb16a7f190af49d894c612 /x11
parent0d5f0ec8304d07f7138b5a3972ec72c48d4fd03b (diff)
downloadports-f783260c1c4d7bacbb6d36cab209eab28da49d4e.tar.gz
ports-f783260c1c4d7bacbb6d36cab209eab28da49d4e.zip
x11/libxshmfence: prefer SHM_ANON over mksotemp()
SHM_ANON is faster and more similar to memfd_create() PR: 239630 Approved by: jkim
Diffstat (limited to 'x11')
-rw-r--r--x11/libxshmfence/Makefile1
-rw-r--r--x11/libxshmfence/files/patch-src__xshmfence_alloc.c12
2 files changed, 12 insertions, 1 deletions
diff --git a/x11/libxshmfence/Makefile b/x11/libxshmfence/Makefile
index f9b72e5372ca..e0cee43889d2 100644
--- a/x11/libxshmfence/Makefile
+++ b/x11/libxshmfence/Makefile
@@ -1,5 +1,6 @@
PORTNAME= libxshmfence
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= x11@FreeBSD.org
diff --git a/x11/libxshmfence/files/patch-src__xshmfence_alloc.c b/x11/libxshmfence/files/patch-src__xshmfence_alloc.c
index e6e0df9a946e..b6e98334e981 100644
--- a/x11/libxshmfence/files/patch-src__xshmfence_alloc.c
+++ b/x11/libxshmfence/files/patch-src__xshmfence_alloc.c
@@ -1,6 +1,16 @@
--- src/xshmfence_alloc.c.orig 2015-03-04 15:28:23 UTC
+++ src/xshmfence_alloc.c
-@@ -79,7 +79,11 @@ xshmfence_alloc_shm(void)
+@@ -73,13 +73,21 @@ xshmfence_alloc_shm(void)
+ fd = memfd_create("xshmfence", MFD_CLOEXEC|MFD_ALLOW_SEALING);
+ if (fd < 0)
+ #endif
++#ifdef SHM_ANON
++ fd = shm_open(SHM_ANON, O_RDWR|O_CLOEXEC, 0600);
++ if (fd < 0)
++#endif
+ {
+ #ifdef O_TMPFILE
+ fd = open(SHMDIR, O_TMPFILE|O_RDWR|O_CLOEXEC|O_EXCL, 0666);
if (fd < 0)
#endif
{