aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/gdal/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index ece8a8c5f0d1..6f7f897f0ab9 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -4,6 +4,7 @@
PORTNAME= gdal
PORTVERSION= 2.1.2
PORTREVISION= 2
+PORTREVISION= 1
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/gdal/${PORTVERSION}/ \
ftp://ftp.remotesensing.org/pub/gdal/${PORTVERSION}/ \
@@ -102,7 +103,7 @@ PGSQL_CONFIGURE_ON= --with-pg=${LOCALBASE}/bin/pg_config
PGSQL_USES= pgsql
PODOFO_CONFIGURE_WITH= podofo
PODOFO_LIB_DEPENDS= libpodofo.so:graphics/podofo
-POPPLER_CONFIGURE_WITH= poppler
+POPPLER_CONFIGURE_WITH= poppler=${LOCALBASE}
POPPLER_LIB_DEPENDS= libpoppler.so:graphics/poppler
SPATIALITE_CONFIGURE_WITH= spatialite
SPATIALITE_LIB_DEPENDS= libspatialite.so:databases/spatialite
@@ -116,7 +117,7 @@ XERCES_LIB_DEPENDS= libxerces-c.so:textproc/xerces-c3
post-patch:
@${REINPLACE_CMD} -e 's|$$(INST_LIB)/pkgconfig|${PREFIX}/libdata/pkgconfig|' ${WRKSRC}/GNUmakefile
@${REINPLACE_CMD} -e 's|-lminizip|-lkmlminizip|' ${WRKSRC}/configure
-# Cleanup bundled libraries
+# Clean up bundled libraries
@${RM} -r ${WRKSRC}/frmts/gif/giflib/
@${RM} -r ${WRKSRC}/frmts/gtiff/libgeotiff/
@${RM} -r ${WRKSRC}/frmts/gtiff/libtiff/