aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/mongodb/Makefile18
-rw-r--r--databases/mongodb/distinfo4
-rw-r--r--databases/mongodb/files/patch-src_mongo_dbtests_documentsourcetests.cpp11
3 files changed, 21 insertions, 12 deletions
diff --git a/databases/mongodb/Makefile b/databases/mongodb/Makefile
index ad111f35af88..7f86f9c1a08a 100644
--- a/databases/mongodb/Makefile
+++ b/databases/mongodb/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mongodb
-PORTVERSION= 2.4.9
-PORTREVISION= 1
+PORTVERSION= 2.4.10
CATEGORIES= databases net
MASTER_SITES= http://downloads.mongodb.org/src/
DISTNAME= ${PORTNAME}-src-r${PORTVERSION}
@@ -18,9 +17,9 @@ LICENSE_COMB= multi
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
libpcre.so:${PORTSDIR}/devel/pcre \
libsnappy.so:${PORTSDIR}/archivers/snappy
-# boost 1.52 from ports make mongod segfaulting with many tests
+# boost 1.52/1.55 from ports make mongod segfaulting with many tests
# LIB_DEPENDS+= libboost_system.so:${PORTSDIR}/devel/boost-libs
-# SCONS_ARGS+= --use-system-boost
+# MAKE_ARGS+= --use-system-boost
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than i386 and amd64"
@@ -64,13 +63,12 @@ LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
.if ${PORT_OPTIONS:MTEST}
BUILD_DEPENDS= pymongo>=2.5:${PORTSDIR}/databases/pymongo
-MAKE_TARGET= all
-SMOKE_TESTS= smokeAll smokeCppUnittests
+TEST_TARGET= smokeAll smokeCppUnittests
. if ${PORT_OPTIONS:MSSL}
-SMOKE_TESTS+= smokeSsl
+TEST_TARGET+= smokeSsl
. endif
.else
-MAKE_TARGET= core tools
+ALL_TARGET= core tools
.endif
.if ${OSVERSION} >= 1000024
@@ -86,8 +84,8 @@ post-patch:
.if ${PORT_OPTIONS:MTEST}
test: build-depends build
- @cd ${BUILD_WRKSRC} && \
- ${SCONS_BIN} ${SCONS_ENV} ${MAKE_ARGS} ${SMOKE_TESTS}
+ @cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ${MAKE_CMD} ${_MAKE_JOBS} ${MAKE_ARGS} ${TEST_TARGET}
.endif
.include <bsd.port.mk>
diff --git a/databases/mongodb/distinfo b/databases/mongodb/distinfo
index daedf8b633cb..c7a0847a36e1 100644
--- a/databases/mongodb/distinfo
+++ b/databases/mongodb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mongodb-src-r2.4.9.tar.gz) = 40755d66419a5c9f0d9909a079b092195825773ded188ded3faf07025d02600f
-SIZE (mongodb-src-r2.4.9.tar.gz) = 14162773
+SHA256 (mongodb-src-r2.4.10.tar.gz) = 8ac8d0537e5316e842e3713870b76ea3cc18ec1234307e850046449f48a87402
+SIZE (mongodb-src-r2.4.10.tar.gz) = 14166404
diff --git a/databases/mongodb/files/patch-src_mongo_dbtests_documentsourcetests.cpp b/databases/mongodb/files/patch-src_mongo_dbtests_documentsourcetests.cpp
new file mode 100644
index 000000000000..8f456b469b0c
--- /dev/null
+++ b/databases/mongodb/files/patch-src_mongo_dbtests_documentsourcetests.cpp
@@ -0,0 +1,11 @@
+--- ./src/mongo/dbtests/documentsourcetests.cpp.orig 2014-04-07 09:45:28.120368155 +0000
++++ ./src/mongo/dbtests/documentsourcetests.cpp 2014-04-07 09:45:21.592368569 +0000
+@@ -583,7 +583,7 @@
+ };
+
+ struct ValueCmp {
+- bool operator()(const Value& a, const Value& b) {
++ bool operator()(const Value& a, const Value& b) const {
+ return Value::compare( a, b ) < 0;
+ }
+ };