aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/seamonkey-i18n/Makefile2
-rw-r--r--www/seamonkey/Makefile2
-rw-r--r--www/seamonkey/distinfo6
-rw-r--r--www/seamonkey/files/patch-bug144071740
4 files changed, 5 insertions, 45 deletions
diff --git a/www/seamonkey-i18n/Makefile b/www/seamonkey-i18n/Makefile
index c34330ddaba6..2f6535646e80 100644
--- a/www/seamonkey-i18n/Makefile
+++ b/www/seamonkey-i18n/Makefile
@@ -5,7 +5,7 @@ PORTNAME= seamonkey-i18n
PORTVERSION= 2.49.3
CATEGORIES= www mail news editors irc
MASTER_SITES= MOZILLA/${PORTNAME:S|-i18n||}/releases/${DISTVERSION}/langpack \
- MOZILLA/${PORTNAME:S|-i18n||}/candidates/${DISTVERSION}-candidates/build1/linux-i686/xpi \
+ MOZILLA/${PORTNAME:S|-i18n||}/candidates/${DISTVERSION}-candidates/build2/linux-i686/xpi \
LOCAL/jbeich/${DIST_SUBDIR}
PKGNAMEPREFIX=
DISTFILES= ${SEAMONKEY_I18N_:S/$/.langpack.xpi/:S/^/seamonkey-${PORTVERSION}./}
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 6d00b98a785f..8e9adbff293a 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -6,7 +6,7 @@ DISTVERSION= 2.49.3
MOZILLA_VER= 52 # above + 3
CATEGORIES?= www mail news editors irc ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
- MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
+ MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build2/source
DISTFILES= ${DISTNAME}.source${EXTRACT_SUFX}
MAINTAINER= gecko@FreeBSD.org
diff --git a/www/seamonkey/distinfo b/www/seamonkey/distinfo
index 8dd28ae5bff6..a20d7fe53444 100644
--- a/www/seamonkey/distinfo
+++ b/www/seamonkey/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1522389599
-SHA256 (seamonkey-2.49.3.source.tar.xz) = 3d149ccb0c5bafe086182b071343561bff430907cbd67f0516282722942f098a
-SIZE (seamonkey-2.49.3.source.tar.xz) = 231791060
+TIMESTAMP = 1522802344
+SHA256 (seamonkey-2.49.3.source.tar.xz) = 1823ed983bbc62e40f622288d5b24be9214ff28f15bf3f21028cc992fa96484b
+SIZE (seamonkey-2.49.3.source.tar.xz) = 231547028
diff --git a/www/seamonkey/files/patch-bug1440717 b/www/seamonkey/files/patch-bug1440717
deleted file mode 100644
index 0bc2424c394a..000000000000
--- a/www/seamonkey/files/patch-bug1440717
+++ /dev/null
@@ -1,40 +0,0 @@
-commit ae9da5994b51
-Author: Nicolas Silva <nsilva@mozilla.com>
-Date: Mon Mar 12 13:36:00 2018 +0100
-
- Bug 1440717 - Use RefPtr for CompositingRenderTargetOGL::mGL. r=Bas, a=ritu
-
- --HG--
- extra : source : b6d2d55223d2aa5cb85bbdf33075d1d38f2a9a30
- extra : intermediate-source : 0ec90964e0bc479412a4da8a61d48b665211736e
----
- gfx/layers/opengl/CompositingRenderTargetOGL.cpp | 2 +-
- gfx/layers/opengl/CompositingRenderTargetOGL.h | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.cpp mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.cpp
-index c05b8edfd346..a1521c56da87 100644
---- mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.cpp
-+++ mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.cpp
-@@ -60,7 +60,7 @@ CompositingRenderTargetOGL::BindRenderTarget()
- msg.AppendPrintf("Framebuffer not complete -- CheckFramebufferStatus returned 0x%x, "
- "GLContext=%p, IsOffscreen()=%d, mFBO=%d, aFBOTextureTarget=0x%x, "
- "aRect.width=%d, aRect.height=%d",
-- result, mGL, mGL->IsOffscreen(), mFBO, mInitParams.mFBOTextureTarget,
-+ result, mGL.get(), mGL->IsOffscreen(), mFBO, mInitParams.mFBOTextureTarget,
- mInitParams.mSize.width, mInitParams.mSize.height);
- NS_WARNING(msg.get());
- }
-diff --git mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.h mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.h
-index 501701d6f1a3..071dc5cac1c2 100644
---- mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.h
-+++ mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.h
-@@ -184,7 +184,7 @@ private:
- * the target is always cleared at the end of a frame.
- */
- RefPtr<CompositorOGL> mCompositor;
-- GLContext* mGL;
-+ RefPtr<GLContext> mGL;
- GLuint mTextureHandle;
- GLuint mFBO;
- };