aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/typo3/Makefile11
-rw-r--r--www/typo343/Makefile11
-rw-r--r--www/typo344/Makefile11
-rw-r--r--www/typo345/Makefile11
-rw-r--r--www/typo346/Makefile11
5 files changed, 40 insertions, 15 deletions
diff --git a/www/typo3/Makefile b/www/typo3/Makefile
index 324925330496..74ef015c85d4 100644
--- a/www/typo3/Makefile
+++ b/www/typo3/Makefile
@@ -7,25 +7,27 @@
PORTNAME= typo3
PORTVERSION= 3.8.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}_src-${PORTVERSION}
-MAINTAINER= tux@pinguru.net
+MAINTAINER= gerrit.beine@gmx.de
COMMENT= The typo3 content management system
NO_BUILD= yes
-USE_PHP= mysql pcre xml
+USE_PHP= mysql pcre xml session ctype
WANT_PHP_WEB= yes
TYPO3DIR= www/${DISTNAME}
SITEDIR?= www/typo3
SITESRC= ${WRKDIR}/${EDITION}-${PORTVERSION}
-EDITION= dummy
.if defined(WITH_EDITION) && (${WITH_EDITION} == "quickstart" || ${WITH_EDITION} == "testsite")
EDITION= ${WITH_EDITION}
+.else
+EDITION= dummy
.endif
.if make(makesum)
@@ -51,6 +53,9 @@ USE_PHP+= gd
USE_PHP+= zlib
.endif
+# Include bsd.php.mk because use USE_PHP after bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.php.mk"
+
.if defined(WITH_IMAGICK)
LIB_DEPENDS+= Magick.9:${PORTSDIR}/graphics/ImageMagick
.endif
diff --git a/www/typo343/Makefile b/www/typo343/Makefile
index 324925330496..74ef015c85d4 100644
--- a/www/typo343/Makefile
+++ b/www/typo343/Makefile
@@ -7,25 +7,27 @@
PORTNAME= typo3
PORTVERSION= 3.8.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}_src-${PORTVERSION}
-MAINTAINER= tux@pinguru.net
+MAINTAINER= gerrit.beine@gmx.de
COMMENT= The typo3 content management system
NO_BUILD= yes
-USE_PHP= mysql pcre xml
+USE_PHP= mysql pcre xml session ctype
WANT_PHP_WEB= yes
TYPO3DIR= www/${DISTNAME}
SITEDIR?= www/typo3
SITESRC= ${WRKDIR}/${EDITION}-${PORTVERSION}
-EDITION= dummy
.if defined(WITH_EDITION) && (${WITH_EDITION} == "quickstart" || ${WITH_EDITION} == "testsite")
EDITION= ${WITH_EDITION}
+.else
+EDITION= dummy
.endif
.if make(makesum)
@@ -51,6 +53,9 @@ USE_PHP+= gd
USE_PHP+= zlib
.endif
+# Include bsd.php.mk because use USE_PHP after bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.php.mk"
+
.if defined(WITH_IMAGICK)
LIB_DEPENDS+= Magick.9:${PORTSDIR}/graphics/ImageMagick
.endif
diff --git a/www/typo344/Makefile b/www/typo344/Makefile
index 324925330496..74ef015c85d4 100644
--- a/www/typo344/Makefile
+++ b/www/typo344/Makefile
@@ -7,25 +7,27 @@
PORTNAME= typo3
PORTVERSION= 3.8.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}_src-${PORTVERSION}
-MAINTAINER= tux@pinguru.net
+MAINTAINER= gerrit.beine@gmx.de
COMMENT= The typo3 content management system
NO_BUILD= yes
-USE_PHP= mysql pcre xml
+USE_PHP= mysql pcre xml session ctype
WANT_PHP_WEB= yes
TYPO3DIR= www/${DISTNAME}
SITEDIR?= www/typo3
SITESRC= ${WRKDIR}/${EDITION}-${PORTVERSION}
-EDITION= dummy
.if defined(WITH_EDITION) && (${WITH_EDITION} == "quickstart" || ${WITH_EDITION} == "testsite")
EDITION= ${WITH_EDITION}
+.else
+EDITION= dummy
.endif
.if make(makesum)
@@ -51,6 +53,9 @@ USE_PHP+= gd
USE_PHP+= zlib
.endif
+# Include bsd.php.mk because use USE_PHP after bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.php.mk"
+
.if defined(WITH_IMAGICK)
LIB_DEPENDS+= Magick.9:${PORTSDIR}/graphics/ImageMagick
.endif
diff --git a/www/typo345/Makefile b/www/typo345/Makefile
index 324925330496..74ef015c85d4 100644
--- a/www/typo345/Makefile
+++ b/www/typo345/Makefile
@@ -7,25 +7,27 @@
PORTNAME= typo3
PORTVERSION= 3.8.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}_src-${PORTVERSION}
-MAINTAINER= tux@pinguru.net
+MAINTAINER= gerrit.beine@gmx.de
COMMENT= The typo3 content management system
NO_BUILD= yes
-USE_PHP= mysql pcre xml
+USE_PHP= mysql pcre xml session ctype
WANT_PHP_WEB= yes
TYPO3DIR= www/${DISTNAME}
SITEDIR?= www/typo3
SITESRC= ${WRKDIR}/${EDITION}-${PORTVERSION}
-EDITION= dummy
.if defined(WITH_EDITION) && (${WITH_EDITION} == "quickstart" || ${WITH_EDITION} == "testsite")
EDITION= ${WITH_EDITION}
+.else
+EDITION= dummy
.endif
.if make(makesum)
@@ -51,6 +53,9 @@ USE_PHP+= gd
USE_PHP+= zlib
.endif
+# Include bsd.php.mk because use USE_PHP after bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.php.mk"
+
.if defined(WITH_IMAGICK)
LIB_DEPENDS+= Magick.9:${PORTSDIR}/graphics/ImageMagick
.endif
diff --git a/www/typo346/Makefile b/www/typo346/Makefile
index 324925330496..74ef015c85d4 100644
--- a/www/typo346/Makefile
+++ b/www/typo346/Makefile
@@ -7,25 +7,27 @@
PORTNAME= typo3
PORTVERSION= 3.8.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}_src-${PORTVERSION}
-MAINTAINER= tux@pinguru.net
+MAINTAINER= gerrit.beine@gmx.de
COMMENT= The typo3 content management system
NO_BUILD= yes
-USE_PHP= mysql pcre xml
+USE_PHP= mysql pcre xml session ctype
WANT_PHP_WEB= yes
TYPO3DIR= www/${DISTNAME}
SITEDIR?= www/typo3
SITESRC= ${WRKDIR}/${EDITION}-${PORTVERSION}
-EDITION= dummy
.if defined(WITH_EDITION) && (${WITH_EDITION} == "quickstart" || ${WITH_EDITION} == "testsite")
EDITION= ${WITH_EDITION}
+.else
+EDITION= dummy
.endif
.if make(makesum)
@@ -51,6 +53,9 @@ USE_PHP+= gd
USE_PHP+= zlib
.endif
+# Include bsd.php.mk because use USE_PHP after bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.php.mk"
+
.if defined(WITH_IMAGICK)
LIB_DEPENDS+= Magick.9:${PORTSDIR}/graphics/ImageMagick
.endif