aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/akode-plugins-ffmpeg/Makefile51
-rw-r--r--audio/akode-plugins-ffmpeg/distinfo3
-rw-r--r--audio/akode-plugins-ffmpeg/files/patch-akode_Makefile.in11
-rw-r--r--audio/akode-plugins-ffmpeg/files/patch-akode_plugins-Makefile.in15
-rw-r--r--audio/akode-plugins-ffmpeg/pkg-descr3
-rw-r--r--audio/akode-plugins-ffmpeg/pkg-plist3
-rw-r--r--audio/akode-plugins-jack/Makefile2
-rw-r--r--audio/akode-plugins-jack/distinfo6
-rw-r--r--audio/akode-plugins-mpc/Makefile2
-rw-r--r--audio/akode-plugins-mpc/distinfo6
-rw-r--r--audio/akode-plugins-mpeg/Makefile2
-rw-r--r--audio/akode-plugins-mpeg/distinfo6
-rw-r--r--audio/akode-plugins-oss/Makefile2
-rw-r--r--audio/akode-plugins-oss/distinfo6
-rw-r--r--audio/akode-plugins-resampler/Makefile2
-rw-r--r--audio/akode-plugins-resampler/distinfo6
-rw-r--r--audio/akode-plugins-xiph/Makefile3
-rw-r--r--audio/akode-plugins-xiph/distinfo6
-rw-r--r--audio/akode/Makefile9
-rw-r--r--audio/akode/distinfo6
20 files changed, 120 insertions, 30 deletions
diff --git a/audio/akode-plugins-ffmpeg/Makefile b/audio/akode-plugins-ffmpeg/Makefile
new file mode 100644
index 000000000000..9ae86c3f74ef
--- /dev/null
+++ b/audio/akode-plugins-ffmpeg/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: mpeglib_artsplug
+# Date created: Jan 14 2008
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= akode-plugins-${PORTNAMESUFX}
+PORTVERSION= 2.0.2
+PORTEPOCH= 1
+CATEGORIES= audio kde
+MASTER_SITES= ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR=distfiles
+DISTNAME= 30375-akode-${PORTVERSION}.tar.bz2
+EXTRACT_SUFX= # none
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= FFMPEG decoder plugin for akode
+
+LIB_DEPENDS= avcodec:${PORTSDIR}/multimedia/ffmpeg
+
+CONFLICTS= kdemultimedia-3.[1-3]*
+
+PLUGIN= ffmpeg_decoder
+PORTNAMESUFX= ${PLUGIN:S/_sink//:S/_decoder//:S/src_//}
+
+USE_AUTOTOOLS= libltdl
+USE_AUTOTOOLS= libtool:15
+USE_BZIP2= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/akode-${PORTVERSION}
+USE_LDCONFIG= yes
+
+CONFIGURE_ENV+= LDFLAGS=-L${WRKSRC}/akode/lib/.libs
+CONFIGURE_ARGS+=--with-extra-libs=${LOCALBASE}/lib \
+ --with-extra-includes=${LOCALBASE}/include
+
+post-patch:
+ @${SETENV} TZ=UTC \
+ ${TOUCH} -t 200607222217.01 ${WRKSRC}/akode/lib/akode_export.h.in
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's@%%SUBDIRS%%@${PLUGIN}@g' ${WRKSRC}/akode/plugins/Makefile.in
+
+do-build:
+ cd ${WRKSRC}/akode && ${GMAKE}
+
+do-install:
+ cd ${WRKSRC}/akode/plugins/${PLUGIN} && ${GMAKE} install
+
+.include <bsd.port.mk>
diff --git a/audio/akode-plugins-ffmpeg/distinfo b/audio/akode-plugins-ffmpeg/distinfo
new file mode 100644
index 000000000000..3b0828c8e327
--- /dev/null
+++ b/audio/akode-plugins-ffmpeg/distinfo
@@ -0,0 +1,3 @@
+MD5 (30375-akode-2.0.2.tar.bz2) = 659ced0c9c735cb3e55b9138ff02342c
+SHA256 (30375-akode-2.0.2.tar.bz2) = ad689f7b3531cc3c42fda07c264873360bc0f4a94b90c1a4c91c92a22333a7a6
+SIZE (30375-akode-2.0.2.tar.bz2) = 472605
diff --git a/audio/akode-plugins-ffmpeg/files/patch-akode_Makefile.in b/audio/akode-plugins-ffmpeg/files/patch-akode_Makefile.in
new file mode 100644
index 000000000000..2b2f77e6972a
--- /dev/null
+++ b/audio/akode-plugins-ffmpeg/files/patch-akode_Makefile.in
@@ -0,0 +1,11 @@
+--- akode/Makefile.in.orig Tue Nov 29 17:51:19 2005
++++ akode/Makefile.in Tue Nov 29 17:51:05 2005
+@@ -247,7 +247,7 @@
+ unsermake_enable_pch_FALSE = @unsermake_enable_pch_FALSE@
+ unsermake_enable_pch_TRUE = @unsermake_enable_pch_TRUE@
+ bin_SCRIPTS = akode-config
+-SUBDIRS = lib plugins akodeplay
++SUBDIRS = lib plugins
+ #>- all: all-recursive
+ #>+ 1
+ all: docs-am all-recursive
diff --git a/audio/akode-plugins-ffmpeg/files/patch-akode_plugins-Makefile.in b/audio/akode-plugins-ffmpeg/files/patch-akode_plugins-Makefile.in
new file mode 100644
index 000000000000..c43387754ff0
--- /dev/null
+++ b/audio/akode-plugins-ffmpeg/files/patch-akode_plugins-Makefile.in
@@ -0,0 +1,15 @@
+--- akode/plugins/Makefile.in.orig Tue Nov 29 18:10:20 2005
++++ akode/plugins/Makefile.in Tue Nov 29 18:10:45 2005
+@@ -252,11 +252,7 @@
+ @include_sun_sink_TRUE@AKODE_SUN_SINK = sun_sink
+ @include_jack_sink_TRUE@AKODE_JACK_SINK = jack_sink
+ @include_polyp_sink_TRUE@AKODE_POLYP_SINK = polyp_sink
+-SUBDIRS = $(AKODE_MPC_DECODER) $(AKODE_XIPH_DECODER) \
+- $(AKODE_MPEG_DECODER) $(AKODE_FFMPEG_DECODER) \
+- $(AKODE_ALSA_SINK) $(AKODE_OSS_SINK) $(AKODE_SUN_SINK) \
+- $(AKODE_JACK_SINK) $(AKODE_POLYP_SINK) \
+- $(AKODE_SRC_RESAMPLER)
++SUBDIRS = %%SUBDIRS%%
+
+ #>- all: all-recursive
+ #>+ 1
diff --git a/audio/akode-plugins-ffmpeg/pkg-descr b/audio/akode-plugins-ffmpeg/pkg-descr
new file mode 100644
index 000000000000..0f03fbfab8c0
--- /dev/null
+++ b/audio/akode-plugins-ffmpeg/pkg-descr
@@ -0,0 +1,3 @@
+aKode is a simple audio-decoding frame-work that provides a uniform interface
+to decode the most common audio-formats. It also has a direct playback option
+for a number of audio-outputs.
diff --git a/audio/akode-plugins-ffmpeg/pkg-plist b/audio/akode-plugins-ffmpeg/pkg-plist
new file mode 100644
index 000000000000..e9cb0f7f80b4
--- /dev/null
+++ b/audio/akode-plugins-ffmpeg/pkg-plist
@@ -0,0 +1,3 @@
+lib/libakode_ffmpeg_decoder.a
+lib/libakode_ffmpeg_decoder.la
+lib/libakode_ffmpeg_decoder.so
diff --git a/audio/akode-plugins-jack/Makefile b/audio/akode-plugins-jack/Makefile
index e1e819eaf59c..4e3000116503 100644
--- a/audio/akode-plugins-jack/Makefile
+++ b/audio/akode-plugins-jack/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= akode-plugins-${PORTNAMESUFX}
-PORTVERSION= 2.0.1
+PORTVERSION= 2.0.2
PORTEPOCH= 1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_GENTOO}
diff --git a/audio/akode-plugins-jack/distinfo b/audio/akode-plugins-jack/distinfo
index 2dd6d912909d..3b0828c8e327 100644
--- a/audio/akode-plugins-jack/distinfo
+++ b/audio/akode-plugins-jack/distinfo
@@ -1,3 +1,3 @@
-MD5 (30375-akode-2.0.1.tar.bz2) = 94a10e7729b20b669bc5c7721f62e162
-SHA256 (30375-akode-2.0.1.tar.bz2) = a1a31d3ea59e151ff1ff51e9f2be0db84fc9fcb40f590abb1c46494d6ff1c08e
-SIZE (30375-akode-2.0.1.tar.bz2) = 460964
+MD5 (30375-akode-2.0.2.tar.bz2) = 659ced0c9c735cb3e55b9138ff02342c
+SHA256 (30375-akode-2.0.2.tar.bz2) = ad689f7b3531cc3c42fda07c264873360bc0f4a94b90c1a4c91c92a22333a7a6
+SIZE (30375-akode-2.0.2.tar.bz2) = 472605
diff --git a/audio/akode-plugins-mpc/Makefile b/audio/akode-plugins-mpc/Makefile
index e4407b3b0d27..8d1b22a55b76 100644
--- a/audio/akode-plugins-mpc/Makefile
+++ b/audio/akode-plugins-mpc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= akode-plugins-${PORTNAMESUFX}
-PORTVERSION= 2.0.1
+PORTVERSION= 2.0.2
PORTEPOCH= 1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_GENTOO}
diff --git a/audio/akode-plugins-mpc/distinfo b/audio/akode-plugins-mpc/distinfo
index 2dd6d912909d..3b0828c8e327 100644
--- a/audio/akode-plugins-mpc/distinfo
+++ b/audio/akode-plugins-mpc/distinfo
@@ -1,3 +1,3 @@
-MD5 (30375-akode-2.0.1.tar.bz2) = 94a10e7729b20b669bc5c7721f62e162
-SHA256 (30375-akode-2.0.1.tar.bz2) = a1a31d3ea59e151ff1ff51e9f2be0db84fc9fcb40f590abb1c46494d6ff1c08e
-SIZE (30375-akode-2.0.1.tar.bz2) = 460964
+MD5 (30375-akode-2.0.2.tar.bz2) = 659ced0c9c735cb3e55b9138ff02342c
+SHA256 (30375-akode-2.0.2.tar.bz2) = ad689f7b3531cc3c42fda07c264873360bc0f4a94b90c1a4c91c92a22333a7a6
+SIZE (30375-akode-2.0.2.tar.bz2) = 472605
diff --git a/audio/akode-plugins-mpeg/Makefile b/audio/akode-plugins-mpeg/Makefile
index 20d6efc9cb77..e214721e5dc7 100644
--- a/audio/akode-plugins-mpeg/Makefile
+++ b/audio/akode-plugins-mpeg/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= akode-plugins-${PORTNAMESUFX}
-PORTVERSION= 2.0.1
+PORTVERSION= 2.0.2
PORTEPOCH= 1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_GENTOO}
diff --git a/audio/akode-plugins-mpeg/distinfo b/audio/akode-plugins-mpeg/distinfo
index 2dd6d912909d..3b0828c8e327 100644
--- a/audio/akode-plugins-mpeg/distinfo
+++ b/audio/akode-plugins-mpeg/distinfo
@@ -1,3 +1,3 @@
-MD5 (30375-akode-2.0.1.tar.bz2) = 94a10e7729b20b669bc5c7721f62e162
-SHA256 (30375-akode-2.0.1.tar.bz2) = a1a31d3ea59e151ff1ff51e9f2be0db84fc9fcb40f590abb1c46494d6ff1c08e
-SIZE (30375-akode-2.0.1.tar.bz2) = 460964
+MD5 (30375-akode-2.0.2.tar.bz2) = 659ced0c9c735cb3e55b9138ff02342c
+SHA256 (30375-akode-2.0.2.tar.bz2) = ad689f7b3531cc3c42fda07c264873360bc0f4a94b90c1a4c91c92a22333a7a6
+SIZE (30375-akode-2.0.2.tar.bz2) = 472605
diff --git a/audio/akode-plugins-oss/Makefile b/audio/akode-plugins-oss/Makefile
index 4f55d42c3972..668218e8a41f 100644
--- a/audio/akode-plugins-oss/Makefile
+++ b/audio/akode-plugins-oss/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= akode-plugins-${PORTNAMESUFX}
-PORTVERSION= 2.0.1
+PORTVERSION= 2.0.2
PORTEPOCH= 1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_GENTOO}
diff --git a/audio/akode-plugins-oss/distinfo b/audio/akode-plugins-oss/distinfo
index 2dd6d912909d..3b0828c8e327 100644
--- a/audio/akode-plugins-oss/distinfo
+++ b/audio/akode-plugins-oss/distinfo
@@ -1,3 +1,3 @@
-MD5 (30375-akode-2.0.1.tar.bz2) = 94a10e7729b20b669bc5c7721f62e162
-SHA256 (30375-akode-2.0.1.tar.bz2) = a1a31d3ea59e151ff1ff51e9f2be0db84fc9fcb40f590abb1c46494d6ff1c08e
-SIZE (30375-akode-2.0.1.tar.bz2) = 460964
+MD5 (30375-akode-2.0.2.tar.bz2) = 659ced0c9c735cb3e55b9138ff02342c
+SHA256 (30375-akode-2.0.2.tar.bz2) = ad689f7b3531cc3c42fda07c264873360bc0f4a94b90c1a4c91c92a22333a7a6
+SIZE (30375-akode-2.0.2.tar.bz2) = 472605
diff --git a/audio/akode-plugins-resampler/Makefile b/audio/akode-plugins-resampler/Makefile
index 3c8436adb9ae..f0a6be11fc5f 100644
--- a/audio/akode-plugins-resampler/Makefile
+++ b/audio/akode-plugins-resampler/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= akode-plugins-${PORTNAMESUFX}
-PORTVERSION= 2.0.1
+PORTVERSION= 2.0.2
PORTEPOCH= 1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_GENTOO}
diff --git a/audio/akode-plugins-resampler/distinfo b/audio/akode-plugins-resampler/distinfo
index 2dd6d912909d..3b0828c8e327 100644
--- a/audio/akode-plugins-resampler/distinfo
+++ b/audio/akode-plugins-resampler/distinfo
@@ -1,3 +1,3 @@
-MD5 (30375-akode-2.0.1.tar.bz2) = 94a10e7729b20b669bc5c7721f62e162
-SHA256 (30375-akode-2.0.1.tar.bz2) = a1a31d3ea59e151ff1ff51e9f2be0db84fc9fcb40f590abb1c46494d6ff1c08e
-SIZE (30375-akode-2.0.1.tar.bz2) = 460964
+MD5 (30375-akode-2.0.2.tar.bz2) = 659ced0c9c735cb3e55b9138ff02342c
+SHA256 (30375-akode-2.0.2.tar.bz2) = ad689f7b3531cc3c42fda07c264873360bc0f4a94b90c1a4c91c92a22333a7a6
+SIZE (30375-akode-2.0.2.tar.bz2) = 472605
diff --git a/audio/akode-plugins-xiph/Makefile b/audio/akode-plugins-xiph/Makefile
index b08971b8c616..a6469e6d9b06 100644
--- a/audio/akode-plugins-xiph/Makefile
+++ b/audio/akode-plugins-xiph/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= akode-plugins-${PORTNAMESUFX}
-PORTVERSION= 2.0.1
-PORTREVISION= 2
+PORTVERSION= 2.0.2
PORTEPOCH= 1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_GENTOO}
diff --git a/audio/akode-plugins-xiph/distinfo b/audio/akode-plugins-xiph/distinfo
index 2dd6d912909d..3b0828c8e327 100644
--- a/audio/akode-plugins-xiph/distinfo
+++ b/audio/akode-plugins-xiph/distinfo
@@ -1,3 +1,3 @@
-MD5 (30375-akode-2.0.1.tar.bz2) = 94a10e7729b20b669bc5c7721f62e162
-SHA256 (30375-akode-2.0.1.tar.bz2) = a1a31d3ea59e151ff1ff51e9f2be0db84fc9fcb40f590abb1c46494d6ff1c08e
-SIZE (30375-akode-2.0.1.tar.bz2) = 460964
+MD5 (30375-akode-2.0.2.tar.bz2) = 659ced0c9c735cb3e55b9138ff02342c
+SHA256 (30375-akode-2.0.2.tar.bz2) = ad689f7b3531cc3c42fda07c264873360bc0f4a94b90c1a4c91c92a22333a7a6
+SIZE (30375-akode-2.0.2.tar.bz2) = 472605
diff --git a/audio/akode/Makefile b/audio/akode/Makefile
index a113bd797c3f..cddd1a7afdaf 100644
--- a/audio/akode/Makefile
+++ b/audio/akode/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= akode
-PORTVERSION= 2.0.1
+PORTVERSION= 2.0.2
PORTEPOCH= 1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_GENTOO}
@@ -19,7 +19,8 @@ COMMENT= Default KDE audio backend
CONFLICTS= kdemultimedia-3.[1-3]*
-OPTIONS= JACK "Jack output plugin" off \
+OPTIONS= FFMPEG "FFMPEG decoder plugin" off \
+ JACK "Jack output plugin" off \
MPC "Monkey's Audio decoder plugin" on \
MPEG "MPEG Audio (including mp3) plugin" on \
OSS "OSS output plugin" on \
@@ -41,6 +42,10 @@ CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
.include <bsd.port.pre.mk>
+.if defined(WITH_FFMPEG)
+RUN_DEPENDS= ${LOCALBASE}/lib/libakode_ffmpeg_decoder.so:${PORTSDIR}/audio/akode-plugins-ffmpeg
+.endif
+
.if defined(WITH_JACK)
RUN_DEPENDS+= ${LOCALBASE}/lib/libakode_jack_sink.so:${PORTSDIR}/audio/akode-plugins-jack
.endif
diff --git a/audio/akode/distinfo b/audio/akode/distinfo
index 2dd6d912909d..3b0828c8e327 100644
--- a/audio/akode/distinfo
+++ b/audio/akode/distinfo
@@ -1,3 +1,3 @@
-MD5 (30375-akode-2.0.1.tar.bz2) = 94a10e7729b20b669bc5c7721f62e162
-SHA256 (30375-akode-2.0.1.tar.bz2) = a1a31d3ea59e151ff1ff51e9f2be0db84fc9fcb40f590abb1c46494d6ff1c08e
-SIZE (30375-akode-2.0.1.tar.bz2) = 460964
+MD5 (30375-akode-2.0.2.tar.bz2) = 659ced0c9c735cb3e55b9138ff02342c
+SHA256 (30375-akode-2.0.2.tar.bz2) = ad689f7b3531cc3c42fda07c264873360bc0f4a94b90c1a4c91c92a22333a7a6
+SIZE (30375-akode-2.0.2.tar.bz2) = 472605