aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/py-obspy/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/science/py-obspy/Makefile b/science/py-obspy/Makefile
index a7ef4e1ad817..96d73c386d9c 100644
--- a/science/py-obspy/Makefile
+++ b/science/py-obspy/Makefile
@@ -21,11 +21,10 @@ BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0:${PORTSDIR}/databases/py-sqlalchemy
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= fortran zip
+USES= fortran zip python
USE_LDCONFIG= yes
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+LDFLAGS+= -shared
+USE_PYTHON= distutils autoplist
post-patch:
${REINPLACE_CMD} -e "s#FC#${FC}#g" ${WRKSRC}/setup.py