aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/php70/Makefile2
-rw-r--r--lang/php70/Makefile.ext24
2 files changed, 14 insertions, 12 deletions
diff --git a/lang/php70/Makefile b/lang/php70/Makefile
index c35d83b5004d..68eabe0f005d 100644
--- a/lang/php70/Makefile
+++ b/lang/php70/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php70
PORTVERSION= 7.0.3
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${PORTVERSION}
diff --git a/lang/php70/Makefile.ext b/lang/php70/Makefile.ext
index 1f449fa43724..ae25af4718fa 100644
--- a/lang/php70/Makefile.ext
+++ b/lang/php70/Makefile.ext
@@ -239,17 +239,6 @@ CONFIGURE_ARGS+=--with-pdo-firebird=${LOCALBASE}
USES+= firebird
USE_PHP= pdo
USE_PHP_BUILD= yes
-
-.endif
-
-.if ${PHP_MODNAME} == "pdo_mysql"
-CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
-USE_PHP=pdo
-USE_PHP_BUILD= yes
-.else
-CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
- --with-zlib-dir=/usr
-USE_MYSQL= yes
.endif
.if ${PHP_MODNAME} == "pdo_odbc"
@@ -546,6 +535,19 @@ USE_MYSQL= yes
. endif
.endif
+.if ${PHP_MODNAME} == "pdo_mysql"
+USE_PHP=pdo
+USE_PHP_BUILD= yes
+. if ${PORT_OPTIONS:MMYSQLND}
+CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
+USE_PHP+= mysqli
+. else
+CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
+ --with-zlib-dir=/usr
+USE_MYSQL= yes
+. endif
+.endif
+
.if ${PHP_MODNAME} == "openssl" || ${PHP_MODNAME} == "sqlite3"
post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4