aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/gtic/Makefile8
-rw-r--r--net/gtic/files/patch-aa10
-rw-r--r--net/gtic/files/patch-ac50
3 files changed, 62 insertions, 6 deletions
diff --git a/net/gtic/Makefile b/net/gtic/Makefile
index 82e26dd68608..32d2f7f6124f 100644
--- a/net/gtic/Makefile
+++ b/net/gtic/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 August 1999
# Whom: Denis Shaposhnikov <dsh@vlink.ru>
#
-# $Id$
+# $FreeBSD$
#
DISTNAME= gtic-1.3b
@@ -14,6 +14,12 @@ MASTER_SITE_SUBDIR= system/fido
MAINTAINER= dsh@vlink.ru
+MAKE_ENV+= DEFINES="${DEFINES}"
+
+.if defined(WITH_AMIGA4D)
+DEFINES+= -DAMIGA4D
+.endif
+
do-install:
${MKDIR} ${PREFIX}/etc/gtic
.for i in areagroups areas config domains help users
diff --git a/net/gtic/files/patch-aa b/net/gtic/files/patch-aa
index 09698e046650..a1f6346eb18a 100644
--- a/net/gtic/files/patch-aa
+++ b/net/gtic/files/patch-aa
@@ -1,5 +1,5 @@
--- CONFIG.orig Mon Jul 6 16:09:40 1998
-+++ CONFIG Sun Aug 22 14:40:57 1999
++++ CONFIG Sun Mar 5 19:42:04 2000
@@ -2,7 +2,7 @@
VERSION = "1.3b"
@@ -9,7 +9,7 @@
# Path to other configuration files (also see default config file).
CONFIGDIR = "/etc/gtic"
-@@ -15,10 +15,10 @@
+@@ -15,13 +15,13 @@
GROUP = gtic
# Name of C compiler.
@@ -21,4 +21,8 @@
+#CFLAGS=-Wall -g
# Defines for gtic's sources use.
- DEFINES = ${OPTS} -DCONFIG=\"${CONFIG}\" -DVERSION=\"${VERSION}\"
+-DEFINES = ${OPTS} -DCONFIG=\"${CONFIG}\" -DVERSION=\"${VERSION}\"
++DEFINES += ${OPTS} -DCONFIG=\"${CONFIG}\" -DVERSION=\"${VERSION}\"
+
+ # Compile-time options.
+
diff --git a/net/gtic/files/patch-ac b/net/gtic/files/patch-ac
index 68f57888d12b..c872ca60c7ad 100644
--- a/net/gtic/files/patch-ac
+++ b/net/gtic/files/patch-ac
@@ -1,6 +1,52 @@
--- src/toss.c.orig Mon Jul 6 16:04:30 1998
-+++ src/toss.c Sun Sep 12 15:41:01 1999
-@@ -873,7 +873,7 @@
++++ src/toss.c Sun Mar 5 18:35:41 2000
+@@ -316,11 +316,16 @@
+ newtic->areadesc=xstrcpy(acur->desc);
+
+ /* make base of outbound file name */
++#ifndef AMIGA4D
+ if(utmp->addr.point!=0)
+ snprintf(ftmp,sizeof(ftmp)-1,"%04x%04x.pnt/%08x",
+ utmp->addr.net,utmp->addr.node,utmp->addr.point);
+ else
+ snprintf(ftmp,sizeof(ftmp)-1,"%04x%04x",utmp->addr.net,utmp->addr.node);
++#else
++ snprintf(ftmp,sizeof(ftmp)-1,"%d.%d.%d.%d", utmp->addr.zone,
++ utmp->addr.net, utmp->addr.node, utmp->addr.point);
++#endif /* AMIGA4D */
+
+ /* determine queue directory */
+ strcpy(qdir,get_outbound(utmp->addr.zone)); strcat(qdir,"/");
+@@ -342,21 +347,28 @@
+ outbound/xxxxyyyy.pnt[/gtic_q]/zzzzzzzz.xlo
+ */
+ strcpy(xlo,get_outbound(utmp->addr.zone)); strcat(xlo,"/");
++#ifndef AMIGA4D
+ if(utmp->addr.point!=0)
+ {
+ snprintf(ftmp,sizeof(ftmp)-1,"%04x%04x.pnt/",
+ utmp->addr.net,utmp->addr.node);
+ strcat(xlo,ftmp);
+ }
++#endif /* AMIGA4D */
+ if(mk_bsy==FALSE)
+ {
+ strcat(xlo,"gtic_q/");
+ mkdirs(xlo,dirmode(outbound_mode));
+ }
++#ifndef AMIGA4D
+ if(newtic->to.point!=0)
+ snprintf(ftmp,sizeof(ftmp)-1,"%08x",newtic->to.point);
+ else
+ snprintf(ftmp,sizeof(ftmp)-1,"%04x%04x",newtic->to.net,newtic->to.node);
++#else
++ snprintf(ftmp,sizeof(ftmp)-1,"%d.%d.%d.%d", newtic->to.zone,
++ newtic->to.net, newtic->to.node, newtic->to.point);
++#endif /* AMIGA4D */
+ if(utmp->flags & USER_HOLD)
+ strcat(ftmp,".hlo");
+ else
+@@ -873,7 +885,7 @@
if(announce_f)
{