aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/libesmtp/Makefile4
-rw-r--r--mail/libesmtp/files/patch-Makefile.in11
-rw-r--r--mail/libesmtp/files/patch-aa11
-rw-r--r--mail/libesmtp/files/patch-ab11
-rw-r--r--mail/libesmtp/files/patch-ac11
-rw-r--r--mail/libesmtp/files/patch-ltmain.sh18
-rw-r--r--mail/libesmtp/pkg-plist4
7 files changed, 21 insertions, 49 deletions
diff --git a/mail/libesmtp/Makefile b/mail/libesmtp/Makefile
index 482205a8f984..64cc509a608e 100644
--- a/mail/libesmtp/Makefile
+++ b/mail/libesmtp/Makefile
@@ -15,10 +15,12 @@ MAINTAINER= jmcoopr@webmail.bmi.net
USE_BZIP2= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
# the following is required for Balsa-1.17
CONFIGURE_ARGS= --enable-require-all-recipients
diff --git a/mail/libesmtp/files/patch-Makefile.in b/mail/libesmtp/files/patch-Makefile.in
deleted file mode 100644
index 2fe920965987..000000000000
--- a/mail/libesmtp/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in Fri Jul 6 15:00:38 2001
-+++ Makefile.in.new Fri Jul 13 13:38:34 2001
-@@ -79,7 +79,7 @@
- LIBESMTP_VERSION = @LIBESMTP_VERSION@
- LIBLTDL = @LIBLTDL@
- LIBS = @LIBS@
--LIBTOOL = @LIBTOOL@
-+LIBTOOL = ${SHELL} ${top_builddir}/libltdl/libtool
- LIBTOOL_DEPS = @LIBTOOL_DEPS@
- LIB_AGE = @LIB_AGE@
- LIB_CURRENT = @LIB_CURRENT@
diff --git a/mail/libesmtp/files/patch-aa b/mail/libesmtp/files/patch-aa
deleted file mode 100644
index e5a72b494906..000000000000
--- a/mail/libesmtp/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./crammd5/Makefile.in Fri Jul 6 15:01:17 2001
-+++ ./crammd5/Makefile.in.new Fri Jul 13 13:48:31 2001
-@@ -78,7 +78,7 @@
- LIBESMTP_VERSION = @LIBESMTP_VERSION@
- LIBLTDL = @LIBLTDL@
- LIBS = @LIBS@
--LIBTOOL = @LIBTOOL@
-+LIBTOOL = ${SHELL} ${top_builddir}/libltdl/libtool
- LIBTOOL_DEPS = @LIBTOOL_DEPS@
- LIB_AGE = @LIB_AGE@
- LIB_CURRENT = @LIB_CURRENT@
diff --git a/mail/libesmtp/files/patch-ab b/mail/libesmtp/files/patch-ab
deleted file mode 100644
index a9c534ef2d7d..000000000000
--- a/mail/libesmtp/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./login/Makefile.in Fri Jul 6 15:01:12 2001
-+++ ./login/Makefile.in.new Fri Jul 13 13:51:30 2001
-@@ -78,7 +78,7 @@
- LIBESMTP_VERSION = @LIBESMTP_VERSION@
- LIBLTDL = @LIBLTDL@
- LIBS = @LIBS@
--LIBTOOL = @LIBTOOL@
-+LIBTOOL = ${SHELL} ${top_builddir}/libltdl/libtool
- LIBTOOL_DEPS = @LIBTOOL_DEPS@
- LIB_AGE = @LIB_AGE@
- LIB_CURRENT = @LIB_CURRENT@
diff --git a/mail/libesmtp/files/patch-ac b/mail/libesmtp/files/patch-ac
deleted file mode 100644
index 0511152b8f26..000000000000
--- a/mail/libesmtp/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./plain/Makefile.in Fri Jul 6 15:01:14 2001
-+++ ./plain/Makefile.in.new Fri Jul 13 13:53:39 2001
-@@ -78,7 +78,7 @@
- LIBESMTP_VERSION = @LIBESMTP_VERSION@
- LIBLTDL = @LIBLTDL@
- LIBS = @LIBS@
--LIBTOOL = @LIBTOOL@
-+LIBTOOL = ${SHELL} ${top_builddir}/libltdl/libtool
- LIBTOOL_DEPS = @LIBTOOL_DEPS@
- LIB_AGE = @LIB_AGE@
- LIB_CURRENT = @LIB_CURRENT@
diff --git a/mail/libesmtp/files/patch-ltmain.sh b/mail/libesmtp/files/patch-ltmain.sh
new file mode 100644
index 000000000000..782fa51f590c
--- /dev/null
+++ b/mail/libesmtp/files/patch-ltmain.sh
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- ltmain.sh 2001/07/20 09:44:24 1.1
++++ ltmain.sh 2001/07/20 09:44:39
+@@ -4175,10 +4175,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/mail/libesmtp/pkg-plist b/mail/libesmtp/pkg-plist
index 2bc60efe476e..1d6a18e3bde6 100644
--- a/mail/libesmtp/pkg-plist
+++ b/mail/libesmtp/pkg-plist
@@ -3,16 +3,12 @@ include/auth-client.h
include/auth-plugin.h
include/libesmtp.h
lib/esmtp/sasl-cram-md5.a
-lib/esmtp/sasl-cram-md5.la
lib/esmtp/sasl-cram-md5.so
lib/esmtp/sasl-login.a
-lib/esmtp/sasl-login.la
lib/esmtp/sasl-login.so
lib/esmtp/sasl-plain.a
-lib/esmtp/sasl-plain.la
lib/esmtp/sasl-plain.so
lib/libesmtp.a
-lib/libesmtp.la
lib/libesmtp.so
lib/libesmtp.so.5
%%PORTDOCS%%share/doc/libesmtp/INSTALL