aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/ripit/Makefile25
-rw-r--r--audio/ripit/distinfo1
-rw-r--r--audio/ripit/files/patch-aa41
-rw-r--r--audio/ripit/pkg-comment1
-rw-r--r--audio/ripit/pkg-descr11
-rw-r--r--audio/ripit/pkg-plist1
6 files changed, 80 insertions, 0 deletions
diff --git a/audio/ripit/Makefile b/audio/ripit/Makefile
new file mode 100644
index 000000000000..e66bd538a7d9
--- /dev/null
+++ b/audio/ripit/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: ripit
+# Version required: 1.2
+# Date created: 2 May 1999
+# Whom: oyvindmo@initio.no
+#
+# $Id$
+#
+
+DISTNAME= ripit-1.2
+CATEGORIES= audio
+MASTER_SITES= http://www.netcomuk.co.uk/~squinn/
+
+MAINTAINER= oyvindmo@initio.no
+
+RUN_DEPENDS= bladeenc:${PORTSDIR}/audio/bladeenc \
+ tosha:${PORTSDIR}/audio/tosha \
+ cda:${PORTSDIR}/audio/xmcd
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+do-install:
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/ripit.pl ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/audio/ripit/distinfo b/audio/ripit/distinfo
new file mode 100644
index 000000000000..f6539e83526b
--- /dev/null
+++ b/audio/ripit/distinfo
@@ -0,0 +1 @@
+MD5 (ripit-1.2.tar.gz) = a760057cd7a9b6d7bab4e911af5cc3a2
diff --git a/audio/ripit/files/patch-aa b/audio/ripit/files/patch-aa
new file mode 100644
index 000000000000..68abae7365c5
--- /dev/null
+++ b/audio/ripit/files/patch-aa
@@ -0,0 +1,41 @@
+diff -uNr ../ripit-1.2.old/ripit.pl ./ripit.pl
+--- ../ripit-1.2.old/ripit.pl Sun May 2 18:24:11 1999
++++ ./ripit.pl Sun May 2 18:27:10 1999
+@@ -26,8 +26,8 @@
+ # User configurable variables
+ #
+
+-$cddev = "/dev/cdrom"; # CD Audio device
+-$outputdir = "/dosc/cdrip/"; # Where the MP3s should go
++$cddev = "/dev/rcd0c"; # CD Audio device
++$outputdir = "/home/mp3/"; # Where the MP3s should go
+ $bitrate = 160; # Bitrate for MP3s
+
+ $use_underscore = 0; # Use _ instead of spaces in filenames (1 yes, 0 no)
+@@ -312,14 +312,11 @@
+
+ &printflush(RIPLOG,"Ripping $tracklist[$_ - 1]...\n");
+
+- if (system("cdparanoia -d $cddev $riptrackno \"$riptrackname.rip\"")) {
+- &printflush(RIPLOG,"cdparanoia failed on $tracklist[$_ - 1]\n");
+- die "cdparanoia failed on $tracklist[$_ - 1]";
++ if (system("tosha -d $cddev -f wav -t $riptrackno -o \"$riptrackname.wav\"")) {
++ &printflush(RIPLOG,"tosha failed on $tracklist[$_ - 1]\n");
++ die "tosha failed on $tracklist[$_ - 1]";
+ }
+
+- # Rename rip file to a wav so bladeenc will encode it
+- rename "$riptrackname.rip","$riptrackname.wav";
+-
+ &printflush(RIPLOG,"Rip complete $tracklist[$_ - 1]\n");
+
+ # Start the Encoder in the background. but only once
+@@ -349,7 +346,7 @@
+ print "\nBladeenc Encoding track ".$ncount." of ".($#seltrack + 1)."\n";
+ &printflush(RIPLOG,"Encoding $tracklist[$_ - 1]...\n");
+
+- # Keep looping until the file appears, ie wait for cdparanoia
++ # Keep looping until the file appears, ie wait for tosha
+ # timeout after 30 minutes
+ $x=0;
+ while( ! -r "$riptrackname.wav" ){
diff --git a/audio/ripit/pkg-comment b/audio/ripit/pkg-comment
new file mode 100644
index 000000000000..2d225b987a42
--- /dev/null
+++ b/audio/ripit/pkg-comment
@@ -0,0 +1 @@
+A perl-script frontend for encoding audio CDs to MP3 files.
diff --git a/audio/ripit/pkg-descr b/audio/ripit/pkg-descr
new file mode 100644
index 000000000000..ae21dbbbea43
--- /dev/null
+++ b/audio/ripit/pkg-descr
@@ -0,0 +1,11 @@
+ripit
+-----
+
+ripit is a small front-end program written in perl for ripping,
+encoding & tagging MP3s. It is a console program that needs no user
+intervention. It requires tosha, bladeenc and xmcd (for CDDB access).
+
+http://www.netcomuk.co.uk/~squinn/ripit.html
+
+--
+Port by Oyvind Moll <oyvindmo@initio.no>
diff --git a/audio/ripit/pkg-plist b/audio/ripit/pkg-plist
new file mode 100644
index 000000000000..cd38f19aa1f6
--- /dev/null
+++ b/audio/ripit/pkg-plist
@@ -0,0 +1 @@
+bin/ripit.pl