aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-pystache/Makefile23
-rw-r--r--textproc/py-pystache/distinfo2
-rw-r--r--textproc/py-pystache/pkg-descr5
4 files changed, 31 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index f4b259c6b416..c987e5fcf343 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1126,6 +1126,7 @@
SUBDIR += py-paragrep
SUBDIR += py-pss
SUBDIR += py-pygments
+ SUBDIR += py-pystache
SUBDIR += py-pyx12
SUBDIR += py-qt4-xml
SUBDIR += py-qt4-xmlpatterns
diff --git a/textproc/py-pystache/Makefile b/textproc/py-pystache/Makefile
new file mode 100644
index 000000000000..3cb40e0a29dd
--- /dev/null
+++ b/textproc/py-pystache/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: pystache
+# Date created: 19 March 2012
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+
+PORTNAME= pystache
+PORTVERSION= 0.4.0
+CATEGORIES= textproc www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= magik@roorback.net
+COMMENT= Logic-less templates for Python
+
+LICENSE= MIT
+
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/textproc/py-pystache/distinfo b/textproc/py-pystache/distinfo
new file mode 100644
index 000000000000..b3e24d46a360
--- /dev/null
+++ b/textproc/py-pystache/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pystache-0.4.0.tar.gz) = afdcf222583193f1dcca17b1e6801a864b05c1e772abff90c88f41f4f77b3ae9
+SIZE (pystache-0.4.0.tar.gz) = 6360
diff --git a/textproc/py-pystache/pkg-descr b/textproc/py-pystache/pkg-descr
new file mode 100644
index 000000000000..a18959804767
--- /dev/null
+++ b/textproc/py-pystache/pkg-descr
@@ -0,0 +1,5 @@
+Pystache is a Python implementation of Mustache.
+Inspired by ctemplate and et, Mustache is a framework-agnostic
+way to render logic-free views.
+
+WWW: https://github.com/defunkt/pystache