aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django41/Makefile73
-rw-r--r--www/py-django41/distinfo3
-rw-r--r--www/py-django41/pkg-descr10
4 files changed, 87 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 070409d39cbd..3d819d41f23d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1559,6 +1559,7 @@
SUBDIR += py-django-widget-tweaks
SUBDIR += py-django32
SUBDIR += py-django40
+ SUBDIR += py-django41
SUBDIR += py-django_compressor
SUBDIR += py-djangocms-admin-style
SUBDIR += py-djangoql
diff --git a/www/py-django41/Makefile b/www/py-django41/Makefile
new file mode 100644
index 000000000000..5e02c199c1b0
--- /dev/null
+++ b/www/py-django41/Makefile
@@ -0,0 +1,73 @@
+# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+
+PORTNAME= django
+PORTVERSION= 4.1
+CATEGORIES= www python
+MASTER_SITES= https://media.djangoproject.com/releases/4.1/ \
+ CHEESESHOP \
+ https://www.djangoproject.com/m/releases/${PORTVERSION}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 41
+DISTNAME= Django-${PORTVERSION}
+DIST_SUBDIR= python
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= High-level Python Web Framework
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}backports.zoneinfo>0:devel/py-backports.zoneinfo@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}asgiref>=3.5.2:www/py-asgiref@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlparse>=0.2.2:databases/py-sqlparse@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tblib>0:devel/py-tblib@${PY_FLAVOR}
+
+USES= cpe python:3.8+ shebangfix
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+DOCSDIR= ${PREFIX}/share/doc/py-django
+PLIST_FILES= man/man1/django-admin.1.gz
+PORTDOCS= *
+
+SHEBANG_FILES= django/conf/project_template/manage.py-tpl
+
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}django22 \
+ ${PYTHON_PKGNAMEPREFIX}django31 \
+ ${PYTHON_PKGNAMEPREFIX}django40
+
+CPE_VENDOR= djangoproject
+
+# Upstream archive contains files with UTF-8 names
+EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
+
+OPTIONS_DEFINE= DOCS HTMLDOCS
+OPTIONS_GROUP= DATABASE
+OPTIONS_GROUP_DATABASE= PGSQL MYSQL SQLITE
+OPTIONS_DEFAULT=SQLITE
+HTMLDOCS_DESC= Install HTML documentation (requires Sphinx)
+
+HTMLDOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_FLAVOR}
+HTMLDOCS_IMPLIES= DOCS
+PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:databases/py-psycopg2@${PY_FLAVOR}
+MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mysqlclient>=1.3.13:databases/py-mysqlclient@${PY_FLAVOR}
+SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
+
+post-build-HTMLDOCS-on:
+ cd ${WRKSRC}/docs && ${MAKE} html SPHINXBUILD=sphinx-build-${PYTHON_VER}
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/docs/man/* ${STAGEDIR}/${MAN1PREFIX}/man/man1
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " * See http://docs.djangoproject.com/ for complete documentation"
+ @${ECHO_MSG} ""
+
+post-install-HTMLDOCS-on:
+ ${MKDIR} ${STAGEDIR}/${DOCSDIR}
+ ${CP} -R ${WRKSRC}/docs/_build/html ${STAGEDIR}/${DOCSDIR}
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} tests/runtests.py --settings=test_sqlite
+
+.include <bsd.port.mk>
diff --git a/www/py-django41/distinfo b/www/py-django41/distinfo
new file mode 100644
index 000000000000..dbeffeaede42
--- /dev/null
+++ b/www/py-django41/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1659655147
+SHA256 (python/Django-4.1.tar.gz) = 032f8a6fc7cf05ccd1214e4a2e21dfcd6a23b9d575c6573cacc8c67828dbe642
+SIZE (python/Django-4.1.tar.gz) = 10484595
diff --git a/www/py-django41/pkg-descr b/www/py-django41/pkg-descr
new file mode 100644
index 000000000000..0ea493b87ab6
--- /dev/null
+++ b/www/py-django41/pkg-descr
@@ -0,0 +1,10 @@
+Django is a high-level Python Web framework that encourages rapid development
+and clean, pragmatic design.
+
+Developed and used over the past two years by a fast-moving online-news
+operation, Django was designed from scratch to handle two challenges: the
+intensive deadlines of a newsroom and the stringent requirements of experienced
+Web developers. It has convenient niceties for developing content-management
+systems, but it's an excellent tool for building any Web site.
+
+WWW: https://www.djangoproject.com/