aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.ruby.mk2
-rw-r--r--devel/rubygem-irb/Makefile16
-rw-r--r--devel/rubygem-rdoc/Makefile12
-rw-r--r--lang/ruby27/Makefile8
-rw-r--r--lang/ruby27/pkg-message9
-rw-r--r--lang/ruby27/pkg-plist10
6 files changed, 34 insertions, 23 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index b49c42b6fbf7..251ad237e2b6 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -176,7 +176,7 @@ RUBY26= "" # PLIST_SUB helpers
# Ruby 2.7
#
RUBY_VERSION= 2.7.0
-RUBY_PORTREVISION= 1
+RUBY_PORTREVISION= 2
RUBY_PORTEPOCH= 1
RUBY27= "" # PLIST_SUB helpers
diff --git a/devel/rubygem-irb/Makefile b/devel/rubygem-irb/Makefile
index 7cb5869986c4..c726239193e7 100644
--- a/devel/rubygem-irb/Makefile
+++ b/devel/rubygem-irb/Makefile
@@ -2,6 +2,7 @@
PORTNAME= irb
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
@@ -20,12 +21,19 @@ NO_ARCH= yes
.include <bsd.port.pre.mk>
-.if ${RUBY_VER} < 2.6
-IGNORE= irb is included in lang/${RUBY_NAME}
-.endif
+.if ${RUBY_VER} >= 2.7
+PLIST_FILES= bin/irb \
+ share/man/man1/irb.1.gz
-# irb executable is installed by ruby port
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/man/irb.1
+.elif ${RUBY_VER} == 2.6
+# WIP: irb wrapper script is installed by ruby port so far, see bug 241554, 237833
post-install:
${RM} ${STAGEDIR}${PREFIX}/bin/irb
+.else
+IGNORE= ${PORTNAME} is included in lang/${RUBY_NAME}
+.endif
.include <bsd.port.post.mk>
diff --git a/devel/rubygem-rdoc/Makefile b/devel/rubygem-rdoc/Makefile
index 946b04057e2a..358ce11d3471 100644
--- a/devel/rubygem-rdoc/Makefile
+++ b/devel/rubygem-rdoc/Makefile
@@ -2,6 +2,7 @@
PORTNAME= rdoc
PORTVERSION= 6.1.2
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
@@ -17,7 +18,16 @@ USE_RUBY= yes
NO_ARCH= yes
+.include <bsd.port.pre.mk>
+
+.if ${RUBY_VER} >= 2.7
+PLIST_FILES= bin/rdoc bin/ri
+.elif ${RUBY_VER} == 2.6
+# WIP: rdoc wrapper script is installed by ruby port so far, see bug 241554, 237833
post-install:
${RM} ${STAGEDIR}${PREFIX}/bin/rdoc ${STAGEDIR}${PREFIX}/bin/ri
+.else
+IGNORE= ${PORTNAME} is included in lang/${RUBY_NAME}
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/ruby27/Makefile b/lang/ruby27/Makefile
index abc05113b839..fed65a02db40 100644
--- a/lang/ruby27/Makefile
+++ b/lang/ruby27/Makefile
@@ -118,8 +118,8 @@ PKGNAMESUFFIX= ${RUBY_VER:C/\.//}
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
-INSTALLED_SCRIPTS= erb irb rdoc ri ruby
-INSTALLED_MANUALS= erb irb ri ruby
+INSTALLED_SCRIPTS= erb ruby
+INSTALLED_MANUALS= erb ruby
EXTSAMPLES= bigdecimal/sample/*.rb
@@ -133,7 +133,9 @@ RB_SET_CONF_VAR=${SH} -c '${REINPLACE_CMD} -E -e "s,(CONFIG\[\"$$0\"\][[:space:]
post-patch:
# We get these from other ports
-.for d in bin/bundle* bin/*racc* lib/bundler* libexec/bundler* man/bundle* bin/gem man/gemfile* \
+.for d in bin/bundle* bin/gem bin/*racc* bin/irb bin/rdoc bin/ri \
+ lib/bundler* libexec/bundler* \
+ man/bundle* man/gemfile* man/irb.1 man/ri.1 \
ext/dbm ext/gdbm ext/win32ole
@${RM} -r ${BUILD_WRKSRC}/${d}
.endfor
diff --git a/lang/ruby27/pkg-message b/lang/ruby27/pkg-message
index a35ee1279372..f17727bf3fcb 100644
--- a/lang/ruby27/pkg-message
+++ b/lang/ruby27/pkg-message
@@ -4,10 +4,11 @@
Some of the standard commands are provided as separate ports for ease
of upgrading:
- devel/ruby-gems: gem - RubyGems package manager
- devel/rubygem-irb: irb - Interactive Ruby
- devel/rubygem-rake: rake - Ruby Make
- devel/rubygem-rdoc: rdoc - Ruby Documentation System
+ devel/ruby-gems: gem - RubyGems package manager
+ devel/rubygem-irb: irb - Interactive Ruby
+ devel/rubygem-rake: rake - Ruby Make
+ devel/rubygem-rdoc: rdoc - Ruby Documentation System
+ sysutils/rubygem-bundler: bundler - Tool that manages gem dependencies for ruby applications
And some of the standard libraries are provided as separate ports
since they require extra dependencies:
diff --git a/lang/ruby27/pkg-plist b/lang/ruby27/pkg-plist
index 734b338d35c0..7879a660d1ec 100644
--- a/lang/ruby27/pkg-plist
+++ b/lang/ruby27/pkg-plist
@@ -1,11 +1,5 @@
%%IF_DEFAULT%%bin/erb
bin/erb%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/irb
-bin/irb%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/rdoc
-bin/rdoc%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/ri
-bin/ri%%RUBY_SUFFIX%%
%%IF_DEFAULT%%bin/ruby
bin/ruby%%RUBY_SUFFIX%%
include/ruby-%%RUBY_VER%%/%%RUBY_ARCH%%/rb_mjit_min_header-%%RUBY_VERSION%%.h
@@ -960,10 +954,6 @@ lib/lib%%RUBY_NAME%%.so.%%RUBY_SHLIBVER%%
libdata/pkgconfig/ruby-%%RUBY_VER%%.pc
%%IF_DEFAULT%%man/man1/erb.1.gz
man/man1/erb%%RUBY_SUFFIX%%.1.gz
-%%IF_DEFAULT%%man/man1/irb.1.gz
-man/man1/irb%%RUBY_SUFFIX%%.1.gz
-%%IF_DEFAULT%%man/man1/ri.1.gz
-man/man1/ri%%RUBY_SUFFIX%%.1.gz
%%IF_DEFAULT%%man/man1/ruby.1.gz
man/man1/%%RUBY_NAME%%.1.gz
%%DOCS%%%%RUBY_DOCDIR%%/COPYING