aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/httping/Makefile3
-rw-r--r--net/httping/distinfo6
-rw-r--r--net/httping/files/patch-Makefile20
3 files changed, 14 insertions, 15 deletions
diff --git a/net/httping/Makefile b/net/httping/Makefile
index 7ba09bcf2674..3693f2783211 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= httping
-PORTVERSION= 1.3.0
+PORTVERSION= 1.3.1
CATEGORIES= net
MASTER_SITES= http://www.vanheusden.com/httping/ \
CRITICAL
@@ -15,6 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A ping-like tool for HTTP requests
+USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
MAN1= httping.1
diff --git a/net/httping/distinfo b/net/httping/distinfo
index cedf758bec70..3a06962b2d9c 100644
--- a/net/httping/distinfo
+++ b/net/httping/distinfo
@@ -1,3 +1,3 @@
-MD5 (httping-1.3.0.tgz) = 41c912a9ecc904e51d7260053fc2195c
-SHA256 (httping-1.3.0.tgz) = 0d86bc4f25a2b40c28e4c74c8e35b7bb618eec2c30e9145689e219d76cba3690
-SIZE (httping-1.3.0.tgz) = 13433
+MD5 (httping-1.3.1.tgz) = fb742d577d3e7a8ea75cf97f7eb802f2
+SHA256 (httping-1.3.1.tgz) = 0649d8b3aa200f03b77dcd69224928602e49abf248568338bed3c5748a94bcf2
+SIZE (httping-1.3.1.tgz) = 12873
diff --git a/net/httping/files/patch-Makefile b/net/httping/files/patch-Makefile
index bd6640c26e33..c9a0fe4d3d57 100644
--- a/net/httping/files/patch-Makefile
+++ b/net/httping/files/patch-Makefile
@@ -1,13 +1,11 @@
---- Makefile.ori Thu Jul 26 10:00:31 2007
-+++ Makefile Tue Sep 25 18:36:53 2007
-@@ -14,9 +14,8 @@
+--- Makefile.orig 2009-08-04 10:55:36.000000000 +0200
++++ Makefile 2009-08-04 10:55:46.000000000 +0200
+@@ -17,7 +17,7 @@
+ TARGET=httping
- include version
-
--DEBUG=-g # -D_DEBUG
- LDFLAGS+=-lssl -lcrypto $(DEBUG)
--CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
-+CFLAGS+=-DVERSION=\"$(VERSION)\"
-
- OBJS=mem.o http.o io.o str.o error.o utils.o main.o tcp.o mssl.o res.o
+ WFLAGS=-Wall -W
+-OFLAGS=-O2
++OFLAGS?=-O2
+ CFLAGS=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
+ PACKAGE=$(TARGET)-$(VERSION)