aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/onetbb/Makefile4
-rw-r--r--devel/onetbb/files/extra-patch-src_tbb_tools__api_ittnotify__config.h11
2 files changed, 15 insertions, 0 deletions
diff --git a/devel/onetbb/Makefile b/devel/onetbb/Makefile
index 5cda501074da..f98ec6f87bdd 100644
--- a/devel/onetbb/Makefile
+++ b/devel/onetbb/Makefile
@@ -39,6 +39,10 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
+.if ${ARCH} == powerpc
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-src_tbb_tools__api_ittnotify__config.h
+.endif
+
post-install:
${INSTALL_DATA} ${WRKDIR}/onetbb.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig
diff --git a/devel/onetbb/files/extra-patch-src_tbb_tools__api_ittnotify__config.h b/devel/onetbb/files/extra-patch-src_tbb_tools__api_ittnotify__config.h
new file mode 100644
index 000000000000..17105704d4cf
--- /dev/null
+++ b/devel/onetbb/files/extra-patch-src_tbb_tools__api_ittnotify__config.h
@@ -0,0 +1,11 @@
+--- src/tbb/tools_api/ittnotify_config.h.orig 2021-06-30 18:42:09 UTC
++++ src/tbb/tools_api/ittnotify_config.h
+@@ -335,7 +335,7 @@ ITT_INLINE long
+ __itt_interlocked_increment(volatile long* ptr) ITT_INLINE_ATTRIBUTE;
+ ITT_INLINE long __itt_interlocked_increment(volatile long* ptr)
+ {
+- return __TBB_machine_fetchadd4(ptr, 1) + 1L;
++ return __atomic_fetch_add(ptr, 1L, __ATOMIC_SEQ_CST) + 1L;
+ }
+ #endif /* ITT_SIMPLE_INIT */
+