aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/p5-Filesys-Virtual-DAAP/Makefile8
-rw-r--r--audio/p5-Net-DAAP-Client/Makefile6
-rw-r--r--databases/p5-Class-DBI-AsForm/Makefile6
-rw-r--r--databases/p5-Class-DBI-DATA-Schema/Makefile4
-rw-r--r--databases/p5-Class-DBI-LazyInflate/Makefile4
-rw-r--r--databases/p5-Class-DBI-Loader-Relationship/Makefile4
-rw-r--r--databases/p5-Class-DBI-Plugin-RetrieveAll/Makefile2
-rw-r--r--databases/p5-Class-DBI-Plugin-Type/Makefile2
-rw-r--r--databases/p5-Class-DBI-Plugin/Makefile2
-rw-r--r--databases/p5-Class-DBI-Untaint/Makefile4
-rw-r--r--devel/p5-Class-Accessor-Lvalue/Makefile4
-rw-r--r--devel/p5-Date-Holidays-DK/Makefile4
-rw-r--r--devel/p5-Log-Dispatch-FileRotate/Makefile6
-rw-r--r--devel/p5-Module-Starter-PBP/Makefile4
-rw-r--r--devel/p5-Test-SubCalls/Makefile4
-rw-r--r--devel/p5-Test-XML/Makefile4
-rw-r--r--games/p5-Games-Bingo-Bot/Makefile2
-rw-r--r--games/p5-Games-Bingo-Print/Makefile12
-rw-r--r--mail/p5-Email-LocalDelivery-Ezmlm/Makefile4
-rw-r--r--mail/p5-Net-IMAP-Simple-SSL/Makefile4
-rw-r--r--mail/p5-URI-imap/Makefile2
-rw-r--r--mail/p5-URI-imaps/Makefile2
-rw-r--r--net-mgmt/ifgraph/Makefile2
-rw-r--r--net-mgmt/p5-Net-SNMP/Makefile2
-rw-r--r--textproc/p5-Lingua-EN-Inflect-Number/Makefile2
-rw-r--r--textproc/p5-Text-RecordParser/Makefile4
-rw-r--r--www/p5-CGI-Ajax/Makefile2
-rw-r--r--www/p5-HTTP-Server-Simple-Static/Makefile8
-rw-r--r--www/p5-Template-Plugin-Class/Makefile2
-rw-r--r--www/p5-Template-Plugin-FillInForm/Makefile4
-rw-r--r--www/p5-Template-Timer/Makefile2
31 files changed, 61 insertions, 61 deletions
diff --git a/audio/p5-Filesys-Virtual-DAAP/Makefile b/audio/p5-Filesys-Virtual-DAAP/Makefile
index 7a827f9265cd..ed3429641128 100644
--- a/audio/p5-Filesys-Virtual-DAAP/Makefile
+++ b/audio/p5-Filesys-Virtual-DAAP/Makefile
@@ -15,10 +15,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Present a DAAP share as a VFS
-RUN_DEPENDS= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
- ${SITE_PERL}/Filesys/Virtual.pm:${PORTSDIR}/devel/p5-Filesys-Virtual \
- ${SITE_PERL}/Filesys/Virtual/Plain.pm:${PORTSDIR}/devel/p5-Filesys-Virtual-Plain \
- ${SITE_PERL}/Net/DAAP/Client.pm:${PORTSDIR}/audio/p5-Net-DAAP-Client
+RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Filesys-Virtual>=0:${PORTSDIR}/devel/p5-Filesys-Virtual \
+ p5-Filesys-Virtual-Plain>=0:${PORTSDIR}/devel/p5-Filesys-Virtual-Plain \
+ p5-Net-DAAP-Client>=0:${PORTSDIR}/audio/p5-Net-DAAP-Client
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
diff --git a/audio/p5-Net-DAAP-Client/Makefile b/audio/p5-Net-DAAP-Client/Makefile
index 5042e0f291d2..bab96130b380 100644
--- a/audio/p5-Net-DAAP-Client/Makefile
+++ b/audio/p5-Net-DAAP-Client/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Client for Apple iTunes DAAP service
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5/M4p.pm:${PORTSDIR}/security/p5-Digest-MD5-M4p \
- ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/Net/DAAP/DMAP.pm:${PORTSDIR}/audio/p5-Net-DAAP-DMAP
+RUN_DEPENDS= p5-Digest-MD5-M4p>=0:${PORTSDIR}/security/p5-Digest-MD5-M4p \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Net-DAAP-DMAP>=0:${PORTSDIR}/audio/p5-Net-DAAP-DMAP
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
diff --git a/databases/p5-Class-DBI-AsForm/Makefile b/databases/p5-Class-DBI-AsForm/Makefile
index 6545db591160..47929c6ba7a0 100644
--- a/databases/p5-Class-DBI-AsForm/Makefile
+++ b/databases/p5-Class-DBI-AsForm/Makefile
@@ -13,9 +13,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Produce HTML form elements for database columns
-BUILD_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI \
- ${SITE_PERL}/HTML/Element.pm:${PORTSDIR}/www/p5-HTML-Tree \
- ${SITE_PERL}/Class/DBI/Plugin/Type.pm:${PORTSDIR}/databases/p5-Class-DBI-Plugin-Type
+BUILD_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI \
+ p5-HTML-Tree>=0:${PORTSDIR}/www/p5-HTML-Tree \
+ p5-Class-DBI-Plugin-Type>=0:${PORTSDIR}/databases/p5-Class-DBI-Plugin-Type
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-Class-DBI-DATA-Schema/Makefile b/databases/p5-Class-DBI-DATA-Schema/Makefile
index a56ad566c427..fac903afc6ea 100644
--- a/databases/p5-Class-DBI-DATA-Schema/Makefile
+++ b/databases/p5-Class-DBI-DATA-Schema/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Execute Class::DBI SQL from DATA sections
-RUN_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI
+RUN_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI
BUILD_DEPENDS= ${RUN_DEPENDS}
-BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS+= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
PERL_CONFIGURE= yes
diff --git a/databases/p5-Class-DBI-LazyInflate/Makefile b/databases/p5-Class-DBI-LazyInflate/Makefile
index 8272985b0ccb..7edd87002744 100644
--- a/databases/p5-Class-DBI-LazyInflate/Makefile
+++ b/databases/p5-Class-DBI-LazyInflate/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Defer inflating of columns until they are used
-BUILD_DEPENDS= ${SITE_PERL}/Data/Lazy.pm:${PORTSDIR}/devel/p5-Data-Lazy \
- ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI
+BUILD_DEPENDS= p5-Data-Lazy>=0:${PORTSDIR}/devel/p5-Data-Lazy \
+ p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-Class-DBI-Loader-Relationship/Makefile b/databases/p5-Class-DBI-Loader-Relationship/Makefile
index 3e795483c88f..ae75da839b9e 100644
--- a/databases/p5-Class-DBI-Loader-Relationship/Makefile
+++ b/databases/p5-Class-DBI-Loader-Relationship/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Easier relationship specification in CDBI::L
-BUILD_DEPENDS= ${SITE_PERL}/Class/DBI/Loader.pm:${PORTSDIR}/databases/p5-Class-DBI-Loader \
- ${SITE_PERL}/Lingua/EN/Inflect/Number.pm:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect-Number
+BUILD_DEPENDS= p5-Class-DBI-Loader>=0:${PORTSDIR}/databases/p5-Class-DBI-Loader \
+ p5-Lingua-EN-Inflect-Number>=0:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect-Number
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-Class-DBI-Plugin-RetrieveAll/Makefile b/databases/p5-Class-DBI-Plugin-RetrieveAll/Makefile
index b242007990ee..27989b2055a0 100644
--- a/databases/p5-Class-DBI-Plugin-RetrieveAll/Makefile
+++ b/databases/p5-Class-DBI-Plugin-RetrieveAll/Makefile
@@ -13,7 +13,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= More complex retrieve_all() for Class::DBI
-BUILD_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI
+BUILD_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
diff --git a/databases/p5-Class-DBI-Plugin-Type/Makefile b/databases/p5-Class-DBI-Plugin-Type/Makefile
index b59ee886e2f1..d9ef6247a3ae 100644
--- a/databases/p5-Class-DBI-Plugin-Type/Makefile
+++ b/databases/p5-Class-DBI-Plugin-Type/Makefile
@@ -13,7 +13,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Determine type information for columns
-BUILD_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI
+BUILD_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
diff --git a/databases/p5-Class-DBI-Plugin/Makefile b/databases/p5-Class-DBI-Plugin/Makefile
index 1ccbef341d83..a28513d009d7 100644
--- a/databases/p5-Class-DBI-Plugin/Makefile
+++ b/databases/p5-Class-DBI-Plugin/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Abstract base class for Class::DBI plugins
-BUILD_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI
+BUILD_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-Class-DBI-Untaint/Makefile b/databases/p5-Class-DBI-Untaint/Makefile
index 003ec0c4f417..f8bf1efac7d0 100644
--- a/databases/p5-Class-DBI-Untaint/Makefile
+++ b/databases/p5-Class-DBI-Untaint/Makefile
@@ -13,8 +13,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Class::DBI constraints using CGI::Untaint
-BUILD_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI \
- ${SITE_PERL}/CGI/Untaint.pm:${PORTSDIR}/www/p5-CGI-Untaint
+BUILD_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI \
+ p5-CGI-Untaint>=0:${PORTSDIR}/www/p5-CGI-Untaint
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
diff --git a/devel/p5-Class-Accessor-Lvalue/Makefile b/devel/p5-Class-Accessor-Lvalue/Makefile
index 1c3902065dd0..8533a98d3eca 100644
--- a/devel/p5-Class-Accessor-Lvalue/Makefile
+++ b/devel/p5-Class-Accessor-Lvalue/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Create Lvalue accessors
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Want.pm:${PORTSDIR}/devel/p5-Want \
- ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor
+BUILD_DEPENDS= p5-Want>=0:${PORTSDIR}/devel/p5-Want \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-Date-Holidays-DK/Makefile b/devel/p5-Date-Holidays-DK/Makefile
index e1ca30e5287a..4c0d10db914e 100644
--- a/devel/p5-Date-Holidays-DK/Makefile
+++ b/devel/p5-Date-Holidays-DK/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Determine Danish public holidays
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Date/Simple.pm:${PORTSDIR}/devel/p5-Date-Simple \
- ${SITE_PERL}/Date/Easter.pm:${PORTSDIR}/devel/p5-Date-Easter
+BUILD_DEPENDS= p5-Date-Simple>=0:${PORTSDIR}/devel/p5-Date-Simple \
+ p5-Date-Easter>=0:${PORTSDIR}/devel/p5-Date-Easter
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Log-Dispatch-FileRotate/Makefile b/devel/p5-Log-Dispatch-FileRotate/Makefile
index 44e3616ff4de..cf030e46f529 100644
--- a/devel/p5-Log-Dispatch-FileRotate/Makefile
+++ b/devel/p5-Log-Dispatch-FileRotate/Makefile
@@ -14,10 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= A Log::Dispatch plug-in for files that archive/rotate themselves
-BUILD_DEPENDS= ${SITE_PERL}/Log/Dispatch.pm:${PORTSDIR}/devel/p5-Log-Dispatch \
- ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
+BUILD_DEPENDS= p5-Log-Dispatch>=0:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
- ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Module-Starter-PBP/Makefile b/devel/p5-Module-Starter-PBP/Makefile
index de8be0789d1c..46e2b7898538 100644
--- a/devel/p5-Module-Starter-PBP/Makefile
+++ b/devel/p5-Module-Starter-PBP/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Create a module as recommended in "Perl Best Practices"
-BUILD_DEPENDS= ${SITE_PERL}/Module/Starter.pm:${PORTSDIR}/devel/p5-Module-Starter \
- ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version
+BUILD_DEPENDS= p5-Module-Starter>=0:${PORTSDIR}/devel/p5-Module-Starter \
+ p5-version>=0:${PORTSDIR}/devel/p5-version
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Test-SubCalls/Makefile b/devel/p5-Test-SubCalls/Makefile
index e5cb9a96be9e..307aae76e090 100644
--- a/devel/p5-Test-SubCalls/Makefile
+++ b/devel/p5-Test-SubCalls/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Track the number of times subs are called
-BUILD_DEPENDS= ${SITE_PERL}/Hook/LexWrap.pm:${PORTSDIR}/devel/p5-Hook-LexWrap \
- ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= p5-Hook-LexWrap>=0:${PORTSDIR}/devel/p5-Hook-LexWrap \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Test-XML/Makefile b/devel/p5-Test-XML/Makefile
index 52499632e436..fe6206896bed 100644
--- a/devel/p5-Test-XML/Makefile
+++ b/devel/p5-Test-XML/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Compare XML in perl tests
-BUILD_DEPENDS= ${SITE_PERL}/XML/SemanticDiff.pm:${PORTSDIR}/textproc/p5-XML-SemanticDiff \
- ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= p5-XML-SemanticDiff>=0:${PORTSDIR}/textproc/p5-XML-SemanticDiff \
+ p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/games/p5-Games-Bingo-Bot/Makefile b/games/p5-Games-Bingo-Bot/Makefile
index 3ba7d2534963..0b7bbc1f68fc 100644
--- a/games/p5-Games-Bingo-Bot/Makefile
+++ b/games/p5-Games-Bingo-Bot/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= A simple class holding IRC related methods for bingo
-BUILD_DEPENDS= ${SITE_PERL}/Games/Bingo.pm:${PORTSDIR}/games/p5-Games-Bingo
+BUILD_DEPENDS= p5-Games-Bingo>=0:${PORTSDIR}/games/p5-Games-Bingo
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/games/p5-Games-Bingo-Print/Makefile b/games/p5-Games-Bingo-Print/Makefile
index be5ea64a06bb..8cd4dcb4be14 100644
--- a/games/p5-Games-Bingo-Print/Makefile
+++ b/games/p5-Games-Bingo-Print/Makefile
@@ -15,12 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Games::Bingo::Print - PDF Generation Class
-BUILD_DEPENDS= ${SITE_PERL}/Games/Bingo.pm:${PORTSDIR}/games/p5-Games-Bingo \
- ${SITE_PERL}/PDFLib.pm:${PORTSDIR}/print/p5-PDFLib \
- ${SITE_PERL}/TAP/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness \
- ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
- ${SITE_PERL}/Test/Perl/Critic.pm:${PORTSDIR}/textproc/p5-Test-Perl-Critic \
- ${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+BUILD_DEPENDS= p5-Games-Bingo>=0:${PORTSDIR}/games/p5-Games-Bingo \
+ p5-PDFLib>=0:${PORTSDIR}/print/p5-PDFLib \
+ p5-Test-Harness>=0:${PORTSDIR}/devel/p5-Test-Harness \
+ p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Perl-Critic>=0:${PORTSDIR}/textproc/p5-Test-Perl-Critic \
+ p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/mail/p5-Email-LocalDelivery-Ezmlm/Makefile b/mail/p5-Email-LocalDelivery-Ezmlm/Makefile
index 904a65850c45..8596b86a39c1 100644
--- a/mail/p5-Email-LocalDelivery-Ezmlm/Makefile
+++ b/mail/p5-Email-LocalDelivery-Ezmlm/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Deliver mail into ezmlm archives
-BUILD_DEPENDS= ${SITE_PERL}/Email/LocalDelivery.pm:${PORTSDIR}/mail/p5-Email-LocalDelivery \
- ${SITE_PERL}/Email/FolderType.pm:${PORTSDIR}/mail/p5-Email-FolderType
+BUILD_DEPENDS= p5-Email-LocalDelivery>=0:${PORTSDIR}/mail/p5-Email-LocalDelivery \
+ p5-Email-FolderType>=0:${PORTSDIR}/mail/p5-Email-FolderType
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/mail/p5-Net-IMAP-Simple-SSL/Makefile b/mail/p5-Net-IMAP-Simple-SSL/Makefile
index 0f1db0d16c5b..de671f26568f 100644
--- a/mail/p5-Net-IMAP-Simple-SSL/Makefile
+++ b/mail/p5-Net-IMAP-Simple-SSL/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= SSL support for Net::IMAP::Simple
-BUILD_DEPENDS= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
- ${SITE_PERL}/Net/IMAP/Simple.pm:${PORTSDIR}/mail/p5-Net-IMAP-Simple
+BUILD_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-Net-IMAP-Simple>=0:${PORTSDIR}/mail/p5-Net-IMAP-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/mail/p5-URI-imap/Makefile b/mail/p5-URI-imap/Makefile
index 4b72599c21df..ec854be2cfe6 100644
--- a/mail/p5-URI-imap/Makefile
+++ b/mail/p5-URI-imap/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= URI::imap - Support IMAP URI
-BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/mail/p5-URI-imaps/Makefile b/mail/p5-URI-imaps/Makefile
index 46235c78a05f..f59003cc0bc7 100644
--- a/mail/p5-URI-imaps/Makefile
+++ b/mail/p5-URI-imaps/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Support IMAPS URI
-BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net-mgmt/ifgraph/Makefile b/net-mgmt/ifgraph/Makefile
index 7f382359cded..ead8b294b74a 100644
--- a/net-mgmt/ifgraph/Makefile
+++ b/net-mgmt/ifgraph/Makefile
@@ -16,7 +16,7 @@ COMMENT= Simple grapher of SNMP data with RRD
RUN_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool \
p5-Color-Rgb>0:${PORTSDIR}/graphics/p5-Color-Rgb \
- ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net-mgmt/p5-Net-SNMP
+ p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP
BUILD_DEPENDS= ${RUN_DEPENDS}
USE_PERL5= yes
diff --git a/net-mgmt/p5-Net-SNMP/Makefile b/net-mgmt/p5-Net-SNMP/Makefile
index ef4eb41030ab..8a2712cc6c0e 100644
--- a/net-mgmt/p5-Net-SNMP/Makefile
+++ b/net-mgmt/p5-Net-SNMP/Makefile
@@ -18,7 +18,7 @@ COMMENT= Object oriented interface to SNMP
BUILD_DEPENDS= ${ARCH_PERL}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES \
${ARCH_PERL}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/Digest/HMAC.pm:${PORTSDIR}/security/p5-Digest-HMAC
+ p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/textproc/p5-Lingua-EN-Inflect-Number/Makefile b/textproc/p5-Lingua-EN-Inflect-Number/Makefile
index ef85c61c312f..8e5ecd16c212 100644
--- a/textproc/p5-Lingua-EN-Inflect-Number/Makefile
+++ b/textproc/p5-Lingua-EN-Inflect-Number/Makefile
@@ -13,7 +13,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Force number of words to singular or plural
-BUILD_DEPENDS= ${SITE_PERL}/Lingua/EN/Inflect.pm:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect
+BUILD_DEPENDS= p5-Lingua-EN-Inflect>=0:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/textproc/p5-Text-RecordParser/Makefile b/textproc/p5-Text-RecordParser/Makefile
index 784ac49f2ae0..4f47b7a69038 100644
--- a/textproc/p5-Text-RecordParser/Makefile
+++ b/textproc/p5-Text-RecordParser/Makefile
@@ -14,8 +14,8 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= lth@FreeBSD.org
COMMENT= Read record-oriented files
-BUILD_DEPENDS= ${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy \
- ${SITE_PERL}/Text/TabularDisplay.pm:${PORTSDIR}/textproc/p5-Text-TabularDisplay \
+BUILD_DEPENDS= p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy \
+ p5-Text-TabularDisplay>=0:${PORTSDIR}/textproc/p5-Text-TabularDisplay \
p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Readonly>=0:${PORTSDIR}/devel/p5-Readonly \
p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
diff --git a/www/p5-CGI-Ajax/Makefile b/www/p5-CGI-Ajax/Makefile
index c806e9e9deb5..04c8e6cc360e 100644
--- a/www/p5-CGI-Ajax/Makefile
+++ b/www/p5-CGI-Ajax/Makefile
@@ -15,7 +15,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C/0$//}
MAINTAINER= lth@FreeBSD.org
COMMENT= A module for writing AJAX/DHTML-based web apps
-BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-HTTP-Server-Simple-Static/Makefile b/www/p5-HTTP-Server-Simple-Static/Makefile
index b57e9224b2f7..71daa469032c 100644
--- a/www/p5-HTTP-Server-Simple-Static/Makefile
+++ b/www/p5-HTTP-Server-Simple-Static/Makefile
@@ -15,10 +15,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Serve static files with HTTP::Server::Simple
-RUN_DEPENDS= ${SITE_PERL}/HTTP/Server/Simple.pm:${PORTSDIR}/www/p5-HTTP-Server-Simple \
- ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/MIME/Types.pm:${PORTSDIR}/mail/p5-MIME-Types \
- ${SITE_PERL}/File/MMagic.pm:${PORTSDIR}/devel/p5-File-MMagic
+RUN_DEPENDS= p5-HTTP-Server-Simple>=0:${PORTSDIR}/www/p5-HTTP-Server-Simple \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-MIME-Types>=0:${PORTSDIR}/mail/p5-MIME-Types \
+ p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
diff --git a/www/p5-Template-Plugin-Class/Makefile b/www/p5-Template-Plugin-Class/Makefile
index 541394375d0e..c5c9b646acb6 100644
--- a/www/p5-Template-Plugin-Class/Makefile
+++ b/www/p5-Template-Plugin-Class/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Allow calling of class methods on arbitrary classes
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+BUILD_DEPENDS= p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-Template-Plugin-FillInForm/Makefile b/www/p5-Template-Plugin-FillInForm/Makefile
index 454efccf24d4..b6c16e61f6f8 100644
--- a/www/p5-Template-Plugin-FillInForm/Makefile
+++ b/www/p5-Template-Plugin-FillInForm/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Template::Plugin::FillInForm - TT plugin for HTML::FillInForm
-RUN_DEPENDS= ${SITE_PERL}/HTML/FillInForm.pm:${PORTSDIR}/www/p5-HTML-FillInForm \
- ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+RUN_DEPENDS= p5-HTML-FillInForm>=0:${PORTSDIR}/www/p5-HTML-FillInForm \
+ p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-Template-Timer/Makefile b/www/p5-Template-Timer/Makefile
index ec1b06596fa4..7cd78df1e8bd 100644
--- a/www/p5-Template-Timer/Makefile
+++ b/www/p5-Template-Timer/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Rudimentary profiling for Template Toolkit
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+BUILD_DEPENDS= p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes