aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Iterator-Util/Makefile30
-rw-r--r--devel/p5-Iterator-Util/distinfo3
-rw-r--r--devel/p5-Iterator-Util/pkg-descr10
-rw-r--r--devel/p5-Iterator-Util/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 26724f9ec29a..ef491aadf5c6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1009,6 +1009,7 @@
SUBDIR += p5-Inline-Tcl
SUBDIR += p5-Ioctl
SUBDIR += p5-Iterator
+ SUBDIR += p5-Iterator-Util
SUBDIR += p5-List-Cycle
SUBDIR += p5-List-Group
SUBDIR += p5-Locale-Maketext
diff --git a/devel/p5-Iterator-Util/Makefile b/devel/p5-Iterator-Util/Makefile
new file mode 100644
index 000000000000..ef4fa53601a5
--- /dev/null
+++ b/devel/p5-Iterator-Util/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Iterator-Util
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Iterator-Util
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Iterator
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Essential utilities for the Iterator class
+
+BUILD_DEPENDS= ${SITE_PERL}/Iterator.pm:${PORTSDIR}/devel/p5-Iterator
+
+MAN3= Iterator::Util.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl5.8 due to dependencies
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Iterator-Util/distinfo b/devel/p5-Iterator-Util/distinfo
new file mode 100644
index 000000000000..54fd3e1b8aaa
--- /dev/null
+++ b/devel/p5-Iterator-Util/distinfo
@@ -0,0 +1,3 @@
+MD5 (Iterator-Util-0.02.tar.gz) = 2b5f0c779c578e00e4d66613c051211f
+SHA256 (Iterator-Util-0.02.tar.gz) = 6182e488f1f1961d8653d6bb3ecb1222776ff2835b51ac120918c5238c1eb563
+SIZE (Iterator-Util-0.02.tar.gz) = 19976
diff --git a/devel/p5-Iterator-Util/pkg-descr b/devel/p5-Iterator-Util/pkg-descr
new file mode 100644
index 000000000000..c9aa69748be5
--- /dev/null
+++ b/devel/p5-Iterator-Util/pkg-descr
@@ -0,0 +1,10 @@
+This module implements many useful functions for creating and manipulating
+iterator objects.
+
+An "iterator" is an object, represented as a code block that generates the
+"next value" of a sequence, and generally implemented as a closure. For
+further information, including a tutorial on using iterator objects, see
+the Iterator documentation.
+
+WWW: http://search.cpan.org/dist/Iterator-DBI
+Author: Eric J. Roode <roode@cpan.org>
diff --git a/devel/p5-Iterator-Util/pkg-plist b/devel/p5-Iterator-Util/pkg-plist
new file mode 100644
index 000000000000..7890eea44a06
--- /dev/null
+++ b/devel/p5-Iterator-Util/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Iterator/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Iterator/Util/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Iterator/Util
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Iterator
+@dirrmtry %%SITE_PERL%%/Iterator