aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/git-cinnabar/Makefile2
-rw-r--r--devel/git-cinnabar/files/patch-git-2.3327
2 files changed, 28 insertions, 1 deletions
diff --git a/devel/git-cinnabar/Makefile b/devel/git-cinnabar/Makefile
index 156569027afe..e0c94286ab9f 100644
--- a/devel/git-cinnabar/Makefile
+++ b/devel/git-cinnabar/Makefile
@@ -1,6 +1,6 @@
PORTNAME= git-cinnabar
DISTVERSION= 0.5.7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
diff --git a/devel/git-cinnabar/files/patch-git-2.33 b/devel/git-cinnabar/files/patch-git-2.33
new file mode 100644
index 000000000000..469b600e802c
--- /dev/null
+++ b/devel/git-cinnabar/files/patch-git-2.33
@@ -0,0 +1,27 @@
+https://github.com/glandium/git-cinnabar/commit/ea33ee10ac39
+
+--- helper/GIT-VERSION.mk.orig 2021-03-31 21:58:42 UTC
++++ helper/GIT-VERSION.mk
+@@ -1,2 +1,2 @@
+-GIT_VERSION ?= v2.32.0
++GIT_VERSION ?= v2.33.0
+ WINDOWS_GIT_VERSION ?= $(GIT_VERSION).windows.1
+--- helper/csum-file.c.patch.orig 2021-03-31 21:58:42 UTC
++++ helper/csum-file.c.patch
+@@ -1,8 +1,8 @@
+ diff --git a/csum-file.c b/csum-file.c
+-index 7510950fa3..19d02e3a63 100644
++index c951cf8277..1215459b01 100644
+ --- a/csum-file.c
+ +++ b/csum-file.c
+-@@ -86,7 +86,7 @@ int finalize_hashfile(struct hashfile *f, unsigned char *result, unsigned int fl
++@@ -91,7 +91,7 @@ int finalize_hashfile(struct hashfile *f, unsigned char *result, unsigned int fl
+ return fd;
+ }
+
+@@ -10,4 +10,4 @@ index 7510950fa3..19d02e3a63 100644
+ +void real_hashwrite(struct hashfile *f, const void *buf, unsigned int count)
+ {
+ while (count) {
+- unsigned left = sizeof(f->buffer) - f->offset;
++ unsigned left = f->buffer_len - f->offset;